aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-08-04 16:12:52 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-08-04 16:12:52 +0000
commitf3d7902b767673c077c491f8708866a2ea738c27 (patch)
tree53a15505cb3c6857cfe9c59d8e7c363e64adaf62 /multimedia
parent061163d10479b754776987aadf4e5b52f238c7b7 (diff)
downloadports-f3d7902b767673c077c491f8708866a2ea738c27.tar.gz
ports-f3d7902b767673c077c491f8708866a2ea738c27.zip
Add patches from Ubuntu's launchpad to fix the plugins stability problem with
Firefox 3, bump the PORTREVISION. Obtained from: https://bugs.launchpad.net/ubuntu/+source/totem/+bug/131658 Reported by: a few Tested by: Joe Kelsey <joe@zircon.seattle.wa.us>
Notes
Notes: svn path=/head/; revision=218029
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/totem/Makefile2
-rw-r--r--multimedia/totem/files/patch-browser-plugin_totemClassInfo.h45
-rw-r--r--multimedia/totem/files/patch-configure12
3 files changed, 58 insertions, 1 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 0d21ee8369f0..a317cbda8877 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -8,7 +8,7 @@
PORTNAME= totem
PORTVERSION= 2.22.2
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/multimedia/totem/files/patch-browser-plugin_totemClassInfo.h b/multimedia/totem/files/patch-browser-plugin_totemClassInfo.h
new file mode 100644
index 000000000000..e4f8e650ed7b
--- /dev/null
+++ b/multimedia/totem/files/patch-browser-plugin_totemClassInfo.h
@@ -0,0 +1,45 @@
+--- browser-plugin/totemClassInfo.h.orig 2007-08-09 17:32:58.000000000 +0000
++++ browser-plugin/totemClassInfo.h 2007-08-09 17:55:50.000000000 +0000
+@@ -47,10 +47,10 @@
+ NS_IMETHODIMP _class::GetClassDescription(char * *aClassDescription)\
+ {\
+ *aClassDescription = static_cast<char*>(\
+- nsMemory::Clone (_description,\
+- sizeof (_description)));\
++ nsMemory::Alloc (sizeof (_description) + 1));\
+ if (!*aClassDescription)\
+ return NS_ERROR_OUT_OF_MEMORY;\
++ strcpy(*aClassDescription, _description);\
+ \
+ return NS_OK;\
+ }\
+@@ -59,10 +59,10 @@
+ NS_IMETHODIMP _class::GetClassID(nsCID * *aClassID)\
+ {\
+ *aClassID = static_cast<nsCID*>(\
+- nsMemory::Clone (&_cid,\
+- sizeof (nsCID*)));\
++ nsMemory::Alloc (sizeof (nsCID*) + 1));\
+ if (!*aClassID)\
+ return NS_ERROR_OUT_OF_MEMORY;\
++ memcpy(*aClassID, &_cid, sizeof (nsCID*));\
+ \
+ return NS_OK;\
+ }\
+@@ -99,13 +99,12 @@
+
+ #define TOTEM_CLASSINFO_ENTRY(_i, _interface)\
+ (*array)[_i] = static_cast<nsIID*>(\
+- nsMemory::Clone(&NS_GET_IID(_interface),\
+- sizeof(nsIID)));\
++ nsMemory::Alloc(sizeof(nsIID) + 1));\
+ if (!(*array)[_i]) {\
+ NS_FREE_XPCOM_ALLOCATED_POINTER_ARRAY (_i, *array);\
+ return NS_ERROR_OUT_OF_MEMORY;\
+- }
+-
++ }\
++ memcpy((*array)[_i], &NS_GET_IID(_interface), sizeof(nsIID));
+
+ #define TOTEM_CLASSINFO_END \
+ return NS_OK;\
diff --git a/multimedia/totem/files/patch-configure b/multimedia/totem/files/patch-configure
new file mode 100644
index 000000000000..67b99d2287b5
--- /dev/null
+++ b/multimedia/totem/files/patch-configure
@@ -0,0 +1,12 @@
+--- configure.orig 2008-08-02 00:06:51.000000000 -0500
++++ configure 2008-08-02 00:09:01.000000000 -0500
+@@ -25298,8 +25298,7 @@
+ if test "$have_libxpcomglue_s" = "yes"; then
+ LIBXPCOMGLUE_S="-L$MOZILLA_LIBDIR -lxpcomglue_s"
+ else
+- { echo "$as_me:$LINENO: WARNING: libxpcomglue_s not available; plugins may not be portable" >&5
+-echo "$as_me: WARNING: libxpcomglue_s not available; plugins may not be portable" >&2;}
++ LIBXPCOMGLUE_S=`$PKG_CONFIG --libs $MOZILLA-xpcom`
+ fi
+ fi
+