aboutsummaryrefslogtreecommitdiff
path: root/net-im/conduit
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-10-07 14:47:27 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-10-25 08:49:12 +0000
commitf5a860a89662f0f18da2d67d09a305e7a6bdece1 (patch)
treee462004e361ce5dad727b2bd91b4d2208869de08 /net-im/conduit
parentc9d85f0d9ca12976d76cad14dcbf24e3acba1ec0 (diff)
downloadports-f5a860a89662f0f18da2d67d09a305e7a6bdece1.tar.gz
ports-f5a860a89662f0f18da2d67d09a305e7a6bdece1.zip
net-im/conduit: Chase USES=cargo's new git source support
PR: 256581
Diffstat (limited to 'net-im/conduit')
-rw-r--r--net-im/conduit/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/net-im/conduit/Makefile b/net-im/conduit/Makefile
index 2e753f3d898a..1fac9946cad3 100644
--- a/net-im/conduit/Makefile
+++ b/net-im/conduit/Makefile
@@ -27,8 +27,6 @@ DBDIR= /var/db/${PORTNAME}
USE_GITLAB= yes
GL_ACCOUNT= famedly
GL_COMMIT= 0d6ae2e1e74ee33fbc8dfcec01a8902e0a4d65d3
-USE_GITHUB= nodefault
-GH_TUPLE= timokoesters:heed:f6f825da7fb2c758867e05ad973ef800a6fe1d5d:heed
CARGO_CRATES= adler32-1.2.0 \
ahash-0.7.4 \
aho-corasick-0.7.18 \
@@ -361,12 +359,10 @@ CARGO_CRATES= adler32-1.2.0 \
zeroize_derive-1.1.0 \
zstd-0.5.4+zstd.1.4.7 \
zstd-safe-2.0.6+zstd.1.4.7 \
- zstd-sys-1.4.18+zstd.1.4.7
-CARGO_USE_GITHUB= yes
+ zstd-sys-1.4.18+zstd.1.4.7 \
+ heed,heed-traits,heed-types@git+https://github.com/timokoesters/heed.git?rev=f6f825da7fb2c758867e05ad973ef800a6fe1d5d\#f6f825da7fb2c758867e05ad973ef800a6fe1d5d
post-patch:
- @${REINPLACE_CMD} -E -e '/^heed = /s,(path = "[^"]+),\1/heed,' \
- ${CARGO_CARGOTOML}
@${REINPLACE_CMD} -e 's,/etc/conduit.toml,${PREFIX}/etc/conduit.toml,' \
${WRKSRC}/src/main.rs
@${REINPLACE_CMD} -e 's,/var/lib/conduit,${DBDIR},' \