aboutsummaryrefslogtreecommitdiff
path: root/net-im/coyim/Makefile
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2019-04-26 11:12:43 +0000
committerPhilip Paeps <philip@FreeBSD.org>2019-04-26 11:12:43 +0000
commit33547fe71740c648288a8aed5cae9d76ae1e6c05 (patch)
tree5f317c6dacb020818779aca2f837a3a0fe3abead /net-im/coyim/Makefile
parentf21c6e8d9cf6a718732994f892bbc9d040d006ec (diff)
downloadports-33547fe71740c648288a8aed5cae9d76ae1e6c05.tar.gz
ports-33547fe71740c648288a8aed5cae9d76ae1e6c05.zip
Add net-im/coyim 0.3.11
Safe and secure by default chat client CoyIM is a chat client that is safe and secure by default: no settings to change, no plugins to install, no computer configuration to change. WWW: https://coy.im PR: 237542 Submitted by: Santhosh Raju <santhosh.raju@gmail.com>
Notes
Notes: svn path=/head/; revision=500099
Diffstat (limited to 'net-im/coyim/Makefile')
-rw-r--r--net-im/coyim/Makefile63
1 files changed, 63 insertions, 0 deletions
diff --git a/net-im/coyim/Makefile b/net-im/coyim/Makefile
new file mode 100644
index 000000000000..941a17fd3dd8
--- /dev/null
+++ b/net-im/coyim/Makefile
@@ -0,0 +1,63 @@
+# $FreeBSD$
+
+PORTNAME= coyim
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.11
+CATEGORIES= net-im
+
+MAINTAINER= support@coy.im
+COMMENT= Safe and secure by default chat client
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= go:lang/go
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= gnome pkgconfig
+
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 pango
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+USE_GITHUB= yes
+GH_ACCOUNT= coyim
+GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${PORTNAME}
+
+SUB_LIST= PORTNAME=${PORTNAME}
+
+PLIST_FILES= bin/coyim \
+ share/applications/coyim.desktop \
+ share/pixmaps/coyim.png
+
+GTK_BUILD_TAG= "$$(pkg-config --modversion gtk+-3.0 | ${TR} . _ | cut -d '_' -f 1-2)"
+
+COYIM_ICON= coyim.png
+COYIM_ICON_SRC= ${WRKSRC}/build/mac-bundle/coy.iconset/icon_32x32@2x.png
+COYIM_DESKTOP= ${WRKSRC}/build/coyim.desktop
+
+INSTALLATION_DIRS+= share/applications share/pixmaps
+
+do-build:
+ cd ${WRKSRC}/${GH_SUBDIR} && \
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} \
+ go build -tags ${GTK_BUILD_TAG} -o ${PORTNAME}
+
+post-build:
+ @${REINPLACE_CMD} -e '/^#/d' \
+ -e '/^$$/d' \
+ ${COYIM_DESKTOP}
+ ${ECHO} "Exec=${PREFIX}/bin/coyim" >> ${COYIM_DESKTOP}
+ ${ECHO} "Icon=${COYIM_ICON}" >> ${COYIM_DESKTOP}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${COYIM_DESKTOP} ${STAGEDIR}${PREFIX}/share/applications/
+ ${INSTALL_DATA} ${COYIM_ICON_SRC} ${STAGEDIR}${PREFIX}/share/pixmaps/${COYIM_ICON}
+
+.include <bsd.port.mk>