aboutsummaryrefslogtreecommitdiff
path: root/net-im/ejabberd
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2015-06-29 04:45:14 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2015-06-29 04:45:14 +0000
commit8c98e280f620fc89931913e8a99ef262f56d26a8 (patch)
tree2e73c3588eb34420da1265a8acba50ae6c1e12c9 /net-im/ejabberd
parentffcef0d26bad373cc407d7b9a6e3f7eb92c909d1 (diff)
downloadports-8c98e280f620fc89931913e8a99ef262f56d26a8.tar.gz
ports-8c98e280f620fc89931913e8a99ef262f56d26a8.zip
- Update to 15.06
- Switch to new dependencies tarball - Add OPTIONs for REDIS, SQLITE, and TOOLS - Update diff for dict:dict() stuff in Erlang R17+ - Add diff for Erlang R18 support[1] Submitted by: olgeni[1] (via private mail)
Notes
Notes: svn path=/head/; revision=390878
Diffstat (limited to 'net-im/ejabberd')
-rw-r--r--net-im/ejabberd/Makefile12
-rw-r--r--net-im/ejabberd/distinfo8
-rw-r--r--net-im/ejabberd/files/patch-ejabberdctl.template10
-rw-r--r--net-im/ejabberd/files/patch-erlang-17-dict-queue199
-rw-r--r--net-im/ejabberd/files/patch-erlang-18209
-rw-r--r--net-im/ejabberd/pkg-plist34
6 files changed, 357 insertions, 115 deletions
diff --git a/net-im/ejabberd/Makefile b/net-im/ejabberd/Makefile
index 051385e5898b..5f978cda772f 100644
--- a/net-im/ejabberd/Makefile
+++ b/net-im/ejabberd/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= ejabberd
-PORTVERSION= 15.04
-PORTREVISION= 1
+PORTVERSION= 15.06
CATEGORIES= net-im
MASTER_SITES= http://www.process-one.net/downloads/${PORTNAME}/${PORTVERSION}/:p1 \
http://distfiles.pirateparty.in/ashish/:deps \
LOCAL/ashish:deps
-DISTFILES+= ${DISTNAME}.tgz:p1 ejabberd-deps-2.tar.xz:deps
+DISTFILES+= ${DISTNAME}.tgz:p1 ejabberd-deps-3.tar.xz:deps
MAINTAINER= ashish@FreeBSD.org
COMMENT= Free and Open Source distributed fault-tolerant Jabber server
@@ -31,7 +30,7 @@ USE_RC_SUBR= ${PORTNAME}
NOPRECIOUSMAKEVARS= yes
CPE_VENDOR= process-one
-OPTIONS_DEFINE= ODBC PAM DOCS JSON MYSQL PGSQL LAGER ICONV RIAK
+OPTIONS_DEFINE= ODBC PAM DOCS JSON MYSQL PGSQL LAGER ICONV RIAK REDIS SQLITE TOOLS
OPTIONS_DEFAULT= LAGER ICONV
MAKE_ENV= PORTVERSION=${PORTVERSION}
@@ -51,6 +50,7 @@ SUB_LIST= PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION} \
OPTIONS_SUB= yes
LAGER_DESC= LAGER logger
RIAK_DESC= Riak database support
+TOOLS_DESC= Build development tools
PAM_CONFIGURE_ENABLE= pam
ODBC_CONFIGURE_ENABLE= odbc
LAGER_CONFIGURE_ENABLE= lager
@@ -59,6 +59,10 @@ MYSQL_CONFIGURE_ENABLE= mysql
PGSQL_CONFIGURE_ENABLE= pgsql
RIAK_CONFIGURE_ENABLE= riak
ICONV_CONFIGURE_ENABLE= iconv
+REDIS_CONFIGURE_ENABLE= redis
+SQLITE_CONFIGURE_ENABLE=sqlite
+TOOS_CONFIGURE_ENABLE= tools
+SQLITE_USE= SQLITE=yes
ICONV_USES= iconv:wchar_t
ICONV_LDFLAGS= ${ICONV_LIB}
DOCS_MAKE_ARGS_OFF= NOPORTDOCS=yes
diff --git a/net-im/ejabberd/distinfo b/net-im/ejabberd/distinfo
index cbae46f6a1fb..8c68bbda0926 100644
--- a/net-im/ejabberd/distinfo
+++ b/net-im/ejabberd/distinfo
@@ -1,4 +1,4 @@
-SHA256 (ejabberd-15.04.tgz) = 6750199b75d6b658dabffdf34e20994803b2fc0832e54fea7ab388e5122d63ec
-SIZE (ejabberd-15.04.tgz) = 3261947
-SHA256 (ejabberd-deps-2.tar.xz) = 0f5604c0ce40c499f082170b457c4238fac570df71b4b03b9d5fa525abb15847
-SIZE (ejabberd-deps-2.tar.xz) = 12475132
+SHA256 (ejabberd-15.06.tgz) = fcc001d0f2fc8b99bb2a4e7a42ec02c3c5d62191ea2aae19636f88e4e08be3a8
+SIZE (ejabberd-15.06.tgz) = 1560640
+SHA256 (ejabberd-deps-3.tar.xz) = 29c3e3d0841d55543a62c74cfc041ab88751f0d9168cc3b9253b5a95611cb842
+SIZE (ejabberd-deps-3.tar.xz) = 18697860
diff --git a/net-im/ejabberd/files/patch-ejabberdctl.template b/net-im/ejabberd/files/patch-ejabberdctl.template
index 27ebcccc5565..29575df21b39 100644
--- a/net-im/ejabberd/files/patch-ejabberdctl.template
+++ b/net-im/ejabberd/files/patch-ejabberdctl.template
@@ -3,7 +3,7 @@ $FreeBSD$
--- ejabberdctl.template.orig
+++ ejabberdctl.template
-@@ -72,10 +72,10 @@
+@@ -71,10 +71,10 @@
EJABBERD_CONFIG_PATH=$ETC_DIR/ejabberd.yml
fi
if [ "$LOGS_DIR" = "" ] ; then
@@ -16,7 +16,7 @@ $FreeBSD$
fi
if [ "$EJABBERD_DOC_PATH" = "" ] ; then
EJABBERD_DOC_PATH={{docdir}}
-@@ -89,10 +89,10 @@
+@@ -88,10 +88,10 @@
EJABBERDDIR={{libdir}}/ejabberd
fi
if [ "$EJABBERD_EBIN_PATH" = "" ] ; then
@@ -29,12 +29,12 @@ $FreeBSD$
fi
if [ "$EJABBERD_BIN_PATH" = "" ] ; then
EJABBERD_BIN_PATH=$EJABBERD_PRIV_PATH/bin
-@@ -279,7 +279,7 @@
+@@ -335,7 +335,7 @@
# using flock if available. Expects a linux-style
# flock that can lock a file descriptor.
MAXCONNID=100
- CONNLOCKDIR={{localstatedir}}/lock/ejabberdctl
+ CONNLOCKDIR={{localstatedir}}/run/ejabberdctl
- FLOCK='/usr/bin/flock'
+ FLOCK=/usr/bin/flock
if [ ! -x "$FLOCK" ] || [ ! -d "$CONNLOCKDIR" ] ; then
- JOT='/usr/bin/jot'
+ JOT=/usr/bin/jot
diff --git a/net-im/ejabberd/files/patch-erlang-17-dict-queue b/net-im/ejabberd/files/patch-erlang-17-dict-queue
index 00d21ba63682..5f67b39599f4 100644
--- a/net-im/ejabberd/files/patch-erlang-17-dict-queue
+++ b/net-im/ejabberd/files/patch-erlang-17-dict-queue
@@ -2,116 +2,136 @@ $FreeBSD$
Fixes to make it work with Erlang R17
---- ../deps/meck/rebar.config.orig
-+++ ../deps/meck/rebar.config
-@@ -1,4 +1,6 @@
--{erl_opts, [warnings_as_errors, debug_info]}.
-+{erl_opts, [
-+ {platform_define, "^17-", 'ERLANG_17'},
-+ warnings_as_errors, debug_info]}.
- {xref_checks, [undefined_function_calls]}.
- {dialyzer_opts, [{warnings, [unmatched_returns]}]}.
-
---- ../deps/meck/src/meck_proc.erl.orig
-+++ ../deps/meck/src/meck_proc.erl
-@@ -46,6 +46,17 @@
- %%% Definitions
- %%%============================================================================
+
+$FreeBSD$
+
+--- ../deps/riak_pb/src/riak_pb_kv_codec.erl.orig
++++ ../deps/riak_pb/src/riak_pb_kv_codec.erl
+@@ -49,7 +49,11 @@
+ -type symbolic_quorum() :: one | quorum | all | default.
+ -type value() :: binary().
+-ifdef(ERLANG_17).
-+-record(state, {mod :: atom(),
-+ can_expect :: any | [{Mod::atom(), Ari::byte()}],
-+ expects :: dict:dict(),
-+ valid = true :: boolean(),
-+ history = [] :: meck_history:history() | undefined,
-+ original :: term(),
-+ was_sticky = false :: boolean(),
-+ reload :: {Compiler::pid(), {From::pid(), Tag::any()}} |
-+ undefined}).
++-type metadata() :: dict:dict().
+-else.
- -record(state, {mod :: atom(),
- can_expect :: any | [{Mod::atom(), Ari::byte()}],
- expects :: dict(),
-@@ -55,6 +66,7 @@
- was_sticky = false :: boolean(),
- reload :: {Compiler::pid(), {From::pid(), Tag::any()}} |
- undefined}).
+ -type metadata() :: dict().
+-endif.
+ -type contents() :: [{metadata(), value()}].
+ %% @doc Convert a list of object {MetaData,Value} pairs to protocol
+
+$FreeBSD$
+
+--- ../deps/riak_pb/rebar.config.orig
++++ ../deps/riak_pb/rebar.config
+@@ -1,5 +1,5 @@
+ %% -*- mode: erlang -*-
+-{erl_opts, [debug_info]}.
++{erl_opts, [{platform_define, "^1[78]-", 'ERLANG_17'},debug_info]}.
+ {deps, [
+ {protobuffs, "0.8.1", {git, "git://github.com/basho/erlang_protobuffs.git", {tag, "0.8.1p1"}}}
+ ]}.
+
+$FreeBSD$
+
+--- ../deps/esip/src/esip_listener.erl.orig
++++ ../deps/esip/src/esip_listener.erl
+@@ -37,7 +37,11 @@
- %%%============================================================================
-@@ -340,9 +352,17 @@
- end.
-
-
+ -include("esip_lib.hrl").
+ -define(TCP_SEND_TIMEOUT, 10000).
+-ifdef(ERLANG_17).
-+-spec init_expects(Exports::[meck_expect:func_ari()] | undefined,
-+ Options::[proplists:property()]) ->
-+ dict:dict().
++-record(state, {listeners = dict:new() :: dict:dict()}).
+-else.
- -spec init_expects(Exports::[meck_expect:func_ari()] | undefined,
- Options::[proplists:property()]) ->
- dict().
+ -record(state, {listeners = dict:new() :: dict()}).
+-endif.
-+
-+
- init_expects(Exports, Options) ->
- Passthrough = proplists:get_bool(passthrough, Options),
- StubAll = proplists:is_defined(stub_all, Options),
-@@ -379,8 +399,13 @@
- erlang:error(concurrent_reload).
+ %%%===================================================================
+ %%% API
+
+$FreeBSD$
+
+--- ../deps/esip/rebar.config.orig
++++ ../deps/esip/rebar.config
+@@ -1,4 +1,5 @@
+-{erl_opts, [{i, "include"},
++{erl_opts, [{platform_define, "^1[78]-", 'ERLANG_17'},
++ {i, "include"},
+ {i, "deps/p1_stun/include"},
+ {i, "../p1_stun/include"}]}.
-+-ifdef(ERLANG_17).
-+-spec do_get_result_spec(Expects::dict:dict(), Func::atom(), Args::[any()]) ->
-+ {meck_ret_spec:result_spec() | undefined, NewExpects::dict:dict()}.
-+-else.
- -spec do_get_result_spec(Expects::dict(), Func::atom(), Args::[any()]) ->
- {meck_ret_spec:result_spec() | undefined, NewExpects::dict()}.
-+-endif.
- do_get_result_spec(Expects, Func, Args) ->
- FuncAri = {Func, erlang:length(Args)},
- Clauses = dict:fetch(FuncAri, Expects),
-@@ -411,23 +436,39 @@
- end.
+
+$FreeBSD$
+
+--- ../deps/p1_stun/src/turn.erl.orig
++++ ../deps/p1_stun/src/turn.erl
+@@ -56,6 +56,29 @@
+ -type addr() :: {inet:ip_address(), inet:port_number()}.
+-ifdef(ERLANG_17).
-+-spec store_expect(Mod::atom(), meck_expect:func_ari(),
-+ meck_expect:expect(), Expects::dict:dict()) ->
-+ {NewExpects::dict:dict(), CompilerPid::pid()}.
++-record(state,
++ {sock_mod = gen_udp :: gen_udp | gen_tcp | p1_tls,
++ sock :: inet:socket() | p1_tls:tls_socket(),
++ addr = {{0,0,0,0}, 0} :: addr(),
++ owner = self() :: pid(),
++ username = <<"">> :: binary(),
++ realm = <<"">> :: binary(),
++ key = {<<"">>, <<"">>, <<"">>} :: {binary(), binary(), binary()},
++ server_name = <<"">> :: binary(),
++ permissions = ?DICT:new() :: dict:dict(),
++ channels = ?DICT:new() :: dict:dict(),
++ max_permissions :: non_neg_integer() | atom(),
++ relay_ip = {127,0,0,1} :: inet:ip_address(),
++ min_port = 49152 :: non_neg_integer(),
++ max_port = 65535 :: non_neg_integer(),
++ relay_addr :: addr(),
++ relay_sock :: inet:socket(),
++ last_trid :: non_neg_integer(),
++ last_pkt = <<>> :: binary(),
++ seq = 1 :: non_neg_integer(),
++ life_timer :: reference()}).
+-else.
- -spec store_expect(Mod::atom(), meck_expect:func_ari(),
- [meck_expect:func_clause()], Expects::dict()) ->
- {NewExpects::dict(), CompilerPid::pid()}.
+ -record(state,
+ {sock_mod = gen_udp :: gen_udp | gen_tcp | p1_tls,
+ sock :: inet:socket() | p1_tls:tls_socket(),
+@@ -77,6 +100,7 @@
+ last_pkt = <<>> :: binary(),
+ seq = 1 :: non_neg_integer(),
+ life_timer :: reference()}).
+-endif.
- store_expect(Mod, FuncAri, Clauses, Expects) ->
- NewExpects = dict:store(FuncAri, Clauses, Expects),
- compile_expects(Mod, NewExpects).
+ %%====================================================================
+ %% API
+
+$FreeBSD$
+
+--- ../deps/p1_stun/rebar.config.orig
++++ ../deps/p1_stun/rebar.config
+@@ -1,4 +1,5 @@
+-{erl_opts, [debug_info, {i, "include"}]}.
++{erl_opts, [{platform_define, "^1[78]-", 'ERLANG_17'},
++ debug_info, {i, "include"}]}.
+
+ {deps, [{p1_tls, ".*", {git, "git://github.com/processone/tls.git"}},
+ {p1_utils, ".*", {git, "git://github.com/processone/p1_utils.git"}}]}.
+
+$FreeBSD$
+
+--- ../deps/p1_stun/src/stun_listener.erl.orig
++++ ../deps/p1_stun/src/stun_listener.erl
+@@ -36,7 +36,11 @@
+ terminate/2, code_change/3]).
+ -define(TCP_SEND_TIMEOUT, 10000).
+-ifdef(ERLANG_17).
-+-spec do_delete_expect(Mod::atom(), meck_expect:func_ari(), Expects::dict:dict()) ->
-+ {NewExpects::dict:dict(), CompilerPid::pid()}.
++-record(state, {listeners = dict:new() :: dict:dict()}).
+-else.
- -spec do_delete_expect(Mod::atom(), meck_expect:func_ari(), Expects::dict()) ->
- {NewExpects::dict(), CompilerPid::pid()}.
+ -record(state, {listeners = dict:new() :: dict()}).
+-endif.
- do_delete_expect(Mod, FuncAri, Expects) ->
- NewExpects = dict:erase(FuncAri, Expects),
- compile_expects(Mod, NewExpects).
-
-+-ifdef(ERLANG_17).
-+-spec compile_expects(Mod::atom(), Expects::dict:dict()) ->
-+ {NewExpects::dict:dict(), CompilerPid::pid()}.
-+-else.
- -spec compile_expects(Mod::atom(), Expects::dict()) ->
- {NewExpects::dict(), CompilerPid::pid()}.
-+-endif.
- compile_expects(Mod, Expects) ->
- %% If the recompilation is made by the server that executes a module
- %% no module that is called from meck_code:compile_and_load_forms/2
+ %%%===================================================================
+ %%% API
--- ../deps/riakc/rebar.config.orig
+++ ../deps/riakc/rebar.config
@@ -1,6 +1,8 @@
@@ -119,7 +139,7 @@ Fixes to make it work with Erlang R17
{eunit_opts, [verbose]}.
-{erl_opts, [warnings_as_errors, debug_info]}.
+{erl_opts, [
-+ {platform_define, "^17-", 'ERLANG_17'},
++ {platform_define, "^1[78]-", 'ERLANG_17'},
+ warnings_as_errors, debug_info]}.
{deps, [
{riak_pb, ".*", {git, "git://github.com/basho/riak_pb", {tag, "1.4.4.0"}}}
@@ -206,3 +226,4 @@ Fixes to make it work with Erlang R17
%% @doc Create a linked process to talk with the riak server on Address:Port
%% Client id will be assigned by the server.
+
diff --git a/net-im/ejabberd/files/patch-erlang-18 b/net-im/ejabberd/files/patch-erlang-18
new file mode 100644
index 000000000000..93f67663326d
--- /dev/null
+++ b/net-im/ejabberd/files/patch-erlang-18
@@ -0,0 +1,209 @@
+diff -ruN --exclude '*.orig' ../deps/esip/src/esip.erl ../deps/esip/src/esip.erl
+--- ../deps/esip/src/esip.erl 2015-01-14 12:52:19.000000000 +0100
++++ ../deps/esip/src/esip.erl 2015-06-25 10:20:59.000000000 +0200
+@@ -739,7 +739,7 @@
+ %% gen_server callbacks
+ %%====================================================================
+ init([]) ->
+- {A, B, C} = now(),
++ {A, B, C} = erlang:timestamp(),
+ random:seed(A, B, C),
+ ets:new(esip_config, [named_table, public]),
+ set_config([]),
+diff -ruN --exclude '*.orig' ../deps/esip/src/esip_codec.erl ../deps/esip/src/esip_codec.erl
+--- ../deps/esip/src/esip_codec.erl 2015-01-14 12:52:19.000000000 +0100
++++ ../deps/esip/src/esip_codec.erl 2015-06-25 10:21:17.000000000 +0200
+@@ -1334,10 +1334,10 @@
+ io:format("~n== Estimate: ~p~n", [T div N]).
+
+ test_loop(P, Msg, N) ->
+- test_loop(P, Msg, N, now()).
++ test_loop(P, Msg, N, erlang:timestamp()).
+
+ test_loop(P, _, 0, T) ->
+- P ! {ok, timer:now_diff(now(), T)};
++ P ! {ok, timer:now_diff(erlang:timestamp(), T)};
+ test_loop(P, Msg, N, T) ->
+ decode(Msg),
+ test_loop(P, Msg, N-1, T).
+diff -ruN --exclude '*.orig' ../deps/esip/src/esip_transaction.erl ../deps/esip/src/esip_transaction.erl
+--- ../deps/esip/src/esip_transaction.erl 2015-01-14 12:52:19.000000000 +0100
++++ ../deps/esip/src/esip_transaction.erl 2015-06-25 10:20:38.000000000 +0200
+@@ -205,9 +205,9 @@
+ maybe_report_error(Type, N) ->
+ case ets:lookup(?MODULE, {last_error_report, Type}) of
+ [{_, Now}] ->
+- case timer:now_diff(now(), Now) of
++ case timer:now_diff(erlang:timestamp(), Now) of
+ T when T > 60000000 ->
+- ets:insert(?MODULE, {{last_error_report, Type}, now()}),
++ ets:insert(?MODULE, {{last_error_report, Type}, erlang:timestamp()}),
+ ?ERROR_MSG("too many ~s transactions: ~p", [Type, N]);
+ _ ->
+ ok
+diff -ruN --exclude '*.orig' ../deps/p1_cache_tab/src/cache_tab.erl ../deps/p1_cache_tab/src/cache_tab.erl
+--- ../deps/p1_cache_tab/src/cache_tab.erl 2015-01-14 12:52:24.000000000 +0100
++++ ../deps/p1_cache_tab/src/cache_tab.erl 2015-06-25 10:22:59.000000000 +0200
+@@ -405,7 +405,7 @@
+ [get_proc(Tab, N) || N <- lists:seq(1, get_proc_num())].
+
+ now_priority() ->
+- {MSec, Sec, USec} = now(),
++ {MSec, Sec, USec} = erlang:timestamp(),
+ -((MSec*1000000 + Sec)*1000000 + USec).
+
+ clean_priority(LifeTime) ->
+@@ -594,20 +594,20 @@
+ test3(Iter) ->
+ ok = new(test_tbl, [{max_size, unlimited}, {life_time, unlimited}]),
+ L = lists:seq(1, Iter),
+- T1 = now(),
++ T1 = erlang:timestamp(),
+ lists:foreach(
+ fun(N) ->
+ ok = ?insert(test_tbl, N, N, fun() -> ok end)
+ end, L),
+ io:format("** average insert (size = ~p): ~p usec~n",
+- [Iter, round(timer:now_diff(now(), T1)/Iter)]),
+- T2 = now(),
++ [Iter, round(timer:now_diff(erlang:timestamp(), T1)/Iter)]),
++ T2 = erlang:timestamp(),
+ lists:foreach(
+ fun(N) ->
+ {ok, N} = ?lookup(test_tbl, N, fun() -> ok end)
+ end, L),
+ io:format("** average lookup (size = ~p): ~p usec~n",
+- [Iter, round(timer:now_diff(now(), T2)/Iter)]),
++ [Iter, round(timer:now_diff(erlang:timestamp(), T2)/Iter)]),
+ {ok, Iter} = info(test_tbl, size),
+ delete(test_tbl).
+
+diff -ruN --exclude '*.orig' ../deps/p1_stun/src/stun.erl ../deps/p1_stun/src/stun.erl
+--- ../deps/p1_stun/src/stun.erl 2015-01-14 12:52:02.000000000 +0100
++++ ../deps/p1_stun/src/stun.erl 2015-06-25 10:22:10.000000000 +0200
+@@ -583,7 +583,7 @@
+ end.
+
+ now_priority() ->
+- {MSec, Sec, USec} = now(),
++ {MSec, Sec, USec} = erlang:timestamp(),
+ -((MSec*1000000 + Sec)*1000000 + USec).
+
+ clean_treap(Treap, CleanPriority) ->
+@@ -647,7 +647,7 @@
+ {ok, Sock}.
+
+ seed() ->
+- {A, B, C} = now(),
++ {A, B, C} = erlang:timestamp(),
+ random:seed(A, B, C).
+
+ prepare_response(State, Msg) ->
+diff -ruN --exclude '*.orig' ../deps/p1_stun/src/stun_shaper.erl ../deps/p1_stun/src/stun_shaper.erl
+--- ../deps/p1_stun/src/stun_shaper.erl 2014-05-19 04:09:58.000000000 +0200
++++ ../deps/p1_stun/src/stun_shaper.erl 2015-06-25 10:21:53.000000000 +0200
+@@ -46,7 +46,7 @@
+ new(none) -> none;
+ new(MaxRate) when is_integer(MaxRate) ->
+ #maxrate{maxrate = MaxRate, lastrate = 0.0,
+- lasttime = now_to_usec(now())}.
++ lasttime = now_to_usec(erlang:timestamp())}.
+
+ -spec update(shaper(), integer()) -> {shaper(), integer()}.
+
+@@ -54,13 +54,13 @@
+ update(#maxrate{} = State, Size) ->
+ MinInterv = 1000 * Size /
+ (2 * State#maxrate.maxrate - State#maxrate.lastrate),
+- Interv = (now_to_usec(now()) - State#maxrate.lasttime) /
++ Interv = (now_to_usec(erlang:timestamp()) - State#maxrate.lasttime) /
+ 1000,
+ Pause = if MinInterv > Interv ->
+ 1 + trunc(MinInterv - Interv);
+ true -> 0
+ end,
+- NextNow = now_to_usec(now()) + Pause * 1000,
++ NextNow = now_to_usec(erlang:timestamp()) + Pause * 1000,
+ {State#maxrate{lastrate =
+ (State#maxrate.lastrate +
+ 1000000 * Size / (NextNow - State#maxrate.lasttime))
+diff -ruN --exclude '*.orig' ../deps/p1_stun/src/stun_test.erl ../deps/p1_stun/src/stun_test.erl
+--- ../deps/p1_stun/src/stun_test.erl 2014-05-19 04:09:58.000000000 +0200
++++ ../deps/p1_stun/src/stun_test.erl 2015-06-25 10:21:35.000000000 +0200
+@@ -356,7 +356,7 @@
+ end.
+
+ mk_trid() ->
+- {A, B, C} = now(),
++ {A, B, C} = erlang:timestamp(),
+ random:seed(A, B, C),
+ random:uniform(1 bsl 96).
+
+diff -ruN --exclude '*.orig' ../deps/p1_stun/src/turn.erl ../deps/p1_stun/src/turn.erl
+--- ../deps/p1_stun/src/turn.erl 2014-05-19 04:09:58.000000000 +0200
++++ ../deps/p1_stun/src/turn.erl 2015-06-25 10:16:52.000000000 +0200
+@@ -64,8 +64,8 @@
+ realm = <<"">> :: binary(),
+ key = {<<"">>, <<"">>, <<"">>} :: {binary(), binary(), binary()},
+ server_name = <<"">> :: binary(),
+- permissions = ?DICT:new() :: dict(),
+- channels = ?DICT:new() :: dict(),
++ permissions = ?DICT:new() :: dict:dict(),
++ channels = ?DICT:new() :: dict:dict(),
+ max_permissions :: non_neg_integer() | atom(),
+ relay_ip = {127,0,0,1} :: inet:ip_address(),
+ min_port = 49152 :: non_neg_integer(),
+@@ -117,7 +117,7 @@
+ ok
+ end,
+ TRef = erlang:start_timer(?DEFAULT_LIFETIME, self(), stop),
+- {A1, A2, A3} = now(),
++ {A1, A2, A3} = erlang:timestamp(),
+ random:seed(A1, A2, A3),
+ case turn_sm:add_allocation(AddrPort, Username, Realm, MaxAllocs, self()) of
+ ok ->
+diff -ruN --exclude '*.orig' ../deps/p1_utils/src/p1_fsm.erl ../deps/p1_utils/src/p1_fsm.erl
+--- ../deps/p1_utils/src/p1_fsm.erl 2014-07-28 01:40:11.000000000 +0200
++++ ../deps/p1_utils/src/p1_fsm.erl 2015-06-25 10:22:37.000000000 +0200
+@@ -601,12 +601,12 @@
+ true ->
+ Time1
+ end,
+- Now = now(),
++ Now = erlang:timestamp(),
+ Reason = case catch rpc_call(Node, M, F, A, RPCTimeout) of
+ {ok, Clone} ->
+ process_flag(trap_exit, true),
+ MRef = erlang:monitor(process, Clone),
+- NowDiff = timer:now_diff(now(), Now) div 1000,
++ NowDiff = timer:now_diff(erlang:timestamp(), Now) div 1000,
+ TimeLeft = lists:max([Time1 - NowDiff, 0]),
+ TRef = erlang:start_timer(TimeLeft, self(), timeout),
+ relay_messages(MRef, TRef, Clone, Queue);
+@@ -664,12 +664,12 @@
+ true ->
+ Time1
+ end,
+- Now = now(),
++ Now = erlang:timestamp(),
+ Reason = case catch rpc_call(Node, M, F, A, RPCTimeout) of
+ {ok, Clone} ->
+ process_flag(trap_exit, true),
+ MRef = erlang:monitor(process, Clone),
+- NowDiff = timer:now_diff(now(), Now) div 1000,
++ NowDiff = timer:now_diff(erlang:timestamp(), Now) div 1000,
+ TimeLeft = lists:max([Time1 - NowDiff, 0]),
+ TRef = erlang:start_timer(TimeLeft, self(), timeout),
+ relay_messages(MRef, TRef, Clone, Queue);
+diff -ruN --exclude '*.orig' ../deps/riakc/src/riakc_pb_socket.erl ../deps/riakc/src/riakc_pb_socket.erl
+--- ../deps/riakc/src/riakc_pb_socket.erl 2015-01-14 13:01:53.000000000 +0100
++++ ../deps/riakc/src/riakc_pb_socket.erl 2015-06-25 10:23:23.000000000 +0200
+@@ -1728,7 +1728,7 @@
+ end.
+
+ %% @private
+-mk_reqid() -> erlang:phash2(erlang:now()). % only has to be unique per-pid
++mk_reqid() -> erlang:phash2(erlang:timestamp()). % only has to be unique per-pid
+
+ %% @private
+ wait_for_list(ReqId) ->
diff --git a/net-im/ejabberd/pkg-plist b/net-im/ejabberd/pkg-plist
index 5e810d9d01e6..aec76b6b1893 100644
--- a/net-im/ejabberd/pkg-plist
+++ b/net-im/ejabberd/pkg-plist
@@ -9,6 +9,8 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/ELDAPv3.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/XmppAddr.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/acl.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/adhoc.beam
+%%REDIS%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/basho_bench_driver_eredis.beam
+%%REDIS%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/basho_bench_driver_erldis.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/bitmap.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/cache_tab.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/cache_tab_sup.beam
@@ -85,6 +87,12 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/eldap_utils.beam
%%PAM%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/epam_app.beam
%%PAM%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/epam_sup.beam
%%PAM%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/epam.beam
+%%REDIS%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/eredis.app
+%%REDIS%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/eredis.beam
+%%REDIS%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/eredis_client.beam
+%%REDIS%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/eredis_parser.beam
+%%REDIS%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/eredis_sub.beam
+%%REDIS%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/eredis_sub_client.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/esip.app
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/esip.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/esip_app.beam
@@ -154,11 +162,13 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/jlib.beam
%%LAGER%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/lager_util.beam
%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck.app
%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_args_matcher.beam
%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_code.beam
%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_code_gen.beam
%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_cover.beam
%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_expect.beam
%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_history.beam
+%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_matcher.beam
%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_proc.beam
%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_ret_spec.beam
%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/meck_util.beam
@@ -180,6 +190,7 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_ip_blacklist.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_irc.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_irc_connection.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_last.beam
+lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_mam.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_muc.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_muc_admin.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/mod_muc_log.beam
@@ -248,7 +259,6 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_fsm.beam
%%MYSQL%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_mysql_sup.beam
%%PAM%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_pam.app
%%PGSQL%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_pgsql.app
-%%PAM%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_prof.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_server.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_sha.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/p1_stringprep.app
@@ -298,6 +308,9 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/pubsub_subscription_odbc.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/randoms.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/scram.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/shaper.beam
+%%SQLITE%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/sqlite3.app
+%%SQLITE%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/sqlite3.beam
+%%SQLITE%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/sqlite3_lib.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/str.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/stringprep.beam
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/ebin/stringprep_app.beam
@@ -332,6 +345,8 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/%%PORTNAME%%_http.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/%%PORTNAME%%_sm.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/%%PORTNAME%%_web_admin.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/eldap.hrl
+lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/eredis.hrl
+lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/eredis_sub.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/esip.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/esip_lib.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/http_bind.hrl
@@ -351,6 +366,7 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/pubsub.hrl
%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/riak_pb_kv_codec.hrl
%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/riak_search_pb.hrl
%%RIAK%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/riakc.hrl
+lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/sqlite3.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/stun.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/xml.hrl
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/include/xml_gen.hrl
@@ -367,6 +383,8 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/ezlib_drv.so
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/p1_sha.so
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/p1_tls_drv.so
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/p1_yaml.so
+%%SQLITE%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/sqlite3_drv.so
+lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/xml.so
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/lib/stringprep.so
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/msgs/ca.msg
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/msgs/cs.msg
@@ -394,20 +412,10 @@ lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/msgs/uk.msg
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/msgs/vi.msg
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/msgs/wa.msg
lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/msgs/zh.msg
+%%SQLITE%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/sql/lite.sql
+%%SQLITE%%lib/erlang/lib/%%PORTNAME%%-%%PORTVERSION%%/priv/sqlite3_drv.so
sbin/%%PORTNAME%%ctl
%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/dev.html
-%%PORTDOCS%%%%DOCSDIR%%/discorus.png
-%%PORTDOCS%%%%DOCSDIR%%/guide.html
-%%PORTDOCS%%%%DOCSDIR%%/guide.pdf
-%%PORTDOCS%%%%DOCSDIR%%/logo.png
-%%PORTDOCS%%%%DOCSDIR%%/msrl-dit-deep.png
-%%PORTDOCS%%%%DOCSDIR%%/msrl-dit-flat.png
-%%PORTDOCS%%%%DOCSDIR%%/msrl-roster-deep.png
-%%PORTDOCS%%%%DOCSDIR%%/msrl-roster-flat.png
-%%PORTDOCS%%%%DOCSDIR%%/webadmmain.png
-%%PORTDOCS%%%%DOCSDIR%%/webadmmainru.png
-%%PORTDOCS%%%%DOCSDIR%%/yozhikheader.png
@dir /var/spool/ejabberd
@dir /var/run/ejabberdctl
@dir /var/log/ejabberd