aboutsummaryrefslogtreecommitdiff
path: root/net-im/empathy
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
commitae52bc80895a23ddbe33b86e75a9cf331ae32ba9 (patch)
tree5538a7d3541f6d56e4bbab9c6329f5b9db64dafb /net-im/empathy
parent7934df773e0cc2a9924de75dd7cad9cc3d79d4ee (diff)
downloadports-ae52bc80895a23ddbe33b86e75a9cf331ae32ba9.tar.gz
ports-ae52bc80895a23ddbe33b86e75a9cf331ae32ba9.zip
Presenting GNOME 2.26 for FreeBSD. See
http://library.gnome.org/misc/release-notes/2.26/ for a list of what's new. On the FreeBSD front, we introduced a port of libxul 1.9 as an alternative for Firefox 2.0 as a Gecko provider. Almost all of the Gecko consumers can make use of this provider by setting: WITH_GECKO=libxul The GNOME 2.26 port was done by ahze, kwm, marcus, and mezz with contributions by Joseph S. Atkinson, Peter Wemm, Eric L. Chen, Martin Matuska, Craig Butler, and Pawel Worach.
Notes
Notes: svn path=/head/; revision=231972
Diffstat (limited to 'net-im/empathy')
-rw-r--r--net-im/empathy/Makefile14
-rw-r--r--net-im/empathy/distinfo6
-rw-r--r--net-im/empathy/pkg-plist95
3 files changed, 99 insertions, 16 deletions
diff --git a/net-im/empathy/Makefile b/net-im/empathy/Makefile
index 0b30f438ca4b..627e6e19ba2e 100644
--- a/net-im/empathy/Makefile
+++ b/net-im/empathy/Makefile
@@ -3,10 +3,10 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/net-im/empathy/Makefile,v 1.16 2008/10/20 23:38:20 kwm Exp $
+# $MCom: ports/net-im/empathy/Makefile,v 1.22 2009/03/30 19:03:24 marcus Exp $
PORTNAME= empathy
-PORTVERSION= 2.24.1
+PORTVERSION= 2.26.0.1
CATEGORIES= net-im gnome
MASTER_SITES= GNOME
@@ -16,7 +16,10 @@ COMMENT= GNOME IM client based around telepathy
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
LIB_DEPENDS= missioncontrol-server.1:${PORTSDIR}/net-im/telepathy-mission-control \
aspell.16:${PORTSDIR}/textproc/aspell \
- telepathy.2:${PORTSDIR}/net-im/libtelepathy
+ telepathy.2:${PORTSDIR}/net-im/libtelepathy \
+ telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib \
+ telepathy-farsight.0:${PORTSDIR}/net-im/telepathy-farsight \
+ canberra-gtk.0:${PORTSDIR}/audio/libcanberra
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
USE_GMAKE= yes
@@ -25,6 +28,7 @@ USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_GNOME= evolutiondataserver gnomehack gnomeprefix pygtk2 ltverhack \
gnomepanel
+USE_GSTREAMER= yes
USE_AUTOTOOLS= libtool:15
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
@@ -65,7 +69,7 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/telepathy-haze:${PORTSDIR}/net-im/telepathy-h
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|$${datadir}/gtk-doc/html|${DOCSDIR}|' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$${datadir}/gtk-doc/html|${DOCSDIR}|g ; \
+ s|-Werror||g' ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/net-im/empathy/distinfo b/net-im/empathy/distinfo
index 756da0a564c4..8bd4e142df70 100644
--- a/net-im/empathy/distinfo
+++ b/net-im/empathy/distinfo
@@ -1,3 +1,3 @@
-MD5 (empathy-2.24.1.tar.bz2) = 98d1ef485b23a75a9a115547ca2da66a
-SHA256 (empathy-2.24.1.tar.bz2) = 24b675e389fb91898bd2924f8b35db7e7aef4c40bbb69412e445048dd9e18123
-SIZE (empathy-2.24.1.tar.bz2) = 1761446
+MD5 (empathy-2.26.0.1.tar.bz2) = e3b0e891c7eac3d6f3eb85373a6f4e25
+SHA256 (empathy-2.26.0.1.tar.bz2) = 02c5648cf48ddd726aba4a484b8c2317af846f9c01d61e2b3700f30e8944b390
+SIZE (empathy-2.26.0.1.tar.bz2) = 2181144
diff --git a/net-im/empathy/pkg-plist b/net-im/empathy/pkg-plist
index e90370f07944..24d08c2c8b0e 100644
--- a/net-im/empathy/pkg-plist
+++ b/net-im/empathy/pkg-plist
@@ -4,11 +4,14 @@ include/libempathy-gtk/empathy-account-chooser.h
include/libempathy-gtk/empathy-account-widget-irc.h
include/libempathy-gtk/empathy-account-widget-sip.h
include/libempathy-gtk/empathy-account-widget.h
+include/libempathy-gtk/empathy-audio-sink.h
+include/libempathy-gtk/empathy-audio-src.h
include/libempathy-gtk/empathy-avatar-chooser.h
include/libempathy-gtk/empathy-avatar-image.h
include/libempathy-gtk/empathy-cell-renderer-activatable.h
include/libempathy-gtk/empathy-cell-renderer-expander.h
include/libempathy-gtk/empathy-cell-renderer-text.h
+include/libempathy-gtk/empathy-chat-text-view.h
include/libempathy-gtk/empathy-chat-view.h
include/libempathy-gtk/empathy-chat.h
include/libempathy-gtk/empathy-conf.h
@@ -16,6 +19,7 @@ include/libempathy-gtk/empathy-contact-dialogs.h
include/libempathy-gtk/empathy-contact-list-store.h
include/libempathy-gtk/empathy-contact-list-view.h
include/libempathy-gtk/empathy-contact-menu.h
+include/libempathy-gtk/empathy-contact-selector.h
include/libempathy-gtk/empathy-contact-widget.h
include/libempathy-gtk/empathy-geometry.h
include/libempathy-gtk/empathy-gtk-enum-types.h
@@ -31,16 +35,22 @@ include/libempathy-gtk/empathy-spell.h
include/libempathy-gtk/empathy-theme-boxes.h
include/libempathy-gtk/empathy-theme-irc.h
include/libempathy-gtk/empathy-theme-manager.h
-include/libempathy-gtk/empathy-theme.h
include/libempathy-gtk/empathy-ui-utils.h
+include/libempathy-gtk/empathy-video-src.h
+include/libempathy-gtk/empathy-video-widget.h
+include/libempathy/empathy-account-manager.h
+include/libempathy/empathy-call-factory.h
+include/libempathy/empathy-call-handler.h
include/libempathy/empathy-chatroom-manager.h
include/libempathy/empathy-chatroom.h
include/libempathy/empathy-contact-factory.h
include/libempathy/empathy-contact-groups.h
include/libempathy/empathy-contact-list.h
include/libempathy/empathy-contact-manager.h
+include/libempathy/empathy-contact-monitor.h
include/libempathy/empathy-contact.h
include/libempathy/empathy-debug.h
+include/libempathy/empathy-dispatch-operation.h
include/libempathy/empathy-dispatcher.h
include/libempathy/empathy-enum-types.h
include/libempathy/empathy-idle.h
@@ -48,6 +58,8 @@ include/libempathy/empathy-irc-network-manager.h
include/libempathy/empathy-irc-network.h
include/libempathy/empathy-irc-server.h
include/libempathy/empathy-log-manager.h
+include/libempathy/empathy-log-store-empathy.h
+include/libempathy/empathy-log-store.h
include/libempathy/empathy-message.h
include/libempathy/empathy-status-presets.h
include/libempathy/empathy-time.h
@@ -55,19 +67,21 @@ include/libempathy/empathy-tp-call.h
include/libempathy/empathy-tp-chat.h
include/libempathy/empathy-tp-contact-factory.h
include/libempathy/empathy-tp-contact-list.h
+include/libempathy/empathy-tp-file.h
include/libempathy/empathy-tp-group.h
include/libempathy/empathy-tp-roomlist.h
include/libempathy/empathy-tp-tube.h
include/libempathy/empathy-tube-handler.h
+include/libempathy/empathy-types.h
include/libempathy/empathy-utils.h
lib/libempathy-gtk.a
lib/libempathy-gtk.la
lib/libempathy-gtk.so
-lib/libempathy-gtk.so.15
+lib/libempathy-gtk.so.19
lib/libempathy.a
lib/libempathy.la
lib/libempathy.so
-lib/libempathy.so.14
+lib/libempathy.so.23
%%PYTHON_SITELIBDIR%%/empathy.a
%%PYTHON_SITELIBDIR%%/empathy.la
%%PYTHON_SITELIBDIR%%/empathy.so
@@ -88,16 +102,20 @@ share/doc/libempathy-gtk/EmpathyCellRendererActivatable.html
share/doc/libempathy-gtk/EmpathyCellRendererExpander.html
share/doc/libempathy-gtk/EmpathyCellRendererText.html
share/doc/libempathy-gtk/EmpathyChat.html
-share/doc/libempathy-gtk/EmpathyChatView.html
+share/doc/libempathy-gtk/EmpathyChatTextView.html
share/doc/libempathy-gtk/EmpathyConf.html
share/doc/libempathy-gtk/EmpathyContactListStore.html
share/doc/libempathy-gtk/EmpathyContactListView.html
+share/doc/libempathy-gtk/EmpathyContactSelector.html
+share/doc/libempathy-gtk/EmpathyGstAudioSink.html
+share/doc/libempathy-gtk/EmpathyGstAudioSrc.html
+share/doc/libempathy-gtk/EmpathyGstVideoSrc.html
share/doc/libempathy-gtk/EmpathyPresenceChooser.html
share/doc/libempathy-gtk/EmpathySmileyManager.html
-share/doc/libempathy-gtk/EmpathyTheme.html
share/doc/libempathy-gtk/EmpathyThemeBoxes.html
share/doc/libempathy-gtk/EmpathyThemeIrc.html
share/doc/libempathy-gtk/EmpathyThemeManager.html
+share/doc/libempathy-gtk/EmpathyVideoWidget.html
share/doc/libempathy-gtk/home.png
share/doc/libempathy-gtk/index.html
share/doc/libempathy-gtk/index.sgml
@@ -106,6 +124,7 @@ share/doc/libempathy-gtk/left.png
share/doc/libempathy-gtk/libempathy-gtk-empathy-account-widget-irc.html
share/doc/libempathy-gtk/libempathy-gtk-empathy-account-widget-sip.html
share/doc/libempathy-gtk/libempathy-gtk-empathy-account-widget.html
+share/doc/libempathy-gtk/libempathy-gtk-empathy-chat-view.html
share/doc/libempathy-gtk/libempathy-gtk-empathy-contact-dialogs.html
share/doc/libempathy-gtk/libempathy-gtk-empathy-contact-menu.html
share/doc/libempathy-gtk/libempathy-gtk-empathy-contact-widget.html
@@ -127,22 +146,29 @@ share/doc/libempathy-gtk/pt02.html
share/doc/libempathy-gtk/right.png
share/doc/libempathy-gtk/style.css
share/doc/libempathy-gtk/up.png
+share/doc/libempathy/EmpathyAccountManager.html
+share/doc/libempathy/EmpathyCallFactory.html
+share/doc/libempathy/EmpathyCallHandler.html
share/doc/libempathy/EmpathyChatroom.html
share/doc/libempathy/EmpathyChatroomManager.html
share/doc/libempathy/EmpathyContact.html
share/doc/libempathy/EmpathyContactFactory.html
share/doc/libempathy/EmpathyContactManager.html
+share/doc/libempathy/EmpathyContactMonitor.html
share/doc/libempathy/EmpathyDispatcher.html
+share/doc/libempathy/EmpathyDispatchOperation.html
share/doc/libempathy/EmpathyIdle.html
share/doc/libempathy/EmpathyIrcNetwork.html
share/doc/libempathy/EmpathyIrcNetworkManager.html
share/doc/libempathy/EmpathyIrcServer.html
share/doc/libempathy/EmpathyLogManager.html
+share/doc/libempathy/EmpathyLogStoreEmpathy.html
share/doc/libempathy/EmpathyMessage.html
share/doc/libempathy/EmpathyTpCall.html
share/doc/libempathy/EmpathyTpChat.html
share/doc/libempathy/EmpathyTpContactFactory.html
share/doc/libempathy/EmpathyTpContactList.html
+share/doc/libempathy/EmpathyTpFile.html
share/doc/libempathy/EmpathyTpGroup.html
share/doc/libempathy/EmpathyTpRoomlist.html
share/doc/libempathy/EmpathyTpTube.html
@@ -154,8 +180,11 @@ share/doc/libempathy/ix01.html
share/doc/libempathy/left.png
share/doc/libempathy/libempathy-empathy-contact-groups.html
share/doc/libempathy/libempathy-empathy-contact-list.html
+share/doc/libempathy/libempathy-empathy-enum-types.html
+share/doc/libempathy/libempathy-empathy-log-store.html
share/doc/libempathy/libempathy-empathy-status-presets.html
share/doc/libempathy/libempathy-empathy-time.html
+share/doc/libempathy/libempathy-empathy-types.html
share/doc/libempathy/libempathy-empathy-utils.html
share/doc/libempathy/libempathy-hierarchy.html
share/doc/libempathy/libempathy.devhelp
@@ -187,7 +216,9 @@ share/doc/libempathy/up.png
%%DATADIR%%/empathy-contact-dialogs.glade
%%DATADIR%%/empathy-contact-groups.dtd
%%DATADIR%%/empathy-contact-widget.glade
+%%DATADIR%%/empathy-ft-manager.glade
%%DATADIR%%/empathy-irc-networks.dtd
+%%DATADIR%%/empathy-import-dialog.glade
%%DATADIR%%/empathy-log-manager.xsl
%%DATADIR%%/empathy-log-window.glade
%%DATADIR%%/empathy-main-window.glade
@@ -283,6 +314,7 @@ share/doc/libempathy/up.png
%%DATADIR%%/icons/hicolor/48x48/status/empathy-extended-away.png
%%DATADIR%%/icons/hicolor/48x48/status/empathy-offline.png
%%DATADIR%%/icons/hicolor/48x48/status/empathy-pending.png
+%%DATADIR%%/icons/hicolor/icon-theme.cache
%%DATADIR%%/icons/hicolor/scalable/apps/im-ekiga.svg
%%DATADIR%%/icons/hicolor/scalable/apps/im-gadugadu.svg
%%DATADIR%%/icons/hicolor/scalable/apps/im-gizmo.svg
@@ -302,23 +334,33 @@ share/doc/libempathy/up.png
%%DATADIR%%/irc-networks.xml
share/gnome/help/empathy/C/empathy.xml
share/gnome/help/empathy/C/figures/empathy-main-window.png
-share/gnome/help/empathy/C/figures/empathy-new-account.png
share/gnome/help/empathy/C/legal.xml
+share/gnome/help/empathy/ca/empathy.xml
+share/gnome/help/empathy/ca/figures/empathy-main-window.png
+share/gnome/help/empathy/ca/figures/empathy-new-account.png
share/gnome/help/empathy/cs/empathy.xml
share/gnome/help/empathy/cs/figures/empathy-main-window.png
-share/gnome/help/empathy/cs/figures/empathy-new-account.png
share/gnome/help/empathy/de/empathy.xml
share/gnome/help/empathy/de/figures/empathy-main-window.png
share/gnome/help/empathy/de/figures/empathy-new-account.png
+share/gnome/help/empathy/el/empathy.xml
+share/gnome/help/empathy/el/figures/empathy-main-window.png
+share/gnome/help/empathy/el/figures/empathy-new-account.png
+share/gnome/help/empathy/en_GB/empathy.xml
+share/gnome/help/empathy/en_GB/figures/empathy-main-window.png
share/gnome/help/empathy/es/empathy.xml
share/gnome/help/empathy/es/figures/empathy-main-window.png
share/gnome/help/empathy/es/figures/empathy-new-account.png
+share/gnome/help/empathy/fi/empathy.xml
+share/gnome/help/empathy/fi/figures/empathy-main-window.png
+share/gnome/help/empathy/fi/figures/empathy-new-account.png
share/gnome/help/empathy/fr/empathy.xml
share/gnome/help/empathy/fr/figures/empathy-main-window.png
share/gnome/help/empathy/fr/figures/empathy-new-account.png
share/gnome/help/empathy/it/empathy.xml
share/gnome/help/empathy/it/figures/empathy-main-window.png
-share/gnome/help/empathy/it/figures/empathy-new-account.png
+share/gnome/help/empathy/ru/empathy.xml
+share/gnome/help/empathy/ru/figures/empathy-main-window.png
share/gnome/help/empathy/sv/empathy.xml
share/gnome/help/empathy/sv/figures/empathy-main-window.png
share/gnome/help/empathy/sv/figures/empathy-new-account.png
@@ -329,7 +371,9 @@ share/icons/hicolor/32x32/apps/empathy.png
share/icons/hicolor/48x48/apps/empathy.png
share/icons/hicolor/scalable/apps/empathy.svg
share/locale/ar/LC_MESSAGES/empathy.mo
+share/locale/as/LC_MESSAGES/empathy.mo
share/locale/az/LC_MESSAGES/empathy.mo
+share/locale/be@latin/LC_MESSAGES/empathy.mo
share/locale/bg/LC_MESSAGES/empathy.mo
share/locale/bn_IN/LC_MESSAGES/empathy.mo
share/locale/ca/LC_MESSAGES/empathy.mo
@@ -357,7 +401,10 @@ share/locale/it/LC_MESSAGES/empathy.mo
share/locale/ja/LC_MESSAGES/empathy.mo
share/locale/kn/LC_MESSAGES/empathy.mo
share/locale/ko/LC_MESSAGES/empathy.mo
+share/locale/ku/LC_MESSAGES/empathy.mo
share/locale/lt/LC_MESSAGES/empathy.mo
+share/locale/lv/LC_MESSAGES/empathy.mo
+share/locale/mai/LC_MESSAGES/empathy.mo
share/locale/mk/LC_MESSAGES/empathy.mo
share/locale/ml/LC_MESSAGES/empathy.mo
share/locale/mr/LC_MESSAGES/empathy.mo
@@ -366,16 +413,21 @@ share/locale/nb/LC_MESSAGES/empathy.mo
share/locale/ne/LC_MESSAGES/empathy.mo
share/locale/nl/LC_MESSAGES/empathy.mo
share/locale/oc/LC_MESSAGES/empathy.mo
+share/locale/or/LC_MESSAGES/empathy.mo
share/locale/pa/LC_MESSAGES/empathy.mo
share/locale/pl/LC_MESSAGES/empathy.mo
+share/locale/ps/LC_MESSAGES/empathy.mo
share/locale/pt/LC_MESSAGES/empathy.mo
share/locale/pt_BR/LC_MESSAGES/empathy.mo
+share/locale/ro/LC_MESSAGES/empathy.mo
share/locale/ru/LC_MESSAGES/empathy.mo
share/locale/sl/LC_MESSAGES/empathy.mo
share/locale/sq/LC_MESSAGES/empathy.mo
share/locale/sr/LC_MESSAGES/empathy.mo
share/locale/sr@latin/LC_MESSAGES/empathy.mo
share/locale/sv/LC_MESSAGES/empathy.mo
+share/locale/ta/LC_MESSAGES/empathy.mo
+share/locale/te/LC_MESSAGES/empathy.mo
share/locale/th/LC_MESSAGES/empathy.mo
share/locale/tr/LC_MESSAGES/empathy.mo
share/locale/uk/LC_MESSAGES/empathy.mo
@@ -400,27 +452,42 @@ share/mission-control/profiles/sipphone.profile
share/mission-control/profiles/sofiasip.profile
share/mission-control/profiles/yahoo.profile
share/omf/empathy/empathy-C.omf
+share/omf/empathy/empathy-ca.omf
share/omf/empathy/empathy-cs.omf
share/omf/empathy/empathy-de.omf
+share/omf/empathy/empathy-el.omf
+share/omf/empathy/empathy-en_GB.omf
share/omf/empathy/empathy-es.omf
+share/omf/empathy/empathy-fi.omf
share/omf/empathy/empathy-fr.omf
share/omf/empathy/empathy-it.omf
+share/omf/empathy/empathy-ru.omf
share/omf/empathy/empathy-sv.omf
@dirrm share/omf/empathy
@dirrm share/mission-control/profiles
@dirrm share/mission-control
@dirrm share/gnome/help/empathy/sv/figures
@dirrm share/gnome/help/empathy/sv
+@dirrm share/gnome/help/empathy/ru/figures
+@dirrm share/gnome/help/empathy/ru
@dirrm share/gnome/help/empathy/it/figures
@dirrm share/gnome/help/empathy/it
@dirrm share/gnome/help/empathy/fr/figures
@dirrm share/gnome/help/empathy/fr
+@dirrm share/gnome/help/empathy/fi/figures
+@dirrm share/gnome/help/empathy/fi
@dirrm share/gnome/help/empathy/es/figures
@dirrm share/gnome/help/empathy/es
+@dirrm share/gnome/help/empathy/en_GB/figures
+@dirrm share/gnome/help/empathy/en_GB
+@dirrm share/gnome/help/empathy/el/figures
+@dirrm share/gnome/help/empathy/el
@dirrm share/gnome/help/empathy/de/figures
@dirrm share/gnome/help/empathy/de
@dirrm share/gnome/help/empathy/cs/figures
@dirrm share/gnome/help/empathy/cs
+@dirrm share/gnome/help/empathy/ca/figures
+@dirrm share/gnome/help/empathy/ca
@dirrm share/gnome/help/empathy/C/figures
@dirrm share/gnome/help/empathy/C
@dirrm share/gnome/help/empathy
@@ -455,13 +522,25 @@ share/omf/empathy/empathy-sv.omf
@dirrm include/libempathy
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
@dirrmtry share/locale/sr@latin/LC_MESSAGES
@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/ps/LC_MESSAGES
+@dirrmtry share/locale/ps
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as