aboutsummaryrefslogtreecommitdiff
path: root/net-im/jabberd/files
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2011-06-19 10:14:45 +0000
committerMartin Matuska <mm@FreeBSD.org>2011-06-19 10:14:45 +0000
commit84c743c90280f777541b766914a539f8d34b7001 (patch)
treea6487a0362675d71baade0a56f874b9930f8d2b3 /net-im/jabberd/files
parent6c7716bcbe2fd04f8f0ff59cde370fc03498669a (diff)
downloadports-84c743c90280f777541b766914a539f8d34b7001.tar.gz
ports-84c743c90280f777541b766914a539f8d34b7001.zip
Update to 2.2.14
Switch to USERS and GROUPS
Notes
Notes: svn path=/head/; revision=275827
Diffstat (limited to 'net-im/jabberd/files')
-rw-r--r--net-im/jabberd/files/patch-etc-Makefile.in20
-rw-r--r--net-im/jabberd/files/pkg-deinstall.in14
-rw-r--r--net-im/jabberd/files/pkg-install.in29
3 files changed, 25 insertions, 38 deletions
diff --git a/net-im/jabberd/files/patch-etc-Makefile.in b/net-im/jabberd/files/patch-etc-Makefile.in
new file mode 100644
index 000000000000..5db085bde5bf
--- /dev/null
+++ b/net-im/jabberd/files/patch-etc-Makefile.in
@@ -0,0 +1,20 @@
+--- etc/Makefile.in.orig 2011-06-19 11:33:59.341460610 +0200
++++ etc/Makefile.in 2011-06-19 11:35:29.949061936 +0200
+@@ -539,7 +539,7 @@
+ uninstall: uninstall-recursive
+
+ install-am: all-am
+- @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
++ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am
+
+ installcheck: installcheck-recursive
+ install-strip:
+@@ -623,7 +623,7 @@
+
+ ps-am:
+
+-uninstall-am: uninstall-initDATA uninstall-sysconfDATA
++uninstall-am: uninstall-sysconfDATA
+
+ .MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) ctags-recursive \
+ install-am install-data-am install-strip tags-recursive
diff --git a/net-im/jabberd/files/pkg-deinstall.in b/net-im/jabberd/files/pkg-deinstall.in
index 248fa7fe1ea9..d2915f81dda9 100644
--- a/net-im/jabberd/files/pkg-deinstall.in
+++ b/net-im/jabberd/files/pkg-deinstall.in
@@ -5,19 +5,9 @@ if [ "$2" != "POST-DEINSTALL" ]; then
exit 0
fi
-USER=%%JABBER_USER%%
-GROUP=%%JABBER_GROUP%%
RUNDIR="%%JABBER_RUNDIR%%"
-if pw usershow "${USER}" 2>/dev/null 1>&2; then
- echo "To delete Jabber user permanently, use 'pw userdel ${USER}'"
-fi
-
-if pw groupshow "${GROUP}" 2>/dev/null 1>&2; then
- echo "To delete Jabber group permanently, use 'pw groupdel ${USER}'"
-fi
-
-echo "You may want to delete the following directories:"
-echo "${RUNDIR}"
+echo "===> You should manually delete the following directories:"
+echo "${RUNDIR}"
exit 0
diff --git a/net-im/jabberd/files/pkg-install.in b/net-im/jabberd/files/pkg-install.in
index 76753f90a3da..ead0e703a634 100644
--- a/net-im/jabberd/files/pkg-install.in
+++ b/net-im/jabberd/files/pkg-install.in
@@ -7,41 +7,18 @@ fi
USER=%%JABBER_USER%%
GROUP=%%JABBER_GROUP%%
-UID=%%JABBER_UID%%
-GID=%%JABBER_GID%%
ETCDIR=%%JABBER_ETCDIR%%
RUNDIR=%%JABBER_RUNDIR%%
-if ! pw groupshow "${GROUP}" 2>/dev/null 1>&2; then
- if pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
-fi
-
-if ! pw usershow "${USER}" 2>/dev/null 1>&2; then
- if pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
- -s "/sbin/nologin" -d "/nonexistent" \
- -c "Jabber Daemon"; \
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
-fi
-
if [ ! -d ${RUNDIR} ]; then
- echo "Creating \"${RUNDIR}\"."
+ echo "===> Creating \"${RUNDIR}\"."
mkdir -p ${RUNDIR}/pid ${RUNDIR}/db ${RUNDIR}/logs
fi
-echo "Fixing ownerships and modes in \"${ETCDIR}\"."
+echo "===> Changing owner and modes for \"${ETCDIR}\"."
chown -R ${USER}:${GROUP} ${ETCDIR}
chmod -R go= ${ETCDIR}
-echo "Fixing ownerships and modes in \"${RUNDIR}\"."
+echo "===> Changing owner and modes for \"${RUNDIR}\"."
chown -R ${USER}:${GROUP} ${RUNDIR}
chmod -R go= ${RUNDIR}