aboutsummaryrefslogtreecommitdiff
path: root/net-im/ktp-accounts-kcm/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 16:18:29 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 16:18:29 +0000
commit5840ae786f9553aabd0b97e758ea551ca66a83f6 (patch)
tree6bc3da971ccf4d09e6b5ee6302e8d9186d3c1d31 /net-im/ktp-accounts-kcm/Makefile
parent5677e2facee4dd09ac408ed7dd41c81bc2aa4307 (diff)
downloadports-5840ae786f9553aabd0b97e758ea551ca66a83f6.tar.gz
ports-5840ae786f9553aabd0b97e758ea551ca66a83f6.zip
New ports: KDE Applications net-im/
* net-im/kaccounts-integration * net-im/kaccounts-providers * net-im/ktp-accounts-kcm * net-im/ktp-approver * net-im/ktp-auth-handler * net-im/ktp-call-ui * net-im/ktp-common-internals * net-im/ktp-contact-list * net-im/ktp-contact-runner * net-im/ktp-desktop-applets * net-im/ktp-filetransfer-handler * net-im/ktp-kded-module * net-im/ktp-send-file * net-im/ktp-text-ui * net-im/telepathy-logger-qt5 This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4.
Notes
Notes: svn path=/head/; revision=466968
Diffstat (limited to 'net-im/ktp-accounts-kcm/Makefile')
-rw-r--r--net-im/ktp-accounts-kcm/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-im/ktp-accounts-kcm/Makefile b/net-im/ktp-accounts-kcm/Makefile
new file mode 100644
index 000000000000..4d2c71957ae1
--- /dev/null
+++ b/net-im/ktp-accounts-kcm/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= ktp-accounts-kcm
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= net-im kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE instant messaging account management module
+
+LIB_DEPENDS= libaccounts-qt5.so:net-im/libaccounts-qt5 \
+ libkaccounts.so:net-im/kaccounts-integration \
+ libtelepathy-qt5.so:net-im/telepathy-qt5 \
+ libtelepathy-logger-qt.so:net-im/telepathy-logger-qt5 \
+ libKTpCommonInternals.so:net-im/ktp-common-internals \
+ libKF5AkonadiPrivate.so:databases/akonadi \
+ libsignon-qt5.so:sysutils/signon-qt5
+
+RUN_DEPENDS= ${KDE_PREFIX}/bin/ktp-contactlist:net-im/ktp-contact-list \
+ ${QT_PLUGINDIR}/kaccounts/ui/owncloud_plugin_kaccounts.so:net-im/kaccounts-providers
+
+USES= cmake:outsource gettext kde:5 pkgconfig tar:xz
+USE_GNOME= intltool
+USE_KDE= auth codecs config configwidgets coreaddons ecm i18n \
+ iconthemes itemviews kcmutils kio notifications notifyconfig \
+ service texteditor wallet widgetsaddons windowsystem
+USE_QT5= core dbus gui network qml sql widgets xml \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= HAZE IRC JABBER SALUT
+OPTIONS_DEFAULT=JABBER
+
+HAZE_DESC= libpurple protocols support
+HAZE_RUN_DEPENDS= ${LOCALBASE}/libexec/telepathy-haze:net-im/telepathy-haze
+
+IRC_DESC= Internet Relay Chat support
+IRC_RUN_DEPENDS= ${LOCALBASE}/libexec/telepathy-idle:net-im/telepathy-idle
+
+JABBER_RUN_DEPENDS= ${LOCALBASE}/libexec/telepathy-gabble:net-im/telepathy-gabble
+
+SALUT_DESC= Link-local (serverless) XMPP support
+SALUT_RUN_DEPENDS= ${LOCALBASE}/libexec/telepathy-salut:net-im/telepathy-salut
+
+.include <bsd.port.mk>