aboutsummaryrefslogtreecommitdiff
path: root/net-im/ktp-send-file/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 16:18:29 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 16:18:29 +0000
commit5840ae786f9553aabd0b97e758ea551ca66a83f6 (patch)
tree6bc3da971ccf4d09e6b5ee6302e8d9186d3c1d31 /net-im/ktp-send-file/Makefile
parent5677e2facee4dd09ac408ed7dd41c81bc2aa4307 (diff)
downloadports-5840ae786f9553aabd0b97e758ea551ca66a83f6.tar.gz
ports-5840ae786f9553aabd0b97e758ea551ca66a83f6.zip
New ports: KDE Applications net-im/
* net-im/kaccounts-integration * net-im/kaccounts-providers * net-im/ktp-accounts-kcm * net-im/ktp-approver * net-im/ktp-auth-handler * net-im/ktp-call-ui * net-im/ktp-common-internals * net-im/ktp-contact-list * net-im/ktp-contact-runner * net-im/ktp-desktop-applets * net-im/ktp-filetransfer-handler * net-im/ktp-kded-module * net-im/ktp-send-file * net-im/ktp-text-ui * net-im/telepathy-logger-qt5 This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4.
Notes
Notes: svn path=/head/; revision=466968
Diffstat (limited to 'net-im/ktp-send-file/Makefile')
-rw-r--r--net-im/ktp-send-file/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-im/ktp-send-file/Makefile b/net-im/ktp-send-file/Makefile
new file mode 100644
index 000000000000..1060889a438d
--- /dev/null
+++ b/net-im/ktp-send-file/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= ktp-send-file
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= net-im kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE instant messaging file transfer application
+
+LIB_DEPENDS= libtelepathy-qt5.so:net-im/telepathy-qt5 \
+ libKTpCommonInternals.so:net-im/ktp-common-internals
+RUN_DEPENDS= ${KDE_PREFIX}/lib/libexec/ktp-filetransfer-handler:net-im/ktp-filetransfer-handler \
+ ${KDE_PREFIX}/bin/ktp-contactlist:net-im/ktp-contact-list
+
+USES= cmake:outsource gettext kde:5 tar:xz
+USE_KDE= auth codecs completion config configwidgets coreaddons ecm \
+ i18n iconthemes jobwidgets kcmutils kio service wallet \
+ widgetsaddons
+USE_QT5= core dbus gui network widgets xml \
+ buildtools_build qmake_build
+
+.include <bsd.port.mk>