aboutsummaryrefslogtreecommitdiff
path: root/net-im/libquotient/Makefile
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-11-20 20:35:54 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2020-11-20 20:35:54 +0000
commit52ed178304218a253b69a8b6235eed84cd9462e5 (patch)
tree6098b2c3ff6014bf623eab27ef6f3c1e3dc941cf /net-im/libquotient/Makefile
parenta27077f47d13113a2697c2a02edd7001f6e41a03 (diff)
downloadports-52ed178304218a253b69a8b6235eed84cd9462e5.tar.gz
ports-52ed178304218a253b69a8b6235eed84cd9462e5.zip
New port: net-im/libquotient
The Quotient project aims to produce a Qt5-based SDK to develop applications for Matrix. libQuotient is a library that enables client applications. It is the backbone of Quaternion, Spectral and other projects. Versions 0.5.x and older use the previous name - libQMatrixClient. Release notes: https://github.com/quotient-im/libQuotient/releases This is repocopied from net-im/libqmatrixclient because libqmatrixclient was renamed to libquotient some time ago; we've been wrestling to keep the old port name with partly-updated library versions, and that gets old. New clients -- modern Quaternion, and soon neoChat (a successor to spectral, which will be deprecated) -- need the newer version. Leaving net-im/libqmatrixclient in the tree for now, although I think it has 0 consumers once I update Quaternion (I'll deprecate it then).
Notes
Notes: svn path=/head/; revision=555785
Diffstat (limited to 'net-im/libquotient/Makefile')
-rw-r--r--net-im/libquotient/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-im/libquotient/Makefile b/net-im/libquotient/Makefile
new file mode 100644
index 000000000000..ad0c8d608314
--- /dev/null
+++ b/net-im/libquotient/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= libquotient
+DISTVERSION= 0.6.2
+CATEGORIES= net-im
+
+MAINTAINER= adridg@FreeBSD.org
+COMMENT= Matrix IM support library using Qt technologies
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+CONFLICTS= libqmatrixclient\*
+
+USES= cmake compiler:c++14-lang qt:5 tar:xz
+USE_QT= core gui multimedia network \
+ buildtools_build qmake_build
+
+USE_GITHUB= yes
+GH_ACCOUNT= quotient-im
+GH_PROJECT= libQuotient
+
+CMAKE_ARGS= -DQuotient_INSTALL_TESTS=OFF
+
+.include <bsd.port.mk>