aboutsummaryrefslogtreecommitdiff
path: root/net-im/licq-osd
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-07 14:55:46 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-07 14:55:46 +0000
commit8728e40bd926bcc99b0d076d70e44ff04b332140 (patch)
tree7c858884022c9da2535168c0af73a07beff53406 /net-im/licq-osd
parent2566156f4c321b9e17412bbaf50cc9ffe13a17ad (diff)
downloadports-8728e40bd926bcc99b0d076d70e44ff04b332140.tar.gz
ports-8728e40bd926bcc99b0d076d70e44ff04b332140.zip
- Unbreak licq-osd: Update to 1.3.0 from main licq-distribution
and use already available infrastructure from net/licq - Reset maintainer PR: ports/78559 Approved by: maintainer
Notes
Notes: svn path=/head/; revision=132695
Diffstat (limited to 'net-im/licq-osd')
-rw-r--r--net-im/licq-osd/Makefile28
-rw-r--r--net-im/licq-osd/files/patch-aa8
-rw-r--r--net-im/licq-osd/files/patch-src::licq_osd.conf.h11
3 files changed, 26 insertions, 21 deletions
diff --git a/net-im/licq-osd/Makefile b/net-im/licq-osd/Makefile
index 4aa26607fcf9..f0d3b1dbe9d2 100644
--- a/net-im/licq-osd/Makefile
+++ b/net-im/licq-osd/Makefile
@@ -6,31 +6,25 @@
#
#
-PORTNAME= licq_osd_plugin
-PORTVERSION= 1.2.7.2
-PORTREVISION= 1
+PORTNAME= osd
+PORTVERSION= ${OSD_LICQ_VER}
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR=/sourceforge/licq-osd
-DISTNAME= licq_osd_plugin-${PORTVERSION}
-MAINTAINER= nm@web.am
+MAINTAINER= ports@FreeBSD.org
COMMENT= OnScreenDisplay messages in licq (like in SIM and more)
-BROKEN= "Incompatible with licq-1.3.0"
-
-BUILD_DEPENDS= ${X11BASE}/lib/libxosd.so.4:${PORTSDIR}/misc/xosd \
- ${LOCALBASE}/include/licq/licq_icqd.h:${PORTSDIR}/net/licq
+LIB_DEPENDS= xosd.4:${PORTSDIR}/misc/xosd
RUN_DEPENDS=${LOCALBASE}/lib/licq/licq_qt-gui.so:${PORTSDIR}/net/licq-qt-gui
# run dependency may be too strict, delete it if you use another
# plugin (gtk+) and wish run osd with it. i've not tested with
# plugins other than qt-gui
-GNU_CONFIGURE=yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" LIBS="-liconv"
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
+
+LICQ_PORT?= net/licq
-PLIST_FILES= lib/licq/licq_osd.la lib/licq/licq_osd.so
+PLIST_FILES= lib/licq/licq_osd.so
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/${LICQ_PORT}/Makefile.inc"
+.include <bsd.port.post.mk>
diff --git a/net-im/licq-osd/files/patch-aa b/net-im/licq-osd/files/patch-aa
index 54ada992cfac..b912e0ecf1f6 100644
--- a/net-im/licq-osd/files/patch-aa
+++ b/net-im/licq-osd/files/patch-aa
@@ -1,10 +1,10 @@
---- src/licq-osd.cpp.orig Wed Jul 16 13:00:53 2003
-+++ src/licq-osd.cpp Wed Jul 16 12:55:10 2003
-@@ -675,7 +675,7 @@
+--- src/licq-osd.cpp.orig Tue Aug 17 20:02:35 2004
++++ src/licq-osd.cpp Mon Mar 7 18:42:53 2005
+@@ -804,7 +804,7 @@
while ((fromsize>0) && (tosize>0))
{
-- if ((int)iconv(conv, &msgptr, &fromsize, &resptr, &tosize)==-1)
+- if ((int)iconv(conv, (char **)&msgptr, &fromsize, &resptr, &tosize)==-1)
+ if ((int)iconv(conv, (const char**)(&msgptr), &fromsize, &resptr, &tosize)==-1)
{
// array is not enough
diff --git a/net-im/licq-osd/files/patch-src::licq_osd.conf.h b/net-im/licq-osd/files/patch-src::licq_osd.conf.h
new file mode 100644
index 000000000000..536d83d1f4da
--- /dev/null
+++ b/net-im/licq-osd/files/patch-src::licq_osd.conf.h
@@ -0,0 +1,11 @@
+--- src/licq_osd.conf.h.orig Mon Mar 7 19:24:09 2005
++++ src/licq_osd.conf.h Mon Mar 7 19:27:17 2005
+@@ -4,7 +4,7 @@
+ "# you can get the available fonts for your machine from xfontsel\n"
+ "# i prefer this one - but it is not available everywhere\n"
+ "# Font=-*-lucida-*-r-*-*-24-*-*-*-*-*-iso8859-15\n"
+-"Font=-*-*-*-*-*-*-24-*-*-*-*-*-*-*\n"
++"Font=-*-lucida-*-*-*-*-24-*-*-*-*-*-iso8859-15\n"
+ "\n"
+ "# how long should a message be displayed\n"
+ "Timeout=5\n"