aboutsummaryrefslogtreecommitdiff
path: root/net-im/licq/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-08-28 15:38:18 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-08-28 15:38:18 +0000
commit7856e867fc3cbf6c0bd634372727094d3af4c534 (patch)
treebc04a2cb1b344b79fa60f11cb4d08c710c9a3090 /net-im/licq/Makefile
parent52c62a7e527f0f906571d4d57e62c0825b343b51 (diff)
downloadports-7856e867fc3cbf6c0bd634372727094d3af4c534.tar.gz
ports-7856e867fc3cbf6c0bd634372727094d3af4c534.zip
- use hook for bsd.openssl.mk
Notes
Notes: svn path=/head/; revision=87906
Diffstat (limited to 'net-im/licq/Makefile')
-rw-r--r--net-im/licq/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index 0e113d1d375b..aecde4ae98f7 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -31,6 +31,12 @@ CONFIGURE_ARGS+=--with-socks5-inc=${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
.endif
+.if !defined(WITHOUT_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-openssl-inc=${OPENSSLINC}
+CONFIGURE_ARGS+=--with-openssl-lib=${OPENSSLLIB}
+.endif
+
pre-configure:
@${MV} ${WRKSRC}/src/licq.conf.h ${WRKSRC}/src/licq.conf.h.sed
${SED} -e "s=/usr/share/licq=${PREFIX}/share/licq=" \
@@ -45,9 +51,5 @@ post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
-CONFIGURE_ARGS+=--with-openssl-inc=${OPENSSLINC}
-CONFIGURE_ARGS+=--with-openssl-lib=${OPENSSLLIB}
-
.include "${LICQ_PORT}/Makefile.inc"
.include <bsd.port.post.mk>