aboutsummaryrefslogtreecommitdiff
path: root/net-im/nheko/Makefile
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2019-04-16 07:25:48 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2019-04-16 07:25:48 +0000
commit431edd0ed9358520b463f7bab541724fd43b81b7 (patch)
treeb184f009cba37a36d99d7c5b5ae614b823647268 /net-im/nheko/Makefile
parent81f8d0f9717f2cd327c9b8d04cb43318f87762d2 (diff)
downloadports-431edd0ed9358520b463f7bab541724fd43b81b7.tar.gz
ports-431edd0ed9358520b463f7bab541724fd43b81b7.zip
Fix up net-im/nheko depends.
- While it looked like everything was being static-linked, so that cmark, libsodium and olm could be build-dep, they're linked in. Then "pkg install" pulls them in, but "pkg autoremove" gets rid of them again, leading to an unusable nheko. Fix the deps.
Notes
Notes: svn path=/head/; revision=499079
Diffstat (limited to 'net-im/nheko/Makefile')
-rw-r--r--net-im/nheko/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-im/nheko/Makefile b/net-im/nheko/Makefile
index 96bac15dd6c0..bdb46afacf80 100644
--- a/net-im/nheko/Makefile
+++ b/net-im/nheko/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nheko
DISTVERSIONPREFIX=v
DISTVERSION= 0.6.3
+PORTREVISION= 1
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
@@ -11,11 +12,13 @@ COMMENT= Matrix IM client based on Qt technologies
LICENSE= GPLv3
LICENSE_FILES= ${WRKSRC}/COPYING
-BUILD_DEPENDS= cmark:textproc/cmark \
- mtxclient>=0.2:net-im/mtxclient \
+BUILD_DEPENDS= mtxclient>=0.2:net-im/mtxclient \
nlohmann-json>=3:devel/nlohmann-json \
spdlog>=1.3:devel/spdlog
-LIB_DEPENDS= liblmdb.so:databases/lmdb
+LIB_DEPENDS= liblmdb.so:databases/lmdb \
+ libsodium.so:security/libsodium \
+ libolm.so:security/olm \
+ libcmark.so:textproc/cmark
USES= cmake compiler:c++17-lang pkgconfig \
localbase:ldflags qt:5 tar:xz