aboutsummaryrefslogtreecommitdiff
path: root/net-im/nheko/Makefile
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-11-20 22:19:19 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-11-20 22:30:28 +0000
commiteb2c8f8f277508cb76b4936ea1b06d41c59294e3 (patch)
tree3227c107f0885a9f05edaa2da87de354b8557ce7 /net-im/nheko/Makefile
parentba53edfff7f33f38bb7ecf19f813d39ba5729edd (diff)
downloadports-eb2c8f8f277508cb76b4936ea1b06d41c59294e3.tar.gz
ports-eb2c8f8f277508cb76b4936ea1b06d41c59294e3.zip
net-im/nheko: update to 0.9.0, latest upstream
This pulls in an update to mtxclient (which then needs coeurl...). E2E encryption is now fully supported (but not audited). There is VOIP support which is switched off right now because our gstreamer seems to be too old.
Diffstat (limited to 'net-im/nheko/Makefile')
-rw-r--r--net-im/nheko/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/net-im/nheko/Makefile b/net-im/nheko/Makefile
index 4e0892baef42..4bb2aa4f3457 100644
--- a/net-im/nheko/Makefile
+++ b/net-im/nheko/Makefile
@@ -1,7 +1,6 @@
PORTNAME= nheko
DISTVERSIONPREFIX=v
-DISTVERSION= 0.8.2
-PORTREVISION= 4
+DISTVERSION= 0.9.0
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
@@ -14,13 +13,8 @@ BUILD_DEPENDS= nlohmann-json>=3:devel/nlohmann-json
# All those boost-libs are pulled in through mtxclient, which
# links to them but stage-qa still complains.
LIB_DEPENDS= \
- libboost_chrono.so:devel/boost-libs \
- libboost_date_time.so:devel/boost-libs \
- libboost_iostreams.so:devel/boost-libs \
- libboost_regex.so:devel/boost-libs \
- libboost_system.so:devel/boost-libs \
- libboost_thread.so:devel/boost-libs \
libcmark.so:textproc/cmark \
+ libcoeurl.so:ftp/coeurl \
libfmt.so:devel/libfmt \
liblmdb.so:databases/lmdb \
libmatrix_client.so:net-im/mtxclient \
@@ -28,8 +22,8 @@ LIB_DEPENDS= \
libqt5keychain.so:security/qtkeychain \
libspdlog.so:devel/spdlog
-USES= cmake compiler:c++17-lang pkgconfig \
- localbase:ldflags qt:5 ssl tar:xz
+USES= cmake compiler:c++17-lang desktop-file-utils \
+ localbase:ldflags pkgconfig qt:5 ssl tar:xz
USE_QT= concurrent core dbus declarative gui multimedia network \
quickcontrols2 svg widgets \
graphicaleffects_run \
@@ -37,7 +31,7 @@ USE_QT= concurrent core dbus declarative gui multimedia network \
# There is one external dependencie: lmdb++
# - lmdb++ is a single header file, it just needs to be included
-CMAKE_ARGS= -DLMDBXX_INCLUDE_DIR=${WRKSRC}/deps/lmdb
+CMAKE_ARGS= -DLMDBXX_INCLUDE_DIR=${WRKSRC}/deps/lmdb -DVOIP=OFF
CFLAGS+= -DSPDLOG_FMT_EXTERNAL=1
LDFLAGS+= -L${LOCALBASE}/lib -lfmt