aboutsummaryrefslogtreecommitdiff
path: root/net-im/p5-Net-OSCAR/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-10-12 11:27:31 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-10-12 11:27:31 +0000
commit733a2edd02acfafb2046dcfb5388100d2bce4a50 (patch)
tree64ee7d29c572fc021f13848d391720d10c54ae64 /net-im/p5-Net-OSCAR/Makefile
parent51416fdfbca9ec71601c1eb588b67d60a51d1ff8 (diff)
downloadports-733a2edd02acfafb2046dcfb5388100d2bce4a50.tar.gz
ports-733a2edd02acfafb2046dcfb5388100d2bce4a50.zip
Add p5-Net-OSCAR 1.907, perl extension for the AOL Instant Messenger
OSCAR protocol. PR: ports/72103 Submitted by: Kelly Cochran <kcochran@trolans.net>
Notes
Notes: svn path=/head/; revision=118958
Diffstat (limited to 'net-im/p5-Net-OSCAR/Makefile')
-rw-r--r--net-im/p5-Net-OSCAR/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-im/p5-Net-OSCAR/Makefile b/net-im/p5-Net-OSCAR/Makefile
new file mode 100644
index 000000000000..c80270e0b420
--- /dev/null
+++ b/net-im/p5-Net-OSCAR/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: p5-Net-OSCAR
+# Date created: 26 Sep 2004
+# Whom: Kelly Cochran <kcochran@trolans.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-OSCAR
+PORTVERSION= 1.907
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kcochran@trolans.net
+COMMENT= Perl extension for the AOL Instant Messenger OSCAR protocol
+
+PERL_MODBUILD= yes
+
+MAN3= Net::OSCAR.3 \
+ Net::OSCAR::Buddylist.3 \
+ Net::OSCAR::Callbacks.3 \
+ Net::OSCAR::Common.3 \
+ Net::OSCAR::Connection.3 \
+ Net::OSCAR::Connection::Chat.3 \
+ Net::OSCAR::Constants.3 \
+ Net::OSCAR::Screenname.3 \
+ Net::OSCAR::TLV.3 \
+ Net::OSCAR::Utility.3 \
+ Net::OSCAR::XML.3 \
+ Net::OSCAR::_BLInternal.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.if ${PERL_LEVEL} < 500601
+IGNORE= Requires perl 5.6.1+, install lang/perl5.8 and try again
+.endif
+.endif
+
+.include <bsd.port.post.mk>