aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin-sipe
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-05-21 13:41:47 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-05-21 13:41:47 +0000
commit790156855fd991a88947637eab57c3af6847d6dc (patch)
tree9370d35a8c0d29918e71e30c92fd47bcaae88b75 /net-im/pidgin-sipe
parenta69653a10955b06a80f66579bc4a6a5b514343a6 (diff)
downloadports-790156855fd991a88947637eab57c3af6847d6dc.tar.gz
ports-790156855fd991a88947637eab57c3af6847d6dc.zip
- Update to 1.4.0
- While here, use SF macro and fix some identation PR: 134729 Submitted by: John Prather <john.c.prather@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=234332
Diffstat (limited to 'net-im/pidgin-sipe')
-rw-r--r--net-im/pidgin-sipe/Makefile13
-rw-r--r--net-im/pidgin-sipe/distinfo6
-rw-r--r--net-im/pidgin-sipe/files/patch-src-sipe.c38
-rw-r--r--net-im/pidgin-sipe/files/patch-src-uuid.c12
-rw-r--r--net-im/pidgin-sipe/pkg-plist3
5 files changed, 55 insertions, 17 deletions
diff --git a/net-im/pidgin-sipe/Makefile b/net-im/pidgin-sipe/Makefile
index c3a6ac050bf3..dc20e3296d16 100644
--- a/net-im/pidgin-sipe/Makefile
+++ b/net-im/pidgin-sipe/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= pidgin-sipe
-PORTVERSION= 1.3.4
+PORTVERSION= 1.4.0
CATEGORIES= net-im
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= sipe
+MASTER_SITES= SF/sipe
MAINTAINER= john.c.prather@gmail.com
COMMENT= A plugin for Pidgin to provide LCS/OCS connectivity
@@ -27,9 +26,9 @@ USE_GETTEXT= yes
CFLAGS+= "-I/${LOCALBASE}/include"
LIBS+= "-L/${LOCALBASE}/lib"
-CONFIGURE_ENV += CFLAGS="${CFLAGS}" \
- LIBS="${LIBS}" \
- COM_ERR_CFLAGS="-I/usr/include" \
- COM_ERR_LIBS="-L/usr/include -lcom_err"
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}" \
+ LIBS="${LIBS}" \
+ COM_ERR_CFLAGS="-I/usr/include" \
+ COM_ERR_LIBS="-L/usr/lib -lcom_err"
.include <bsd.port.mk>
diff --git a/net-im/pidgin-sipe/distinfo b/net-im/pidgin-sipe/distinfo
index 9e54234c3bef..9e14af75c308 100644
--- a/net-im/pidgin-sipe/distinfo
+++ b/net-im/pidgin-sipe/distinfo
@@ -1,3 +1,3 @@
-MD5 (pidgin-sipe-1.3.4.tar.bz2) = 54648ac3acf2d79f6a77bec8a4a447e4
-SHA256 (pidgin-sipe-1.3.4.tar.bz2) = b3148f85aa007d2bdb21245b6e8c6aed6f23a445d519b9089e5883562050ec36
-SIZE (pidgin-sipe-1.3.4.tar.bz2) = 332453
+MD5 (pidgin-sipe-1.4.0.tar.bz2) = a257978b9e1c02a6816c22cb891c8d68
+SHA256 (pidgin-sipe-1.4.0.tar.bz2) = b9fc97ece9cb2be2c1cd2fd4c755c717f7f70b9e08d461438278e571cb0020e4
+SIZE (pidgin-sipe-1.4.0.tar.bz2) = 333977
diff --git a/net-im/pidgin-sipe/files/patch-src-sipe.c b/net-im/pidgin-sipe/files/patch-src-sipe.c
new file mode 100644
index 000000000000..1c54eec4d1b0
--- /dev/null
+++ b/net-im/pidgin-sipe/files/patch-src-sipe.c
@@ -0,0 +1,38 @@
+*** src/sipe.c.orig Sun May 17 19:09:00 2009
+--- src/sipe.c Tue May 19 11:31:02 2009
+***************
+*** 4734,4742 ****
+ const char *username = purple_account_get_username(account);
+ gc = purple_account_get_connection(account);
+
+! if (strpbrk(username, " \t\v\r\n") != NULL) {
+ gc->wants_to_die = TRUE;
+! purple_connection_error(gc, _("SIP Exchange usernames may not contain whitespaces"));
+ return;
+ }
+
+--- 4734,4742 ----
+ const char *username = purple_account_get_username(account);
+ gc = purple_account_get_connection(account);
+
+! if (strpbrk(username, "\t\v\r\n") != NULL) {
+ gc->wants_to_die = TRUE;
+! purple_connection_error(gc, _("SIP Exchange username contains invalid characters"));
+ return;
+ }
+
+***************
+*** 4757,4762 ****
+--- 4757,4768 ----
+ sip->username = g_strjoin("@", userserver[0], userserver[1], NULL);
+ sip->sipdomain = g_strdup(userserver[1]);
+
++ if (strpbrk(sip->username, " \t\v\r\n") != NULL) {
++ gc->wants_to_die = TRUE;
++ purple_connection_error(gc, _("SIP Exchange usernames may not contain whitespaces"));
++ return;
++ }
++
+ domain_user = g_strsplit(signinname_login[1], "\\", 2);
+ sip->authdomain = (domain_user && domain_user[1]) ? g_strdup(domain_user[0]) : NULL;
+ sip->authuser = (domain_user && domain_user[1]) ? g_strdup(domain_user[1]) : (signinname_login ? g_strdup(signinname_login[1]) : NULL);
diff --git a/net-im/pidgin-sipe/files/patch-src-uuid.c b/net-im/pidgin-sipe/files/patch-src-uuid.c
index ff5fb6e9d2f0..47901bc24e17 100644
--- a/net-im/pidgin-sipe/files/patch-src-uuid.c
+++ b/net-im/pidgin-sipe/files/patch-src-uuid.c
@@ -1,5 +1,5 @@
-*** src/uuid.c.orig Mon Apr 13 09:48:29 2009
---- src/uuid.c Thu May 7 12:40:23 2009
+*** src/uuid.c.orig Sun May 17 19:09:00 2009
+--- src/uuid.c Mon May 18 13:43:53 2009
***************
*** 28,34 ****
--- 28,38 ----
@@ -15,8 +15,8 @@
#ifdef _DLL
#define _WS2TCPIP_H_
***************
-*** 135,141 ****
---- 139,149 ----
+*** 133,139 ****
+--- 137,147 ----
strcpy(ifr.ifr_name, IFR->ifr_name);
if (ioctl(s, SIOCGIFFLAGS, &ifr) == 0) {
if (! (ifr.ifr_flags & IFF_LOOPBACK)) {
@@ -29,8 +29,8 @@
break;
}
***************
-*** 145,151 ****
---- 153,163 ----
+*** 143,149 ****
+--- 151,161 ----
close(s);
if (ok) {
diff --git a/net-im/pidgin-sipe/pkg-plist b/net-im/pidgin-sipe/pkg-plist
index c1cf3c280118..cabe38050bff 100644
--- a/net-im/pidgin-sipe/pkg-plist
+++ b/net-im/pidgin-sipe/pkg-plist
@@ -1,11 +1,12 @@
-lib/pidgin/libsipe.so
lib/pidgin/libsipe.la
+lib/pidgin/libsipe.so
share/locale/da/LC_MESSAGES/pidgin-sipe.mo
share/locale/de/LC_MESSAGES/pidgin-sipe.mo
share/locale/es/LC_MESSAGES/pidgin-sipe.mo
share/locale/fr/LC_MESSAGES/pidgin-sipe.mo
share/locale/hi/LC_MESSAGES/pidgin-sipe.mo
share/locale/ta/LC_MESSAGES/pidgin-sipe.mo
+share/locale/zh_CN/LC_MESSAGES/pidgin-sipe.mo
share/pixmaps/pidgin/protocols/16/sipe.png
share/pixmaps/pidgin/protocols/22/sipe.png
share/pixmaps/pidgin/protocols/48/sipe.png