aboutsummaryrefslogtreecommitdiff
path: root/net-im/profanity
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2015-02-17 16:05:20 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2015-02-17 16:05:20 +0000
commitc9626c8c73dade58a005e45d6b142fef9d6a4004 (patch)
treeb87974c25c74265069feb50f36467f82fb05227a /net-im/profanity
parent4a3f1a86d7dd247f43a1e013c9a0e34a2ccadd8b (diff)
downloadports-c9626c8c73dade58a005e45d6b142fef9d6a4004.tar.gz
ports-c9626c8c73dade58a005e45d6b142fef9d6a4004.zip
Add profanity, an console XMPP client
Notes
Notes: svn path=/head/; revision=379173
Diffstat (limited to 'net-im/profanity')
-rw-r--r--net-im/profanity/Makefile24
-rw-r--r--net-im/profanity/distinfo2
-rw-r--r--net-im/profanity/pkg-descr4
-rw-r--r--net-im/profanity/pkg-plist15
4 files changed, 45 insertions, 0 deletions
diff --git a/net-im/profanity/Makefile b/net-im/profanity/Makefile
new file mode 100644
index 000000000000..432e840939ae
--- /dev/null
+++ b/net-im/profanity/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= profanity
+PORTVERSION= 0.4.5
+CATEGORIES= net-im
+MASTER_SITES= http://www.profanity.im/
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Console based XMPP client
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libstrophe.so:${PORTNAME}/net-im/libstrophe \
+ libglib-2.0.so:${PORTSDIR}/devel/glib20 \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libotr.so:${PORTSDIR}/security/libotr3
+
+USES= ncurses pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-otr
+CONFIGURE_ENV= LIBS="${CFLAGS} -lcrypto"
+
+.include <bsd.port.mk>
diff --git a/net-im/profanity/distinfo b/net-im/profanity/distinfo
new file mode 100644
index 000000000000..328d1ca16dd8
--- /dev/null
+++ b/net-im/profanity/distinfo
@@ -0,0 +1,2 @@
+SHA256 (profanity-0.4.5.tar.gz) = 7436b38d03da0645f5cdb3ca3921b974a760ba68fa92e4def82519d759c7fc63
+SIZE (profanity-0.4.5.tar.gz) = 411095
diff --git a/net-im/profanity/pkg-descr b/net-im/profanity/pkg-descr
new file mode 100644
index 000000000000..094a6a65b661
--- /dev/null
+++ b/net-im/profanity/pkg-descr
@@ -0,0 +1,4 @@
+Profanity is a console based XMPP client written in C using ncurses and
+libstrophe, inspired by Irssi
+
+WWW: http://www.profanity.im/
diff --git a/net-im/profanity/pkg-plist b/net-im/profanity/pkg-plist
new file mode 100644
index 000000000000..885a0252b061
--- /dev/null
+++ b/net-im/profanity/pkg-plist
@@ -0,0 +1,15 @@
+bin/profanity
+man/man1/profanity.1.gz
+share/profanity/themes/aqua
+share/profanity/themes/batman
+share/profanity/themes/boothj5
+share/profanity/themes/hacker
+share/profanity/themes/headache
+share/profanity/themes/joker
+share/profanity/themes/orange
+share/profanity/themes/original
+share/profanity/themes/redsplash
+share/profanity/themes/shade
+share/profanity/themes/spawn
+share/profanity/themes/whiteness
+share/profanity/themes/yellowsplash