aboutsummaryrefslogtreecommitdiff
path: root/net-im/prosody
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2014-10-22 23:56:02 +0000
committerDavid Thiel <lx@FreeBSD.org>2014-10-22 23:56:02 +0000
commit270d775d400af50e2626b08fb12a80d226104f81 (patch)
tree2f4fb5090c2e5ef57405a8f7fc731a60e3f10be3 /net-im/prosody
parent4f3ede694e788c87b76fd6b82547dbeee28d47d2 (diff)
downloadports-270d775d400af50e2626b08fb12a80d226104f81.tar.gz
ports-270d775d400af50e2626b08fb12a80d226104f81.zip
Add reload command to rc script, fix luajit support
PR: 194037 194039 Submitted by: Anton Yuzhaninov
Notes
Notes: svn path=/head/; revision=371371
Diffstat (limited to 'net-im/prosody')
-rw-r--r--net-im/prosody/Makefile17
-rw-r--r--net-im/prosody/files/prosody.in3
2 files changed, 10 insertions, 10 deletions
diff --git a/net-im/prosody/Makefile b/net-im/prosody/Makefile
index 6a0659302e4f..b96605cd6b45 100644
--- a/net-im/prosody/Makefile
+++ b/net-im/prosody/Makefile
@@ -3,7 +3,7 @@
PORTNAME= prosody
PORTVERSION= 0.9.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-im
MASTER_SITES= http://prosody.im/downloads/source/ \
http://redundancy.redundancy.org/mirror/
@@ -25,9 +25,9 @@ GROUPS= ${USERS}
USE_RC_SUBR= prosody
-OPTIONS_DEFINE= LUAJIT
-LUAJIT_DESC= Run prosody using luajit
-LUAJIT_LIB_DEPENDS= libluajit-5.1.so:${PORTSDIR}/lang/luajit
+OPTIONS_DEFINE= LUAJIT
+LUAJIT_DESC= Run prosody using luajit
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so:${PORTSDIR}/lang/luajit
.include <bsd.port.options.mk>
@@ -35,17 +35,16 @@ USES= gmake lua:51 shebangfix
SHEBANG_LANG= lua
SHEBANG_FILES= prosody prosodyctl
lua_OLD_CMD= ${SETENV} lua
+.if ${PORT_OPTIONS:MLUAJIT}
+lua_CMD= ${LOCALBASE}/bin/luajit
+.else
lua_CMD= ${LOCALBASE}/bin/${LUA_CMD}
+.endif
LUA_PREMK= yes
.include <bsd.port.pre.mk>
HAS_CONFIGURE= yes
-.if ${PORT_OPTIONS:MLUAJIT}
-CONFIGURE_ARGS+= --runwith=`which luajit`
-.else
-CONFIGURE_ARGS+= --runwith=`which ${LUA_CMD}`
-.endif
CONFIGURE_ARGS+= --ostype=freebsd --c-compiler="${CC}" --linker="${LD}" --with-lua-include="${LUA_INCDIR}"
CONFIGURE_ENV+= LOCALBASE="${LOCALBASE}" PREFIX="${PREFIX}" LUA_SUFFIX="-${LUA_VER}" LUA_LIBDIR="${LUA_LIBDIR}" LUA_INCDIR="${LUA_INCDIR}"
diff --git a/net-im/prosody/files/prosody.in b/net-im/prosody/files/prosody.in
index ee48176af067..3faf2501f198 100644
--- a/net-im/prosody/files/prosody.in
+++ b/net-im/prosody/files/prosody.in
@@ -23,10 +23,11 @@ load_rc_config $name
prosody_enable=${prosody_enable:-"NO"}
pidfile=${prosody_pidfile:-"%%PREFIX%%/var/lib/prosody/prosody.pid"}
-extra_commands="status"
+extra_commands="reload status"
start_cmd="prosody_start"
stop_cmd="prosody_cmd stop"
+reload_cmd="prosody_cmd reload"
restart_cmd="$stop_cmd; $start_cmd"
status_cmd="prosody_cmd status"