aboutsummaryrefslogtreecommitdiff
path: root/net-im/quaternion/Makefile
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2019-03-07 22:47:52 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2019-03-07 22:47:52 +0000
commit7b8be605750fe92b1577594f87a135d2fd7367ed (patch)
tree54c0ab75d95fe36bc0ecfb51e3990c6825539cba /net-im/quaternion/Makefile
parent2354e3faa0d7b05efb5472b8f3f095ff8d305770 (diff)
downloadports-7b8be605750fe92b1577594f87a135d2fd7367ed.tar.gz
ports-7b8be605750fe92b1577594f87a135d2fd7367ed.zip
net-im/quaternion uses C++17 features (which generate a warning from
clang in C++11 mode, not an error). While here, pet portlint.
Notes
Notes: svn path=/head/; revision=495003
Diffstat (limited to 'net-im/quaternion/Makefile')
-rw-r--r--net-im/quaternion/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/net-im/quaternion/Makefile b/net-im/quaternion/Makefile
index 9209ce881d32..6821bced908c 100644
--- a/net-im/quaternion/Makefile
+++ b/net-im/quaternion/Makefile
@@ -11,14 +11,17 @@ COMMENT= Matrix IM client based on Qt technologies
LICENSE= GPLv3
LICENSE_FILES= ${WRKSRC}/COPYING
-USE_GITHUB= yes
-GH_ACCOUNT= QMatrixClient
+LIB_DEPENDS= libqt5keychain.so:security/qtkeychain@qt5 \
+ libsecret-1.so:security/libsecret
+BUILD_DEPENDS= libqmatrixclient>=0.5:net-im/libqmatrixclient
-LIB_DEPENDS= libqt5keychain.so:security/qtkeychain@qt5
-BUILD_DEPENDS= ${LOCALBASE}/lib/libQMatrixClient.a:net-im/libqmatrixclient
+USES= cmake compiler:c++17-lang gettext-runtime gnome \
+ localbase:ldflags qt:5 tar:xz
+USE_GNOME= glib20
+USE_QT= core dbus declarative gui multimedia network widgets \
+ buildtools_build linguist_build qmake_build
-USES= cmake compiler:c++17-lang localbase:ldflags qt:5 tar:xz
-USE_QT= core declarative gui network widgets \
- buildtools_build linguist_build qmake_build
+USE_GITHUB= yes
+GH_ACCOUNT= QMatrixClient
.include <bsd.port.mk>