aboutsummaryrefslogtreecommitdiff
path: root/net-im/sayaka
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-11-03 22:50:32 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-11-03 22:50:32 +0000
commit0e7c254e76d58bc168636f91ed9f06780ca2bbad (patch)
tree022969584259face97f2c0606a5f96979c56860c /net-im/sayaka
parent54782d57d4c68b364a2062f48d143de24e712210 (diff)
downloadports-0e7c254e76d58bc168636f91ed9f06780ca2bbad.tar.gz
ports-0e7c254e76d58bc168636f91ed9f06780ca2bbad.zip
Fix build with curl 7.62.0
- While I'm here, add USES=gnome
Notes
Notes: svn path=/head/; revision=483948
Diffstat (limited to 'net-im/sayaka')
-rw-r--r--net-im/sayaka/Makefile2
-rw-r--r--net-im/sayaka/files/patch-libcurl.vapi19
2 files changed, 20 insertions, 1 deletions
diff --git a/net-im/sayaka/Makefile b/net-im/sayaka/Makefile
index 8e837cb0fc20..3aa74bc8d12e 100644
--- a/net-im/sayaka/Makefile
+++ b/net-im/sayaka/Makefile
@@ -12,7 +12,7 @@ LICENSE= BSD2CLAUSE
BUILD_DEPENDS= valac:lang/vala
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= gettext-runtime pkgconfig
+USES= gettext-runtime gnome pkgconfig
USE_GNOME= glib20 gdkpixbuf2
USE_GITHUB= yes
diff --git a/net-im/sayaka/files/patch-libcurl.vapi b/net-im/sayaka/files/patch-libcurl.vapi
new file mode 100644
index 000000000000..2bbcff6620c0
--- /dev/null
+++ b/net-im/sayaka/files/patch-libcurl.vapi
@@ -0,0 +1,19 @@
+--- libcurl.vapi.orig 2016-09-25 11:53:37 UTC
++++ libcurl.vapi
+@@ -236,7 +236,6 @@ namespace Native.Curl {
+ TOO_MANY_REDIRECTS,
+ UNKNOWN_OPTION,
+ TELNET_OPTION_SYNTAX,
+- PEER_FAILED_VERIFICATION,
+ GOT_NOTHING,
+ SSL_ENGINE_NOTFOUND,
+ SSL_ENGINE_SETFAILED,
+@@ -244,7 +243,7 @@ namespace Native.Curl {
+ RECV_ERROR,
+ SSL_CERTPROBLEM,
+ SSL_CIPHER,
+- SSL_CACERT,
++ PEER_FAILED_VERIFICATION,
+ BAD_CONTENT_ENCODING,
+ LDAP_INVALID_URL,
+ FILESIZE_EXCEEDED,