aboutsummaryrefslogtreecommitdiff
path: root/net-im/slack-term/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-04 08:10:30 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-04 08:10:30 +0000
commit1998171b2220bcf33895b3142649ef62259a9a20 (patch)
treef7093c255944fb43f8a67530ad66d07657786303 /net-im/slack-term/Makefile
parent4c26f3eadd207c4ad1c714071257258330f3a6f2 (diff)
New port: net-im/slack-term: Slack client for your terminal
PR: 226332 Submitted by: Dmitri Goutnik <dg@syrec.org> Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D14577
Notes
Notes: svn path=/head/; revision=463556
Diffstat (limited to 'net-im/slack-term/Makefile')
-rw-r--r--net-im/slack-term/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-im/slack-term/Makefile b/net-im/slack-term/Makefile
new file mode 100644
index 000000000000..a1dc22f5f133
--- /dev/null
+++ b/net-im/slack-term/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= slack-term
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.2
+CATEGORIES= net-im
+
+MAINTAINER= dg@syrec.org
+COMMENT= Slack client for your terminal
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= go:lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= erroneousboat
+GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${PORTNAME}
+
+SUB_FILES= pkg-message
+SUB_LIST= PORTNAME=${PORTNAME}
+
+PORTDOCS= README.md
+
+PLIST_FILES= bin/slack-term
+
+OPTIONS_DEFINE= DOCS
+
+do-build:
+ @cd ${WRKSRC}/${GH_SUBDIR} && \
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build -o ${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>