aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-qt4
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-01-15 01:41:45 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-01-15 01:41:45 +0000
commit2769285c72e5c5aa57b69320399349c869e797d2 (patch)
tree28dd4ac7d1cd79987757ea34eaa57eee91b6d54c /net-im/telepathy-qt4
parenta0d909b284122a6eee974a24610acaf70c0d345c (diff)
downloadports-2769285c72e5c5aa57b69320399349c869e797d2.tar.gz
ports-2769285c72e5c5aa57b69320399349c869e797d2.zip
- Fix build with Clang solving an ambiguity with parenthesis.
Notes
Notes: svn path=/head/; revision=289246
Diffstat (limited to 'net-im/telepathy-qt4')
-rw-r--r--net-im/telepathy-qt4/Makefile2
-rw-r--r--net-im/telepathy-qt4/files/patch-TelepathyQt4__optional-interface-factory.h20
2 files changed, 21 insertions, 1 deletions
diff --git a/net-im/telepathy-qt4/Makefile b/net-im/telepathy-qt4/Makefile
index e1761cdda21b..52c0ea698be6 100644
--- a/net-im/telepathy-qt4/Makefile
+++ b/net-im/telepathy-qt4/Makefile
@@ -24,8 +24,8 @@ USE_PYTHON_BUILD= 2.5+
USE_QT_VER= 4
QT_COMPONENTS= dbus gui network qtestlib_build xml \
moc_build qmake_build rcc_build uic_build
-MAKE_JOBS_SAFE= yes
USE_CMAKE= yes
+MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
PORTDOCS= AUTHORS ChangeLog HACKING NEWS README html
diff --git a/net-im/telepathy-qt4/files/patch-TelepathyQt4__optional-interface-factory.h b/net-im/telepathy-qt4/files/patch-TelepathyQt4__optional-interface-factory.h
new file mode 100644
index 000000000000..e45a9fc0d3d6
--- /dev/null
+++ b/net-im/telepathy-qt4/files/patch-TelepathyQt4__optional-interface-factory.h
@@ -0,0 +1,20 @@
+--- ./TelepathyQt4/optional-interface-factory.h.orig 2012-01-13 15:03:15.336883448 +0100
++++ ./TelepathyQt4/optional-interface-factory.h 2012-01-13 15:03:58.296892805 +0100
+@@ -97,7 +97,7 @@
+ InterfaceSupportedChecking check = CheckInterfaceSupported) const
+ {
+ // Check for the remote object supporting the interface
+- QString name(QLatin1String(Interface::staticInterfaceName()));
++ QString name( (QLatin1String(Interface::staticInterfaceName())) );
+ if (check == CheckInterfaceSupported && !mInterfaces.contains(name)) {
+ return 0;
+ }
+@@ -113,7 +113,7 @@
+ Q_UNUSED(interfaceMustBeASubclassOfAbstractInterface);
+
+ // If there is a interface cached already, return it
+- QString name(QLatin1String(Interface::staticInterfaceName()));
++ QString name( (QLatin1String(Interface::staticInterfaceName())) );
+ AbstractInterface *cached = getCached(name);
+ if (cached)
+ return static_cast<Interface *>(cached);