aboutsummaryrefslogtreecommitdiff
path: root/net-im/toxic
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-09-08 20:38:21 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-09-08 20:38:21 +0000
commit09b195259f50a5cbdc60463c1069845aff532568 (patch)
treed959d9be520e0b60b479f7636a9c7ff7dc0a15f6 /net-im/toxic
parentbdc71bbf2f85a7133cfd95471f6db91d53651372 (diff)
downloadports-09b195259f50a5cbdc60463c1069845aff532568.tar.gz
ports-09b195259f50a5cbdc60463c1069845aff532568.zip
Refresh.
Notes
Notes: svn path=/head/; revision=367697
Diffstat (limited to 'net-im/toxic')
-rw-r--r--net-im/toxic/Makefile13
-rw-r--r--net-im/toxic/distinfo4
-rw-r--r--net-im/toxic/files/patch-build_Makefile15
-rw-r--r--net-im/toxic/files/patch-src_misc_tools.c18
4 files changed, 12 insertions, 38 deletions
diff --git a/net-im/toxic/Makefile b/net-im/toxic/Makefile
index 3c8f001aeaee..5ddc6d664a54 100644
--- a/net-im/toxic/Makefile
+++ b/net-im/toxic/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= toxic
-PORTVERSION= 0.4.7.140815
+PORTVERSION= 0.5.0.140908
CATEGORIES= net-im
MAINTAINER= thierry@FreeBSD.org
@@ -21,7 +21,14 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= tox
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= 67f637a
+GH_COMMIT= 09f90d0
+
+OPTIONS_DEFINE= X11
+OPTIONS_DEFAULT=X11
+
+X11_USE= XORG=x11
+X11_CFLAGS_OFF= DISABLE_X11=1 DISABLE_DESKTOP_NOTIFY=1
+X11_LIB_DEPENDS=libnotify.so:${PORTSDIR}/devel/libnotify
WRKSRC= ${WRKDIR}/Tox-${PORTNAME}-${GH_COMMIT}
BUILD_WRKSRC= ${WRKSRC}/build
@@ -40,7 +47,7 @@ LDFLAGS+= -B${LOCALBASE}/bin
pre-configure:
${REINPLACE_CMD} -e 's|PREFIX =|PREFIX?=|;s|$$(shell git rev-list HEAD --count)|${GH_COMMIT}|' \
- ${BUILD_WRKSRC}/${MAKEFILE}
+ ${WRKSRC}/cfg/global_vars.mk
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/toxic
diff --git a/net-im/toxic/distinfo b/net-im/toxic/distinfo
index fcaf96a7eeaf..c2454a1ace58 100644
--- a/net-im/toxic/distinfo
+++ b/net-im/toxic/distinfo
@@ -1,2 +1,2 @@
-SHA256 (toxic-0.4.7.140815.tar.gz) = 24017bcd4e14bc5e6b5efc23e339ec818394d0b332eb3a9f0b9c9b446da9941f
-SIZE (toxic-0.4.7.140815.tar.gz) = 4070353
+SHA256 (toxic-0.5.0.140908.tar.gz) = a450d6271ec617de89cfd62a1feb4a9cc8650e7be2f6c1227cb37a98609105c9
+SIZE (toxic-0.5.0.140908.tar.gz) = 4075659
diff --git a/net-im/toxic/files/patch-build_Makefile b/net-im/toxic/files/patch-build_Makefile
deleted file mode 100644
index ce4339d6cf50..000000000000
--- a/net-im/toxic/files/patch-build_Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- build/Makefile.orig 2014-08-15 03:31:28.000000000 +0200
-+++ build/Makefile 2014-08-15 16:56:36.000000000 +0200
-@@ -4,10 +4,10 @@
-
- CFG_DIR = ../cfg
- SRC_DIR = ../src
--PREFIX = /usr/local
-+#PREFIX = /usr/local
- BINDIR = $(PREFIX)/bin
- DATADIR = $(PREFIX)/share/toxic
--MANDIR = $(PREFIX)/share/man
-+MANDIR = $(PREFIX)/man
-
- LIBS = libtoxcore ncursesw libconfig
-
diff --git a/net-im/toxic/files/patch-src_misc_tools.c b/net-im/toxic/files/patch-src_misc_tools.c
deleted file mode 100644
index 135638db85f1..000000000000
--- a/net-im/toxic/files/patch-src_misc_tools.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/misc_tools.c.orig 2014-08-15 03:31:28.000000000 +0200
-+++ src/misc_tools.c 2014-08-15 16:51:14.000000000 +0200
-@@ -38,6 +38,7 @@
-
- static uint64_t current_unix_time;
-
-+/* Allready defined in libtoxcore
- void host_to_net(uint8_t *num, uint16_t numbytes)
- {
- #ifndef WORDS_BIGENDIAN
-@@ -52,6 +53,7 @@
- #endif
- return;
- }
-+*/
-
- void update_unix_time(void)
- {