aboutsummaryrefslogtreecommitdiff
path: root/net-im/toxic
diff options
context:
space:
mode:
authorAndriy Voskoboinyk <avos@FreeBSD.org>2019-07-16 06:57:13 +0000
committerAndriy Voskoboinyk <avos@FreeBSD.org>2019-07-16 06:57:13 +0000
commit5d4f8493bc30800aaaf3696741f17109d2c6af23 (patch)
tree616dc8ff8f5232bc00943f0df39e62b29466d2d3 /net-im/toxic
parent549d2ad4c337908eca7046b33036fe4072d3ee26 (diff)
downloadports-5d4f8493bc30800aaaf3696741f17109d2c6af23.tar.gz
ports-5d4f8493bc30800aaaf3696741f17109d2c6af23.zip
net-im/toxic: drop unused dependencies, unbreak PYTHON option
- Remove security/libsodium and audio/opus dependencies; the port does not reference nor links against them. - Allow to use ncurses from base (if possible). - Patch python3 detection to use proper pkgconfig/python3-config and bin/python3 paths. - Move USES upper (portlint). - Bump PORTREVISION. PR: 239215 Approved by: portmgr (blanket(s): dependencies, build fix(es)) MFH: 2019Q3
Notes
Notes: svn path=/head/; revision=506727
Diffstat (limited to 'net-im/toxic')
-rw-r--r--net-im/toxic/Makefile17
-rw-r--r--net-im/toxic/files/patch-Makefile13
2 files changed, 24 insertions, 6 deletions
diff --git a/net-im/toxic/Makefile b/net-im/toxic/Makefile
index 8ef143c66727..d59764ebd591 100644
--- a/net-im/toxic/Makefile
+++ b/net-im/toxic/Makefile
@@ -4,7 +4,7 @@
PORTNAME= toxic
PORTVERSION= 0.8.3
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MAINTAINER= thierry@FreeBSD.org
@@ -16,20 +16,18 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:net-im/tox \
${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
LIB_DEPENDS= libvpx.so:multimedia/libvpx \
- libsodium.so:security/libsodium \
- libpng.so:graphics/png \
- libopus.so:audio/opus \
+ libpng.so:graphics/png \
libcurl.so:ftp/curl \
libv4l2.so:multimedia/libv4l \
libqrencode.so:graphics/libqrencode \
libconfig.so:devel/libconfig
RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:net-im/tox
+USES= desktop-file-utils gettext-runtime gmake ncurses openal:al,alut pkgconfig
+
USE_GITHUB= yes
GH_ACCOUNT= JFreegman
-USES= desktop-file-utils gettext-runtime gmake ncurses:port openal:al,alut pkgconfig
-
OPTIONS_DEFINE= X11 PYTHON
OPTIONS_DEFAULT=X11
@@ -41,11 +39,18 @@ X11_LIB_DEPENDS=libnotify.so:devel/libnotify
PYTHON_USES= python:3.3+
PYTHON_MAKE_ARGS= ENABLE_PYTHON=1
+CFLAGS+= -I${NCURSESINC}
+LDFLAGS+= -L${NCURSESLIB}
MAKE_ENV= USER_CFLAGS="${CFLAGS}" USER_LDFLAGS="${LDFLAGS}" \
MANDIR="${MANPREFIX}/man"
LLD_UNSAFE= yes
SUB_FILES= pkg-message
+post-patch-PYTHON-on:
+ ${REINPLACE_CMD} -e '/PYTHON3_LIBS/ s|python3|python-${PYTHON_VER}|' \
+ -e 's|python3-config|${PYTHON_VERSION}-config|g' \
+ ${WRKSRC}/cfg/checks/python.mk
+
pre-configure:
${REINPLACE_CMD} -e 's|PREFIX =|PREFIX?=|;s|$$(shell git rev-list HEAD.*$$|${GH_TAGNAME}|' \
${WRKSRC}/cfg/global_vars.mk
diff --git a/net-im/toxic/files/patch-Makefile b/net-im/toxic/files/patch-Makefile
new file mode 100644
index 000000000000..26f08944f975
--- /dev/null
+++ b/net-im/toxic/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2019-07-14 18:05:38 UTC
++++ Makefile
+@@ -23,6 +23,10 @@ UNAME_S = $(shell uname -s)
+ ifeq ($(UNAME_S), Linux)
+ LDFLAGS += -ldl -lrt
+ endif
++ifeq ($(UNAME_S), FreeBSD)
++LIBS := $(filter-out ncursesw, $(LIBS))
++LDFLAGS += -lncursesw
++endif
+ ifeq ($(UNAME_S), OpenBSD)
+ LIBS := $(filter-out ncursesw, $(LIBS))
+ LDFLAGS += -lncursesw