aboutsummaryrefslogtreecommitdiff
path: root/net-im/toxic
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2017-06-08 20:37:18 +0000
committerThierry Thomas <thierry@FreeBSD.org>2017-06-08 20:37:18 +0000
commitbce8db559772684ed0ced78407cf59660a51ceac (patch)
tree5599756cc1bd517997fcf315b3d652a5887b2c8b /net-im/toxic
parentb9a868dd2334f6a09576873377f1e111bdd196ec (diff)
downloadports-bce8db559772684ed0ced78407cf59660a51ceac.tar.gz
ports-bce8db559772684ed0ced78407cf59660a51ceac.zip
Upgrade to 0.8.0.
Changelog at <https://github.com/JFreegman/toxic/releases/tag/v0.8.0>. Note: adding a new option for Python binding, disabled by default.
Notes
Notes: svn path=/head/; revision=442958
Diffstat (limited to 'net-im/toxic')
-rw-r--r--net-im/toxic/Makefile8
-rw-r--r--net-im/toxic/distinfo6
-rw-r--r--net-im/toxic/files/patch-cfg_global__vars.mk20
3 files changed, 28 insertions, 6 deletions
diff --git a/net-im/toxic/Makefile b/net-im/toxic/Makefile
index 5701ff6892c5..3b5c264d627c 100644
--- a/net-im/toxic/Makefile
+++ b/net-im/toxic/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= toxic
-PORTVERSION= 0.7.2
-PORTREVISION= 1
+PORTVERSION= 0.8.0
DISTVERSIONPREFIX= v
CATEGORIES= net-im
@@ -28,13 +27,16 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= JFreegman
-OPTIONS_DEFINE= X11
+OPTIONS_DEFINE= X11 PYTHON
OPTIONS_DEFAULT=X11
X11_USE= GNOME=gdkpixbuf2,glib20 XORG=x11
X11_MAKE_ARGS_OFF= DISABLE_X11=1 DISABLE_DESKTOP_NOTIFY=1
X11_LIB_DEPENDS=libnotify.so:devel/libnotify
+PYTHON_VARS= USES+=python:3.3+
+PYTHON_MAKE_ARGS= ENABLE_PYTHON=1
+
MAKE_ENV= USER_CFLAGS="${CFLAGS}" USER_LDFLAGS="${LDFLAGS}"
SUB_FILES= pkg-message
diff --git a/net-im/toxic/distinfo b/net-im/toxic/distinfo
index d0ebe5b44121..0f6cba663ef8 100644
--- a/net-im/toxic/distinfo
+++ b/net-im/toxic/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1487003244
-SHA256 (JFreegman-toxic-v0.7.2_GH0.tar.gz) = a2962aca766caf84b52a52e9a5ce2276a9d3906685f565d2a00551e7c2916c59
-SIZE (JFreegman-toxic-v0.7.2_GH0.tar.gz) = 1136947
+TIMESTAMP = 1496951410
+SHA256 (JFreegman-toxic-v0.8.0_GH0.tar.gz) = 4078167ff09a94a78cd46d55163524b0a6692b56a74458c99093b84316a6c604
+SIZE (JFreegman-toxic-v0.8.0_GH0.tar.gz) = 1145799
diff --git a/net-im/toxic/files/patch-cfg_global__vars.mk b/net-im/toxic/files/patch-cfg_global__vars.mk
new file mode 100644
index 000000000000..abc4a9f2f3ee
--- /dev/null
+++ b/net-im/toxic/files/patch-cfg_global__vars.mk
@@ -0,0 +1,20 @@
+--- cfg/global_vars.mk.orig 2017-05-24 18:57:32 UTC
++++ cfg/global_vars.mk
+@@ -1,11 +1,11 @@
+ # Version
+-TOXIC_VERSION = 0.7.2
+-REV = $(shell git rev-list HEAD --count 2>/dev/null || echo -n "error")
+-ifneq (, $(findstring error, $(REV)))
++TOXIC_VERSION = 0.8.0
++#REV = $(shell git rev-list HEAD --count 2>/dev/null || echo -n "error")
++#ifneq (, $(findstring error, $(REV)))
+ VERSION = $(TOXIC_VERSION)
+-else
+- VERSION = $(TOXIC_VERSION)_r$(REV)
+-endif
++#else
++# VERSION = $(TOXIC_VERSION)_r$(REV)
++#endif
+
+ # Project directories
+ BUILD_DIR = $(BASE_DIR)/build