aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-07-03 20:52:54 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-07-03 20:52:54 +0000
commit1116efdafd74a3c43d6a933f60358f88c55dda97 (patch)
tree28c82bbda40943106905bfb2e8e8700a0bbf0cd5 /net-im
parent991db535c95fa94368a59444f5aba2365a575ea4 (diff)
downloadports-1116efdafd74a3c43d6a933f60358f88c55dda97.tar.gz
ports-1116efdafd74a3c43d6a933f60358f88c55dda97.zip
New port: net-im/libaccounts-glib.
From pkg-descr: Accounts and SSO (Single Sign-On) framework for Linux and POSIX based platforms. WWW: https://code.google.com/p/accounts-sso/ Necessary for the upcoming libaccounts-qt5, which is used in newer versions of KDE Telepathy. Submitted by: Tobias Berner <tcberner@gmail.com> via area51
Notes
Notes: svn path=/head/; revision=391272
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/libaccounts-glib/Makefile33
-rw-r--r--net-im/libaccounts-glib/distinfo2
-rw-r--r--net-im/libaccounts-glib/files/patch-libaccounts-glib_ag-manager.c21
-rw-r--r--net-im/libaccounts-glib/pkg-descr3
-rw-r--r--net-im/libaccounts-glib/pkg-plist75
6 files changed, 135 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 41945c4bff91..06e269aadb6e 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -54,6 +54,7 @@
SUBDIR += ktp-kded-integration-module
SUBDIR += ktp-send-file
SUBDIR += ktp-text-ui
+ SUBDIR += libaccounts-glib
SUBDIR += libjreen
SUBDIR += libnice
SUBDIR += libnice-gst010
diff --git a/net-im/libaccounts-glib/Makefile b/net-im/libaccounts-glib/Makefile
new file mode 100644
index 000000000000..b4271ed4959f
--- /dev/null
+++ b/net-im/libaccounts-glib/Makefile
@@ -0,0 +1,33 @@
+# Created by: Tobias C. Berner <tcberner@gmail.com>
+# $FreeBSD$
+
+PORTNAME= libaccounts-glib
+PORTVERSION= 1.18
+CATEGORIES= net-im
+MASTER_SITES= https://drive.google.com/uc?export=download&id=0B8fX9XOwH_g4U1NzNmg0cWoxNGM&dummy= \
+ LOCAL/rakuco
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Accounts and SSO framework for Linux and POSIX based platforms
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libsqlite3.so:${PORTSDIR}/databases/sqlite3
+
+FETCH_BEFORE_ARGS= -o ${DISTFILES}
+
+GNU_CONFIGURE= YES
+# The line below is a hack required when the port is configure either without
+# devel/libcheck installed or with --disable-tests.
+# A proper fix has been submitted upstream:
+# https://gitlab.com/accounts-sso/libaccounts-glib/merge_requests/1
+CONFIGURE_ENV= HAVE_GCOV_FALSE='\#'
+CONFIGURE_ARGS= --disable-tests
+INSTALL_TARGET= install-strip
+
+USES= gmake libtool pathfix pkgconfig python
+USE_GNOME= pygobject3 introspection libxml2
+
+.include <bsd.port.mk>
diff --git a/net-im/libaccounts-glib/distinfo b/net-im/libaccounts-glib/distinfo
new file mode 100644
index 000000000000..bbf03f892719
--- /dev/null
+++ b/net-im/libaccounts-glib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libaccounts-glib-1.18.tar.gz) = 7aab9ec2ba3ae2548125f4bb330ed433e8066c672e32101a339cbb7f4657ff56
+SIZE (libaccounts-glib-1.18.tar.gz) = 579435
diff --git a/net-im/libaccounts-glib/files/patch-libaccounts-glib_ag-manager.c b/net-im/libaccounts-glib/files/patch-libaccounts-glib_ag-manager.c
new file mode 100644
index 000000000000..7bf0947aba99
--- /dev/null
+++ b/net-im/libaccounts-glib/files/patch-libaccounts-glib_ag-manager.c
@@ -0,0 +1,21 @@
+Fixes the following build error with clang:
+
+ag-manager.c:503:16: error: implicit conversion from enumeration type 'AgAccountsError' to different enumeration type 'AgError' [-Werror,-Wenum-conversion]
+ code = AG_ACCOUNTS_ERROR_DB_LOCKED;
+ ~ ^~~~~~~~~~~~~~~~~~~~~~~~~~~
+ag-manager.c:508:16: error: implicit conversion from enumeration type 'AgAccountsError' to different enumeration type 'AgError' [-Werror,-Wenum-conversion]
+ code = AG_ACCOUNTS_ERROR_DB;
+ ~ ^~~~~~~~~~~~~~~~~~~~
+
+Sent upstream: https://gitlab.com/accounts-sso/libaccounts-glib/merge_requests/3
+--- libaccounts-glib/ag-manager.c
++++ libaccounts-glib/ag-manager.c
+@@ -490,7 +490,7 @@ static void
+ set_error_from_db (AgManager *manager)
+ {
+ AgManagerPrivate *priv = manager->priv;
+- AgError code;
++ AgAccountsError code;
+ GError *error;
+
+ switch (sqlite3_errcode (priv->db))
diff --git a/net-im/libaccounts-glib/pkg-descr b/net-im/libaccounts-glib/pkg-descr
new file mode 100644
index 000000000000..647a08c6a888
--- /dev/null
+++ b/net-im/libaccounts-glib/pkg-descr
@@ -0,0 +1,3 @@
+Accounts and SSO (Single Sign-On) framework for Linux and POSIX based platforms.
+
+WWW: https://code.google.com/p/accounts-sso/
diff --git a/net-im/libaccounts-glib/pkg-plist b/net-im/libaccounts-glib/pkg-plist
new file mode 100644
index 000000000000..0d2a5070bd60
--- /dev/null
+++ b/net-im/libaccounts-glib/pkg-plist
@@ -0,0 +1,75 @@
+bin/ag-backup
+bin/ag-tool
+include/libaccounts-glib/accounts-glib.h
+include/libaccounts-glib/ag-account-service.h
+include/libaccounts-glib/ag-account.h
+include/libaccounts-glib/ag-application.h
+include/libaccounts-glib/ag-auth-data.h
+include/libaccounts-glib/ag-errors.h
+include/libaccounts-glib/ag-manager.h
+include/libaccounts-glib/ag-provider.h
+include/libaccounts-glib/ag-service-type.h
+include/libaccounts-glib/ag-service.h
+include/libaccounts-glib/ag-types.h
+lib/girepository-1.0/Accounts-1.0.typelib
+lib/libaccounts-glib.so
+lib/libaccounts-glib.so.0
+lib/libaccounts-glib.so.0.1.3
+libdata/pkgconfig/libaccounts-glib.pc
+%%PYTHON_SITELIBDIR%%/gi/overrides/Accounts.py
+%%PYTHON_SITELIBDIR%%/gi/overrides/Accounts.pyc
+%%PYTHON_SITELIBDIR%%/gi/overrides/Accounts.pyo
+share/backup-framework/applications/accounts.conf
+share/dbus-1/interfaces/com.google.code.AccountsSSO.Accounts.Manager.xml
+share/gir-1.0/Accounts-1.0.gir
+share/gtk-doc/html/libaccounts-glib/AgAccount.html
+share/gtk-doc/html/libaccounts-glib/AgAccountService.html
+share/gtk-doc/html/libaccounts-glib/AgApplication.html
+share/gtk-doc/html/libaccounts-glib/AgAuthData.html
+share/gtk-doc/html/libaccounts-glib/AgManager.html
+share/gtk-doc/html/libaccounts-glib/AgProvider.html
+share/gtk-doc/html/libaccounts-glib/AgService.html
+share/gtk-doc/html/libaccounts-glib/AgServiceType.html
+share/gtk-doc/html/libaccounts-glib/account-management.html
+share/gtk-doc/html/libaccounts-glib/ag-backup.html
+share/gtk-doc/html/libaccounts-glib/ag-tool.html
+share/gtk-doc/html/libaccounts-glib/annotation-glossary.html
+share/gtk-doc/html/libaccounts-glib/api-index-1-1.html
+share/gtk-doc/html/libaccounts-glib/api-index-1-2.html
+share/gtk-doc/html/libaccounts-glib/api-index-1-4.html
+share/gtk-doc/html/libaccounts-glib/api-index-1-5.html
+share/gtk-doc/html/libaccounts-glib/api-index-deprecated.html
+share/gtk-doc/html/libaccounts-glib/api-index-full.html
+share/gtk-doc/html/libaccounts-glib/appendices.html
+share/gtk-doc/html/libaccounts-glib/gettext-xml-files.html
+share/gtk-doc/html/libaccounts-glib/glossary.html
+share/gtk-doc/html/libaccounts-glib/home.png
+share/gtk-doc/html/libaccounts-glib/index.html
+share/gtk-doc/html/libaccounts-glib/index.sgml
+share/gtk-doc/html/libaccounts-glib/left-insensitive.png
+share/gtk-doc/html/libaccounts-glib/left.png
+share/gtk-doc/html/libaccounts-glib/libaccounts-compiling.html
+share/gtk-doc/html/libaccounts-glib/libaccounts-glib-objects.html
+share/gtk-doc/html/libaccounts-glib/libaccounts-glib-overview.html
+share/gtk-doc/html/libaccounts-glib/libaccounts-glib-tools.html
+share/gtk-doc/html/libaccounts-glib/libaccounts-glib.devhelp2
+share/gtk-doc/html/libaccounts-glib/libaccounts-overview.html
+share/gtk-doc/html/libaccounts-glib/libaccounts-running.html
+share/gtk-doc/html/libaccounts-glib/object-tree.html
+share/gtk-doc/html/libaccounts-glib/provider-file-format.html
+share/gtk-doc/html/libaccounts-glib/right-insensitive.png
+share/gtk-doc/html/libaccounts-glib/right.png
+share/gtk-doc/html/libaccounts-glib/service-file-format.html
+share/gtk-doc/html/libaccounts-glib/service-type-file-format.html
+share/gtk-doc/html/libaccounts-glib/style.css
+share/gtk-doc/html/libaccounts-glib/up-insensitive.png
+share/gtk-doc/html/libaccounts-glib/up.png
+share/gtk-doc/html/libaccounts-glib/validating-xml-files.html
+share/gtk-doc/html/libaccounts-glib/xml-file-formats.html
+share/gtk-doc/html/libaccounts-glib/xml-files.html
+share/vala/vapi/libaccounts-glib.deps
+share/vala/vapi/libaccounts-glib.vapi
+share/xml/accounts/schema/dtd/accounts-application.dtd
+share/xml/accounts/schema/dtd/accounts-provider.dtd
+share/xml/accounts/schema/dtd/accounts-service-type.dtd
+share/xml/accounts/schema/dtd/accounts-service.dtd