aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2010-12-21 23:49:09 +0000
committerMatthias Andree <mandree@FreeBSD.org>2010-12-21 23:49:09 +0000
commit215977f6ef4a066bc70147fe1dae0204d3ff4f79 (patch)
tree86329200a25e93abfb6de3fde69cf7cf107e88a7 /net-im
parenta1248a845396b84c171d904d9b56dc8e7ad0978a (diff)
downloadports-215977f6ef4a066bc70147fe1dae0204d3ff4f79.tar.gz
ports-215977f6ef4a066bc70147fe1dae0204d3ff4f79.zip
Update to upstream SVN rev 605, removing patch.
Fix build-tarball Makefile target, adding missing ${DISTFILES}: target.
Notes
Notes: svn path=/head/; revision=266710
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pidgin-skype/Makefile3
-rw-r--r--net-im/pidgin-skype/distinfo4
-rw-r--r--net-im/pidgin-skype/files/patch-skype_messaging.c32
3 files changed, 4 insertions, 35 deletions
diff --git a/net-im/pidgin-skype/Makefile b/net-im/pidgin-skype/Makefile
index 720a8949f51a..a9674d22ede0 100644
--- a/net-im/pidgin-skype/Makefile
+++ b/net-im/pidgin-skype/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pidgin-skype
-PORTVERSION= 0.0.0.604
+PORTVERSION= 0.0.0.605
CATEGORIES= net-im
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= mandree
@@ -28,6 +28,7 @@ USE_XZ= yes
# this is a local target to build a tarball
build-tarball: ${DISTFILES}
+${DISTFILES}:
${RM} -rf ${WRKSRC}
svn export -r${PORTVERSION:E} \
http://skype4pidgin.googlecode.com/svn/trunk/ ${WRKSRC}
diff --git a/net-im/pidgin-skype/distinfo b/net-im/pidgin-skype/distinfo
index 3eeff73ff5ac..c7707472d680 100644
--- a/net-im/pidgin-skype/distinfo
+++ b/net-im/pidgin-skype/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pidgin-skype-svn-r604.tar.xz) = c32da346e2baf4105dc5e52be89243fbe8a14e04c5414afaed73d7d6475bc75b
-SIZE (pidgin-skype-svn-r604.tar.xz) = 113888
+SHA256 (pidgin-skype-svn-r605.tar.xz) = 9ae6e905653b9b7cfe8529c144566d0a5090bfca257d4746b1a52050f2a688c0
+SIZE (pidgin-skype-svn-r605.tar.xz) = 113900
diff --git a/net-im/pidgin-skype/files/patch-skype_messaging.c b/net-im/pidgin-skype/files/patch-skype_messaging.c
deleted file mode 100644
index 43ac79c0c36e..000000000000
--- a/net-im/pidgin-skype/files/patch-skype_messaging.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- ./skype_messaging.c.orig 2010-01-28 02:22:49.000000000 +0100
-+++ ./skype_messaging.c 2010-12-20 02:20:23.000000000 +0100
-@@ -176,7 +176,7 @@
- #ifdef __APPLE__
- guint timeout = 0;
- #else
--#ifdef _WIN32
-+#if _WIN32 || __FreeBSD__
- guint timeout = 0;
- #else
- gboolean condition_result;
-@@ -223,6 +223,12 @@
-
- if (timeout++ == 10000)
- #else
-+#ifdef __FreeBSD__
-+ usleep(1000);
-+ g_static_mutex_lock2(&mutex);
-+
-+ if (timeout++ == 10000)
-+#else
-
- //wait for message for a maximum of 10 seconds
- g_get_current_time(&endtime);
-@@ -235,6 +241,7 @@
- if(!condition_result)
- #endif
- #endif
-+#endif
- {
- //we timed out while waiting
- g_hash_table_remove(message_queue, &cur_message_num);