aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-03-12 10:52:04 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-03-12 10:52:04 +0000
commit589fcb8c6cd8cab11259eaa60367f61ca1c5cd65 (patch)
tree1a4fc5a6fc7a806d2f8c56b9d859f2a1d2b1ec17 /net-im
parentfdd43a57dfff927d5eb863992b67b7e5cd5c068d (diff)
downloadports-589fcb8c6cd8cab11259eaa60367f61ca1c5cd65.tar.gz
ports-589fcb8c6cd8cab11259eaa60367f61ca1c5cd65.zip
- Fix runtime error: unknown (tk) option "state"
- Beautify and fix style in Makefile - Adopt maintainship PR: 118074 Submitted by: Henk van Oers <henk@signature.nl> Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=208880
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jarl/Makefile21
-rw-r--r--net-im/jarl/files/patch-lib_login_tk.pl11
-rw-r--r--net-im/jarl/files/patch-lib_main_tk.pl11
3 files changed, 31 insertions, 12 deletions
diff --git a/net-im/jarl/Makefile b/net-im/jarl/Makefile
index a8599374919d..2db6569569dd 100644
--- a/net-im/jarl/Makefile
+++ b/net-im/jarl/Makefile
@@ -7,13 +7,12 @@
PORTNAME= jarl
PORTVERSION= 0.5001
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= Jarl-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= A Perl/Tk Jabber client
RUN_DEPENDS= ptksh:${PORTSDIR}/x11-toolkits/p5-Tk \
@@ -25,7 +24,7 @@ USE_PERL5= yes
makeplist:
${ECHO_CMD} bin/jarl > ${PLIST}
- ${FIND} ${PREFIX}/share/jarl -type f -print | ${CUT} -d/ -f4- >> \
+ ${FIND} ${PREFIX}/share/jarl ! -name "*.orig" -type f -print | ${CUT} -d/ -f4- >> \
${PLIST}
${FIND} ${PREFIX}/share/jarl -type d -print | ${CUT} -d/ -f4- | \
${SORT} -r | ${SED} 's/^/@dirrm /' >> ${PLIST}
@@ -34,13 +33,11 @@ post-patch:
${REINPLACE_CMD} -e "s:%%PREFIX%%:${PREFIX}:g" ${WRKSRC}/jarl
do-install:
- ${MKDIR} ${PREFIX}/share/jarl
+ ${MKDIR} ${DATADIR}
+ ${MKDIR} ${DATADIR}/lib
+ ${MKDIR} ${DATADIR}/bitmaps
+ (cd ${WRKSRC}/lib && ${COPYTREE_SHARE} \* ${DATADIR}/lib)
+ (cd ${WRKSRC}/bitmaps && ${COPYTREE_SHARE} \* ${DATADIR}/bitmaps)
${INSTALL_SCRIPT} ${WRKSRC}/jarl ${PREFIX}/bin
- cd ${WRKSRC} && ${FIND} lib bitmaps -type d -print | while read d; do \
- ${MKDIR} ${PREFIX}/share/jarl/$$d; \
- ${FIND} $$d -maxdepth 1 -type f -print | \
- ${XARGS} -t -J% ${INSTALL_DATA} % \
- ${PREFIX}/share/jarl/$$d; \
- done;
.include <bsd.port.mk>
diff --git a/net-im/jarl/files/patch-lib_login_tk.pl b/net-im/jarl/files/patch-lib_login_tk.pl
new file mode 100644
index 000000000000..79b4d769842a
--- /dev/null
+++ b/net-im/jarl/files/patch-lib_login_tk.pl
@@ -0,0 +1,11 @@
+--- lib/login_tk.pl.orig 2008-03-12 03:03:39.000000000 +0100
++++ lib/login_tk.pl 2008-03-12 02:57:41.000000000 +0100
+@@ -281,7 +281,7 @@
+ -font=>$GUI{fonts}->{login},
+ -state=>"disabled",
+ -command=>sub{
+- $GUI{Login}->{Connect}->configure(state=>"disabled");
++ $GUI{Login}->{Connect}->configure(-state=>"disabled");
+
+ $activeProfile = $GUI{Login}->{vars}->{profile};
+ &jarlSettings_SetConfig();
diff --git a/net-im/jarl/files/patch-lib_main_tk.pl b/net-im/jarl/files/patch-lib_main_tk.pl
new file mode 100644
index 000000000000..cd50c3724597
--- /dev/null
+++ b/net-im/jarl/files/patch-lib_main_tk.pl
@@ -0,0 +1,11 @@
+--- lib/main_tk.pl.orig 2008-03-12 02:55:50.000000000 +0100
++++ lib/main_tk.pl 2008-03-12 02:55:59.000000000 +0100
+@@ -947,7 +947,7 @@
+ $GUI{top}->deiconify();
+ $GUI{top}->lower($GUI{Login}->{window}) if Exists($GUI{Login}->{window});
+
+- $GUI{Login}->{Connect}->configure(state=>"normal");
++ $GUI{Login}->{Connect}->configure(-state=>"normal");
+
+ $GUI{top}->after(1500, sub { &jarlMainIF_Loop() });
+ }