aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-09-05 19:23:42 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-09-05 19:23:42 +0000
commit82a87de90c337aae160ac254606dad78d0d78d11 (patch)
tree516db145d6cf5fd4d2666f811272aad577272ac5 /net-im
parentf22162b04be45bf28d125c67ee0a841fb1ae4b55 (diff)
downloadports-82a87de90c337aae160ac254606dad78d0d78d11.tar.gz
ports-82a87de90c337aae160ac254606dad78d0d78d11.zip
- Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk with
Mk/Uses/linux.mk. - Replace USE_LINUX=yes with USES+=linux and USE_LINUX=(.*) with USES+=linux:\1 in all ports. - Replace USE_LINUX_APPS with USE_LINUX in all ports. - Use INSTALL_SCRIPT instead of INSTALL_PROGRAM to install scripts in some ports. - When USE_LINUX_RPM is defined, simplify the way DISTFILES and EXTRACT_ONLY are defined. - Remove BRANDELF_DIRS and BRANDELF_FILES handling. In the very rare cases that it is still necessary ports can run ${BRANDELF} from post-patch. - Remove AUTOMATIC_PLIST handling. Only one port used it. - Fix Linux MASTER_SITES. - Replace OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS with default versions framework. - bsd.port.mk: - Move Linux related bits to Uses/linux.mk, except USE_LINUX_PREFIX. - Put USE_LINUX_PREFIX handling after USES processing. - Define DOCSDIR, DATADIR, etc. after handling USE_LINUX_PREFIX so it can give these variables a different default value. - When a package needs to run Linux ldconfig check before installation if Linux support is enabled. - emulators/linux_base-*: - Use USES=linux and remove duplication. - Remove files/lp. FreeBSD or CUPS lp(1) should work. - Remove files/yp.conf. No longer seems to be used. - Remove pkg-deinstall and move pkg-install into pkg-plist. - Update pkg-descr and pkg-message. - Fix handling of ldconfig cache in pkg-plist. - devel/fb-adb: Use a Linux shell to run a Linux script but patch the script to use FreeBSD mkdir so mkdir -p $path creates $path and not /compat/linux/$path. PR: 211645 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=421387
Diffstat (limited to 'net-im')
-rw-r--r--net-im/linux-instantbird/Makefile2
-rw-r--r--net-im/qq/Makefile4
-rw-r--r--net-im/skype-devel/Makefile15
-rw-r--r--net-im/skype/Makefile15
-rw-r--r--net-im/skype4/Makefile22
-rw-r--r--net-im/yoono/Makefile5
6 files changed, 29 insertions, 34 deletions
diff --git a/net-im/linux-instantbird/Makefile b/net-im/linux-instantbird/Makefile
index efafd5a7dafa..c7e947a480db 100644
--- a/net-im/linux-instantbird/Makefile
+++ b/net-im/linux-instantbird/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= gecko@FreeBSD.org
COMMENT= Instant Messaging client based on XULRunner and libpurple
USES= tar:bzip2
-USE_LINUX_APPS= libxml2 #avahiglib avahilibs
+USE_LINUX= libxml2 #avahiglib avahilibs
ALL_LOCALES= cs de en-US es-ES et fr nl pl pt-BR ru sk sv-SE uk
LOCALE= ${${PORT_OPTIONS:MLANG_*}}
diff --git a/net-im/qq/Makefile b/net-im/qq/Makefile
index 8876a1385fbf..a67312799158 100644
--- a/net-im/qq/Makefile
+++ b/net-im/qq/Makefile
@@ -12,8 +12,8 @@ MAINTAINER= kaiw27@gmail.com
COMMENT= Tencent QQ for Linux
ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= yes
-USE_LINUX_APPS= gtk2 xorglibs
+USES= linux
+USE_LINUX= gtk2 xorglibs
NO_BUILD= yes
QQDIR= libexec/qq
diff --git a/net-im/skype-devel/Makefile b/net-im/skype-devel/Makefile
index c49c0e18df2d..7ca22104f9cf 100644
--- a/net-im/skype-devel/Makefile
+++ b/net-im/skype-devel/Makefile
@@ -23,9 +23,8 @@ CONFLICTS= skype-1* skype-2.0* skype-2.1*
NO_BUILD= yes
-USES= cpe tar:bzip2
-USE_LINUX= yes
-USE_LINUX_APPS+=alsalib alsa-plugins-oss expat fontconfig libasyncns \
+USES= cpe linux tar:bzip2
+USE_LINUX= alsalib alsa-plugins-oss expat fontconfig libasyncns \
libsigcpp20
RESTRICTED= Redistribution prohibited.
@@ -36,18 +35,18 @@ PLIST_SUB+= SKYPEDIR=${SKYPEDIR}
SUB_FILES= skype.sh
SUB_LIST+= SKYPEDIR=${SKYPEDIR}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNVIDIA_GL}
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-USE_LINUX_APPS+=xorglibs
+USE_LINUX+= xorglibs
.else
-USE_LINUX_APPS+=dri
+USE_LINUX+= dri
.endif
.if ${PORT_OPTIONS:MVIDEO}
RUN_DEPENDS+= webcamd:multimedia/webcamd
-USE_LINUX_APPS+=libv4l
+USE_LINUX+= libv4l
SUB_LIST+= VIDEO="LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so "
.else
SUB_LIST+= VIDEO=""
@@ -71,4 +70,4 @@ do-install:
@cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/skype/Makefile b/net-im/skype/Makefile
index a1d6741a0801..62e63c91638a 100644
--- a/net-im/skype/Makefile
+++ b/net-im/skype/Makefile
@@ -19,9 +19,8 @@ OPTIONS_DEFAULT= VIDEO
NO_BUILD= yes
-USES= cpe tar:bzip2
-USE_LINUX= yes
-USE_LINUX_APPS+=alsalib alsa-plugins-oss expat fontconfig libasyncns \
+USES= cpe linux tar:bzip2
+USE_LINUX= alsalib alsa-plugins-oss expat fontconfig libasyncns \
libsigcpp20
RESTRICTED= Redistribution prohibited.
@@ -32,18 +31,18 @@ PLIST_SUB+= SKYPEDIR=${SKYPEDIR}
SUB_FILES= skype.sh
SUB_LIST+= SKYPEDIR=${SKYPEDIR}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNVIDIA_GL}
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-USE_LINUX_APPS+=xorglibs
+USE_LINUX+= xorglibs
.else
-USE_LINUX_APPS+=dri
+USE_LINUX+= dri
.endif
.if ${PORT_OPTIONS:MVIDEO}
RUN_DEPENDS+= webcamd:multimedia/webcamd
-USE_LINUX_APPS+=libv4l
+USE_LINUX+= libv4l
SUB_LIST+= VIDEO="LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so "
.else
SUB_LIST+= VIDEO=""
@@ -66,4 +65,4 @@ do-install:
@cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/skype4/Makefile b/net-im/skype4/Makefile
index dc13d044e935..21346087ae33 100644
--- a/net-im/skype4/Makefile
+++ b/net-im/skype4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= skype
PORTVERSION= 4.3.0.37
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= net-im
MASTER_SITES= http://download.skype.com/linux/
@@ -21,9 +21,8 @@ OPTIONS_DEFAULT= VIDEO
NO_BUILD= yes
-USES= cpe desktop-file-utils tar:bzip2
-USE_LINUX= yes
-USE_LINUX_APPS+= fontconfig xorglibs qt47 qt47-x11 qt47-webkit openssl openssl-compat pulseaudio-libs
+USES= cpe desktop-file-utils linux tar:bzip2
+USE_LINUX= fontconfig xorglibs qt47 qt47-x11 qt47-webkit openssl pulseaudio-libs
RESTRICTED= Redistribution prohibited.
@@ -33,20 +32,19 @@ PLIST_SUB+= SKYPEDIR=${SKYPEDIR}
SUB_FILES= skype.sh
SUB_LIST+= SKYPEDIR=${SKYPEDIR}
-.include <bsd.port.pre.mk>
+NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
+NVIDIA_GL_USE= LINUX=xorglibs
+NVIDIA_GL_USE_OFF= LINUX=dri
+
+.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100075 || ${OSVERSION} >= 1000000 && ${OSVERSION} < 1002507)
BROKEN= Skype 4.3 requires Linux 2.6.32 emulation.
.endif
-NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-NVIDIA_GL_USE= LINUX_APPS=xorglibs
-NVIDIA_GL_USE_OFF= LINUX_APPS=dri
-
-.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MVIDEO}
RUN_DEPENDS+= webcamd:multimedia/webcamd
-USE_LINUX_APPS+= libv4l
+USE_LINUX+= libv4l
SUB_LIST+= VIDEO="LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so "
.else
SUB_LIST+= VIDEO=""
@@ -72,4 +70,4 @@ do-install:
@${INSTALL} -d ${STAGEDIR}${DOCSDIR}
@cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/yoono/Makefile b/net-im/yoono/Makefile
index 0f0cea88b2bc..b6e9b06993de 100644
--- a/net-im/yoono/Makefile
+++ b/net-im/yoono/Makefile
@@ -30,10 +30,9 @@ ONLY_FOR_ARCHS_REASON= binary distribution
SUB_FILES= ${PORTNAME} pkg-message
SUB_LIST= LINUXBASE=${LINUXBASE}
+USES= linux tar:bzip2
USE_LDCONFIG= yes
-USE_LINUX= yes
-USE_LINUX_APPS= alsalib dbuslibs gtk2 xorglibs
-USES= tar:bzip2
+USE_LINUX= alsalib dbuslibs gtk2 xorglibs
WRKSRC= ${WRKDIR}/${PORTNAME}-desktop