aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2011-06-27 22:51:06 +0000
committerDavid Thiel <lx@FreeBSD.org>2011-06-27 22:51:06 +0000
commit9a6ce42123744a696503d831ef24edb397ddffc7 (patch)
treee6adde32d6b997f4ed4c3f1ae2a887e6282ea327 /net-im
parent589069db9a8f11f8db276f8dca00224ffb0d7599 (diff)
downloadports-9a6ce42123744a696503d831ef24edb397ddffc7.tar.gz
ports-9a6ce42123744a696503d831ef24edb397ddffc7.zip
Update to 0.8.2, a bugfix release. Also, update certificate makefile to specify
"gmake", and regenerate localhost certs before install, in case someone carelessly uses them in production.
Notes
Notes: svn path=/head/; revision=276527
Diffstat (limited to 'net-im')
-rw-r--r--net-im/prosody/Makefile5
-rw-r--r--net-im/prosody/distinfo4
-rw-r--r--net-im/prosody/files/patch-certs-Makefile25
3 files changed, 31 insertions, 3 deletions
diff --git a/net-im/prosody/Makefile b/net-im/prosody/Makefile
index 477928d1c5bd..9148a8172b55 100644
--- a/net-im/prosody/Makefile
+++ b/net-im/prosody/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= prosody
-PORTVERSION= 0.8.1
+PORTVERSION= 0.8.2
CATEGORIES= net-im
MASTER_SITES= http://prosody.im/downloads/source/ \
http://redundancy.redundancy.org/mirror/
@@ -27,6 +27,7 @@ MANCOMPRESSED= no
USE_LUA= 5.1
WANT_LUA_VER= 5.1
+USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS+="--ostype=freebsd"
@@ -37,6 +38,8 @@ SUB_FILES= pkg-install pkg-deinstall
pre-install:
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
${REINPLACE_CMD} -e 's|/usr/bin/env lua|${LUA_CMD}|' ${WRKSRC}/prosody ${WRKSRC}/prosodyctl
+ ${RM} ${WRKSRC}/certs/localhost.*
+ cd ${WRKSRC}/certs && ${GMAKE} localhost.cert
post-install:
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/net-im/prosody/distinfo b/net-im/prosody/distinfo
index 845b9cbab5f5..49aa02056ed2 100644
--- a/net-im/prosody/distinfo
+++ b/net-im/prosody/distinfo
@@ -1,2 +1,2 @@
-SHA256 (prosody-0.8.1.tar.gz) = 6d6db07975f82adece05fb01fc6f448230d6b9c871d6f6d8259d68d4f2d72886
-SIZE (prosody-0.8.1.tar.gz) = 211970
+SHA256 (prosody-0.8.2.tar.gz) = d0315150f8487fc960adf56ce057985428679975f9c6f3fcf424832d24eaae60
+SIZE (prosody-0.8.2.tar.gz) = 212170
diff --git a/net-im/prosody/files/patch-certs-Makefile b/net-im/prosody/files/patch-certs-Makefile
new file mode 100644
index 000000000000..e2cc781ec039
--- /dev/null
+++ b/net-im/prosody/files/patch-certs-Makefile
@@ -0,0 +1,25 @@
+--- certs/Makefile.orig 2011-06-27 15:22:39.024815105 -0700
++++ certs/Makefile 2011-06-27 15:24:55.275832762 -0700
+@@ -2,13 +2,13 @@
+ keysize=2048
+
+ # How to:
+-# First, `make yourhost.cnf` which creates a openssl config file.
++# First, `gmake yourhost.cnf` which creates a openssl config file.
+ # Then edit this file and fill in the details you want it to have,
+ # and add or change hosts and components it should cover.
+-# Then `make yourhost.key` to create your private key, you can
++# Then `gmake yourhost.key` to create your private key, you can
+ # include keysize=number to change the size of the key.
+-# Then you can either `make yourhost.csr` to generate a certificate
+-# signing request that you can submit to a CA, or `make yourhost.cert`
++# Then you can either `gmake yourhost.csr` to generate a certificate
++# signing request that you can submit to a CA, or `gmake yourhost.cert`
+ # to generate a self signed certificate.
+
+ .PRECIOUS: %.cnf %.key
+@@ -28,3 +28,4 @@
+ %.key:
+ openssl genrsa $(keysize) > $@
+ @chmod 400 $@
++ @chown prosody:prosody $@