aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2018-02-01 18:03:09 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2018-02-01 18:03:09 +0000
commita3cc513bfc69ef10d52ed310dd9a6e6bb8c57491 (patch)
tree4a6b8513515fb032f2183d945863a1d39dbcd0c1 /net-im
parent7a6d87cd185d39c7023ee32da472cca4f391e7f2 (diff)
downloadports-a3cc513bfc69ef10d52ed310dd9a6e6bb8c57491.tar.gz
ports-a3cc513bfc69ef10d52ed310dd9a6e6bb8c57491.zip
Flavorize and modernize Emacs ports
- Convert USE_EMACS to USES=emacs - Remove editors/emacs-nox11 (refer to nox flavors of editors/emacs and editors/emacs-devel) - Permit default Emacs flavor to be specified in make.conf - Rename japanese/migemo-emacs23 to japanese/migemo-emacs - Update and simplify audio/emms and fix build on FreeBSD 10 [1] - Update databases/bbdd and fix build on FreeBSD 10 [1] - Update editors/emacs-devel - Ensure Makefile shell commands that change directory are executed in a subshell - Silence some portlint warnings [1] By not depending on base texinfo PR: 225404 Reviewed by: antoine Approved by: portmgr (mat) ashish (maintainer) Differential Revision: https://reviews.freebsd.org/D13506
Notes
Notes: svn path=/head/; revision=460621
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jabber.el/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/net-im/jabber.el/Makefile b/net-im/jabber.el/Makefile
index 3518c63a6ff1..ea8b8c934cf8 100644
--- a/net-im/jabber.el/Makefile
+++ b/net-im/jabber.el/Makefile
@@ -3,9 +3,10 @@
PORTNAME= jabber.el
PORTVERSION= 0.8.92
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net-im elisp
MASTER_SITES= SF/emacs-jabber/emacs-jabber%20beta%20versions/${PORTVERSION}
+PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
DISTNAME= emacs-jabber-${PORTVERSION}
MAINTAINER= max.n.boyarov@gmail.com
@@ -13,19 +14,16 @@ COMMENT= Minimal jabber client for [X]Emacs
RUN_DEPENDS= ${LOCALBASE}/bin/gnutls-cli:security/gnutls
-INFO= emacs-jabber
-PORTDOCS+= AUTHORS NEWS README
-
-USE_EMACS= yes
+USES= emacs gmake
GNU_CONFIGURE= yes
-USES= gmake
-OPTIONS_DEFINE= DOCS
+INFO= emacs-jabber
+PORTDOCS= AUTHORS NEWS README
-CONFIGURE_ARGS+= --with-lispdir=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/emacs-jabber \
- --disable-schemas-install
+CONFIGURE_ARGS= --with-lispdir=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/emacs-jabber \
+ --disable-schemas-install
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
pre-configure:
${REINPLACE_CMD} -e 's/jabber\.info/emacs-jabber.info/' \
@@ -40,7 +38,7 @@ pre-install:
${MKDIR} ${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/emacs-jabber
post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}/
.endfor