aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2007-05-27 03:03:31 +0000
committerKris Kennaway <kris@FreeBSD.org>2007-05-27 03:03:31 +0000
commitb7ff7031ea6f07582ad920bef0ffd13ac1adcc44 (patch)
treefa95c4dec9e92efb4ff7df81d579129d7bc11807 /net-im
parentbd5f3dd41b37a452c489843e85d75cf94433bbc6 (diff)
downloadports-b7ff7031ea6f07582ad920bef0ffd13ac1adcc44.tar.gz
ports-b7ff7031ea6f07582ad920bef0ffd13ac1adcc44.zip
BROKEN with gcc 4.2
Notes
Notes: svn path=/head/; revision=191950
Diffstat (limited to 'net-im')
-rw-r--r--net-im/icmpchat/Makefile8
-rw-r--r--net-im/jit/Makefile8
-rw-r--r--net-im/linpopup/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/net-im/icmpchat/Makefile b/net-im/icmpchat/Makefile
index f582ca901961..4ba770d27e6c 100644
--- a/net-im/icmpchat/Makefile
+++ b/net-im/icmpchat/Makefile
@@ -14,6 +14,12 @@ MASTER_SITE_SUBDIR= icmpchat
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple console-based chat that uses the ICMP protocol
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|-O2 -Wall -pedantic|${CFLAGS}|;\
s|= gcc|?= gcc|;s|default|all|' ${WRKSRC}/Makefile
@@ -29,4 +35,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Todo ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-im/jit/Makefile b/net-im/jit/Makefile
index 21a5930fb27e..56d0e2e490e9 100644
--- a/net-im/jit/Makefile
+++ b/net-im/jit/Makefile
@@ -22,6 +22,12 @@ CFLAGS+= -fPIC
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/jit/jabber-icq.example
@@ -36,4 +42,4 @@ do-install:
post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-im/linpopup/Makefile b/net-im/linpopup/Makefile
index 30d7e2be84b9..00d942249234 100644
--- a/net-im/linpopup/Makefile
+++ b/net-im/linpopup/Makefile
@@ -28,10 +28,16 @@ USE_X_PREFIX= yes
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-samba3
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s#/doc/#/share/doc/#" ${WRKSRC}/Makefile
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>