aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/argus3/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2013-01-05 07:52:19 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2013-01-05 07:52:19 +0000
commitf40e13cbaa2229d9c73bfbb3042839d1b81f560f (patch)
tree153900adb6d10f2ab01a02d1aa4539c4317891f9 /net-mgmt/argus3/Makefile
parentc8e8f2480f66291ec5bb59c1de95e842c9f3bf39 (diff)
downloadports-f40e13cbaa2229d9c73bfbb3042839d1b81f560f.tar.gz
ports-f40e13cbaa2229d9c73bfbb3042839d1b81f560f.zip
- update to 3.0.6.1
- convert to optionsng - remove unneded patches while here: - trim Makefile header - add license (GPLv3) - add missing perl dependency PR: 173040 Submitted by: Paul Schmehl <pauls@utdallas.edu> Approved by: Alexander Demin <support@spectrum.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=309949
Diffstat (limited to 'net-mgmt/argus3/Makefile')
-rw-r--r--net-mgmt/argus3/Makefile32
1 files changed, 15 insertions, 17 deletions
diff --git a/net-mgmt/argus3/Makefile b/net-mgmt/argus3/Makefile
index 48194c97be87..b3fff6aa68e7 100644
--- a/net-mgmt/argus3/Makefile
+++ b/net-mgmt/argus3/Makefile
@@ -1,24 +1,21 @@
-# New ports collection makefile for: argus3
-# Date created: 08 Jul 2006
-# Whom: Stefan Esser <se@FreeBSD.org>
-#
+# Created by: Stefan Esser <se@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= argus
-PORTVERSION= 3.0.4
-PORTREVISION= 1
+PORTVERSION= 3.0.6.1
CATEGORIES= net-mgmt security
MASTER_SITES= http://qosient.com/argus/src/ \
ftp://qosient.com/pub/argus/src/
MAINTAINER= pauls@utdallas.edu
-COMMENT= A generic IP network transaction auditing tool
+COMMENT= Generic IP network transaction auditing tool
+
+LICENSE= GPLv3
CONFLICTS= argus-2* argus-sasl-2* argus-clients-2*
-OPTIONS_DEFINE= SASL
-OPTIONS_DEFAULT= SASL
+OPTIONS_DEFINE= SASL MANPAGES
+OPTIONS_DEFAULT=SASL MANPAGES
USE_RC_SUBR= argus
@@ -26,9 +23,10 @@ USE_RC_SUBR= argus
USE_BISON= build
GNU_CONFIGURE= true
+USE_PERL5= yes
.if ${PORT_OPTIONS:MSASL}
-PKGNAMESUFFIX= -sasl
+PKGNAMESUFFIX+= -sasl
LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
.endif
@@ -36,14 +34,14 @@ CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
MAN5= argus.conf.5
MAN8= argus.8
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's#/usr/lib/sasl2#${LOCALBASE}/lib/sasl2#' ${WRKSRC}/argus/ArgusOutput.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/argus ${PREFIX}/sbin/argus
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/argusbug ${PREFIX}/bin/argusbug
+.for i in argus-lsof argus-snmp argus-vmstat argusbug
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/$i ${PREFIX}/bin/$i
+.endfor
${MKDIR} ${EXAMPLESDIR}/Archive ${EXAMPLESDIR}/Config \
${EXAMPLESDIR}/Deployment ${EXAMPLESDIR}/Startup \
${EXAMPLESDIR}/System
@@ -55,13 +53,13 @@ do-install:
System/crontab System/magic
${INSTALL_DATA} ${WRKSRC}/support/$i ${EXAMPLESDIR}/$i
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/
.for i in README
${INSTALL_DATA} ${WRKSRC}/doc/$i ${DOCSDIR}/
.endfor
.endif
-.if !defined(NOMAN)
+.if ${PORT_OPTIONS:MMANPAGES}
.for i in ${MAN5}
${INSTALL_DATA} ${WRKSRC}/man/man5/$i ${MANPREFIX}/man/man5
.endfor
@@ -70,4 +68,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>