aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/arpwatch
diff options
context:
space:
mode:
authorBrian Somers <brian@FreeBSD.org>2001-04-07 01:51:53 +0000
committerBrian Somers <brian@FreeBSD.org>2001-04-07 01:51:53 +0000
commitaa8166ab58fe1bf124853eaea53c809df6ac41e3 (patch)
tree85695671496883b339b85c1b3eed5756d6dfcb26 /net-mgmt/arpwatch
parentc8ce25062ea59b488455eb9559ccefd1a855b279 (diff)
downloadports-aa8166ab58fe1bf124853eaea53c809df6ac41e3.tar.gz
ports-aa8166ab58fe1bf124853eaea53c809df6ac41e3.zip
GNU_CONFIGURE=yes and teach arpwatch.sh to figure out $PREFIX
Suggested and reviewed by: John E. Hein <jhein@timing.com>
Notes
Notes: svn path=/head/; revision=40982
Diffstat (limited to 'net-mgmt/arpwatch')
-rw-r--r--net-mgmt/arpwatch/Makefile1
-rw-r--r--net-mgmt/arpwatch/files/arpwatch.sh14
2 files changed, 13 insertions, 2 deletions
diff --git a/net-mgmt/arpwatch/Makefile b/net-mgmt/arpwatch/Makefile
index 5fae6c47cf8f..157cddbed58c 100644
--- a/net-mgmt/arpwatch/Makefile
+++ b/net-mgmt/arpwatch/Makefile
@@ -15,6 +15,7 @@ DISTNAME= arpwatch-2.1a10
MAINTAINER= brian@Awfulhak.org
+GNU_CONFIGURE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --quiet
INSTALL_TARGET= install install-man
diff --git a/net-mgmt/arpwatch/files/arpwatch.sh b/net-mgmt/arpwatch/files/arpwatch.sh
index f0c8a797cb54..1f4ad205b3fe 100644
--- a/net-mgmt/arpwatch/files/arpwatch.sh
+++ b/net-mgmt/arpwatch/files/arpwatch.sh
@@ -1,9 +1,19 @@
#!/bin/sh
+prog=$(realpath $0) || exit 1
+dir=${prog%/*}
+PREFIX=${dir%/etc/rc.d}
+
+if [ ."$dir" = ."$prog" -o ."$PREFIX" = ."$dir" ]
+then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
case $1 in
start)
- if [ -x /usr/local/sbin/arpwatch -a -d /usr/local/arpwatch ]; then
- /usr/local/sbin/arpwatch && echo -n ' arpwatch'
+ if [ -x "$PREFIX"/sbin/arpwatch -a -d "$PREFIX"/arpwatch ]; then
+ "$PREFIX"/sbin/arpwatch && echo -n ' arpwatch'
fi
;;
stop)