aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/better-cacti-templates/Makefile
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-01-30 09:04:54 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-01-30 09:04:54 +0000
commit4c5ae611181ba9b17bf7fe319ec3ebfabae4af26 (patch)
tree5a593488f63fde27ce82ceaf246136b41afe36b8 /net-mgmt/better-cacti-templates/Makefile
parent7a30e3c83a213e244219fe1db2c7628d38ff1b2d (diff)
downloadports-4c5ae611181ba9b17bf7fe319ec3ebfabae4af26.tar.gz
ports-4c5ae611181ba9b17bf7fe319ec3ebfabae4af26.zip
- No duplicated data in RRD files.
- No unused data in RRD files. - No wasted polling for the same data over and over PR: ports/160272 Submitted by: Alexey V. Degtyarev <alexey@renatasystems.org> (maintainer) Approved by: maintainer, gabor (mentor)
Notes
Notes: svn path=/head/; revision=290104
Diffstat (limited to 'net-mgmt/better-cacti-templates/Makefile')
-rw-r--r--net-mgmt/better-cacti-templates/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-mgmt/better-cacti-templates/Makefile b/net-mgmt/better-cacti-templates/Makefile
new file mode 100644
index 000000000000..42ad02d81830
--- /dev/null
+++ b/net-mgmt/better-cacti-templates/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: better-cacti-templates
+# Date created: Sat Aug 27 2011
+# Whom: Alexey V. Degtyarev <alexey@renatasystems.org>
+#
+# $FreeBSD$
+
+PORTNAME= better-cacti-templates
+PORTVERSION= 1.1.8
+CATEGORIES= net-mgmt
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE:S/better/mysql/}
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Better Cacti templates for MySQL, Apache, Memcached and more
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= cacti>=0:${PORTSDIR}/net-mgmt/cacti \
+ p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
+ p5-Data-Dumper>=0:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long \
+ p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
+
+USE_MYSQL= yes
+USE_PHP= yes
+WANT_PHP_CLI= yes
+
+NO_BUILD= yes
+
+CACTIDIR?= share/cacti
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README Changelog
+.endif
+
+do-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}/${doc}
+.endfor
+.endif
+ ${MKDIR} ${PREFIX}/share/cacti/scripts
+ ${MKDIR} ${PREFIX}/share/better-cacti-templates
+ cd ${WRKSRC}
+.for dir in definitions misc templates tools
+ cd ${WRKSRC} && ${PAX} -r -w ${dir} \
+ ${PREFIX}/share/better-cacti-templates
+.endfor
+.for script in ss_get_by_ssh.php ss_get_mysql_stats.php
+ ${INSTALL_DATA} ${WRKSRC}/scripts/${script} \
+ ${PREFIX}/share/cacti/scripts/${script}
+.endfor
+
+.include <bsd.port.mk>