aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/blackbox_exporter
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2019-08-14 20:02:08 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2019-08-14 20:02:08 +0000
commit14653cd9cf915e8ebb80234392ad75fec539f628 (patch)
treec56c8fcbcc891723ebfd7c2555f02609eef6e66f /net-mgmt/blackbox_exporter
parent0c3d57ff0ec7d9731cd4b65d77ef1bc5eaf3be5f (diff)
downloadports-14653cd9cf915e8ebb80234392ad75fec539f628.tar.gz
ports-14653cd9cf915e8ebb80234392ad75fec539f628.zip
net-mgmt/blackbox_exporter: Switch to USES=go:modules, fix build with go1.13
PR: 239865 Submitted by: Dmitri Goutnik <dg@syrec.org>
Notes
Notes: svn path=/head/; revision=508966
Diffstat (limited to 'net-mgmt/blackbox_exporter')
-rw-r--r--net-mgmt/blackbox_exporter/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/net-mgmt/blackbox_exporter/Makefile b/net-mgmt/blackbox_exporter/Makefile
index 7f0b50f43523..7bad0c877c15 100644
--- a/net-mgmt/blackbox_exporter/Makefile
+++ b/net-mgmt/blackbox_exporter/Makefile
@@ -12,7 +12,8 @@ COMMENT= Prometheus exporter for endpoints over HTTP(S), DNS, TCP and ICMP
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= go
+USES= go:modules
+
USE_GITHUB= yes
GH_ACCOUNT= prometheus
USE_RC_SUBR= blackbox_exporter
@@ -20,9 +21,6 @@ USE_RC_SUBR= blackbox_exporter
USERS= prometheus
GROUPS= prometheus
-GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
-GO_TARGET= github.com/${GH_ACCOUNT}/${PORTNAME}
-
PORTEXAMPLES= ${WRKSRC}/*.yml
OPTIONS_DEFINE= EXAMPLES
@@ -33,8 +31,7 @@ PLIST_FILES= bin/blackbox_exporter \
${EXAMPLESDIR}/blackbox.yml \
${EXAMPLESDIR}/example.yml
-do-install:
- ${INSTALL_PROGRAM} ${WRKDIR}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/*.yml ${STAGEDIR}${EXAMPLESDIR}