aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/blackbox_exporter
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2017-07-17 20:30:12 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2017-07-17 20:30:12 +0000
commit18af24c4bf494dec469438aa8d6ceb49cb7ac7d4 (patch)
treea062a4d9bd01b20b58e14a334b4d5e80dc223c0b /net-mgmt/blackbox_exporter
parentefa05a3a5bbb698cd96599e37379aa0d5bb6f2cb (diff)
downloadports-18af24c4bf494dec469438aa8d6ceb49cb7ac7d4.tar.gz
ports-18af24c4bf494dec469438aa8d6ceb49cb7ac7d4.zip
blackbox_exporter is a prometheus exporter. The blackbox exporter
allows blackbox probing of endpoints over HTTP, HTTPS, DNS, TCP and ICMP. WWW: https://github.com/prometheus/blackbox_exporter
Notes
Notes: svn path=/head/; revision=446114
Diffstat (limited to 'net-mgmt/blackbox_exporter')
-rw-r--r--net-mgmt/blackbox_exporter/Makefile33
-rw-r--r--net-mgmt/blackbox_exporter/distinfo3
-rw-r--r--net-mgmt/blackbox_exporter/files/blackbox_exporter.in55
-rw-r--r--net-mgmt/blackbox_exporter/pkg-descr5
-rw-r--r--net-mgmt/blackbox_exporter/pkg-plist4
5 files changed, 100 insertions, 0 deletions
diff --git a/net-mgmt/blackbox_exporter/Makefile b/net-mgmt/blackbox_exporter/Makefile
new file mode 100644
index 000000000000..804db0adc746
--- /dev/null
+++ b/net-mgmt/blackbox_exporter/Makefile
@@ -0,0 +1,33 @@
+# Created by: Boris Samorodov <bsam@FreeBSDD.org>
+# $FreeBSD$
+
+PORTNAME= blackbox_exporter
+PORTVERSION= 0.6.0
+DISTVERSIONPREFIX=v
+CATEGORIES= net-mgmt
+
+MAINTAINER= bsam@FreeBSD.org
+COMMENT= Prometheus exporter for endpoints over HTTP(S), DNS, TCP and ICMP
+
+LICENSE= APACHE20
+
+USES= go
+USE_GITHUB= yes
+
+GH_ACCOUNT= prometheus
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+GO_TARGET= github.com/${GH_ACCOUNT}/${PORTNAME}
+
+USE_RC_SUBR= ${PORTNAME}
+
+STRIP= # stripping can break go binaries
+
+PORTEXAMPLES= ${WRKSRC}/*.yml
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.yml ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/blackbox_exporter/distinfo b/net-mgmt/blackbox_exporter/distinfo
new file mode 100644
index 000000000000..bed3b2443b75
--- /dev/null
+++ b/net-mgmt/blackbox_exporter/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1500301013
+SHA256 (prometheus-blackbox_exporter-v0.6.0_GH0.tar.gz) = 0f7711b1994873aef6db4480a2fcb0635cd2e35244c84b3e02836214b4df4a1d
+SIZE (prometheus-blackbox_exporter-v0.6.0_GH0.tar.gz) = 948058
diff --git a/net-mgmt/blackbox_exporter/files/blackbox_exporter.in b/net-mgmt/blackbox_exporter/files/blackbox_exporter.in
new file mode 100644
index 000000000000..693dd6f39460
--- /dev/null
+++ b/net-mgmt/blackbox_exporter/files/blackbox_exporter.in
@@ -0,0 +1,55 @@
+#!/bin/sh
+
+# PROVIDE: blackbox_exporter
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# blackbox_exporter_enable (bool): Set to NO by default.
+# Set it to YES to enable blackbox_exporter.
+# blackbox_exporter_user (string): Set user that blackbox_exporter will run under
+# Default is "nobody".
+# blackbox_exporter_group (string): Set group that blackbox_exporter will run under
+# Default is "nobody".
+# blackbox_exporter_args (string): Set extra arguments to pass to blackbox_exporter
+# Default is "".
+# blackbox_exporter_listen_address (string):Set ip:port that blackbox_exporter will listen on
+# Default is ":9115".
+# blackbox_exporter_config (string): Set configuration file of blackbox_exporter
+# Default is "%%PREFIX%%/etc/blackbox_exporter.yml".
+
+. /etc/rc.subr
+
+name=blackbox_exporter
+rcvar=blackbox_exporter_enable
+
+load_rc_config $name
+
+: ${blackbox_exporter_enable:="NO"}
+: ${blackbox_exporter_user:="nobody"}
+: ${blackbox_exporter_group:="nobody"}
+: ${blackbox_exporter_args:=""}
+: ${blackbox_exporter_listen_address:=":9115"}
+: ${blackbox_exporter_config:="%%PREFIX%%/etc/blackbox_exporter.yml"}
+
+pidfile=/var/run/blackbox_exporter.pid
+command="/usr/sbin/daemon"
+procname="%%PREFIX%%/bin/blackbox_exporter"
+command_args="-p ${pidfile} /usr/bin/env ${procname} \
+ -web.listen-address=${blackbox_exporter_listen_address} \
+ -config.file=${blackbox_exporter_config} \
+ ${blackbox_exporter_args}"
+
+start_precmd=blackbox_exporter_startprecmd
+
+blackbox_exporter_startprecmd()
+{
+ if [ ! -e ${pidfile} ]; then
+ install -o ${blackbox_exporter_user} -g ${blackbox_exporter_group} /dev/null ${pidfile};
+ fi
+}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/net-mgmt/blackbox_exporter/pkg-descr b/net-mgmt/blackbox_exporter/pkg-descr
new file mode 100644
index 000000000000..fac2622b53e2
--- /dev/null
+++ b/net-mgmt/blackbox_exporter/pkg-descr
@@ -0,0 +1,5 @@
+blackbox_exporter is a prometheus exporter. The blackbox exporter
+allows blackbox probing of endpoints over HTTP, HTTPS, DNS, TCP and
+ICMP.
+
+WWW: https://github.com/prometheus/blackbox_exporter
diff --git a/net-mgmt/blackbox_exporter/pkg-plist b/net-mgmt/blackbox_exporter/pkg-plist
new file mode 100644
index 000000000000..40d69d50f611
--- /dev/null
+++ b/net-mgmt/blackbox_exporter/pkg-plist
@@ -0,0 +1,4 @@
+bin/blackbox_exporter
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/blackbox.yml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/circle.yml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.yml