aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/check_logfiles/Makefile
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2011-04-28 21:59:12 +0000
committerFlorian Smeets <flo@FreeBSD.org>2011-04-28 21:59:12 +0000
commit758396906ac6cf4abe806e9dcb172c5f3804be56 (patch)
tree2ee694f973c34f372272a0e87bbb01a72dac1c6f /net-mgmt/check_logfiles/Makefile
parent8570eb69d2041ebac4d8ee2db23ea76c42f45b7c (diff)
downloadports-758396906ac6cf4abe806e9dcb172c5f3804be56.tar.gz
ports-758396906ac6cf4abe806e9dcb172c5f3804be56.zip
Add new port net-mgmt/check_logfiles
Nagios plugin which scans log files for specific patterns. This plugin looks for patterns in files. It is capable of detecting logfile rotation. If you tell it how the rotated archives look like, it will also examine these files. Traditional logfile plugins were not aware of the gap which could occur, so under some circumstances they ignored what had happened between their checks. In a production environment this is not tolerable, that's why check_logfiles came into being. WWW: http://labs.consol.de/lang/en/nagios/check_logfiles/
Notes
Notes: svn path=/head/; revision=273306
Diffstat (limited to 'net-mgmt/check_logfiles/Makefile')
-rw-r--r--net-mgmt/check_logfiles/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/net-mgmt/check_logfiles/Makefile b/net-mgmt/check_logfiles/Makefile
new file mode 100644
index 000000000000..1131e4b80686
--- /dev/null
+++ b/net-mgmt/check_logfiles/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: check_logfile
+# Date created: 11 Mar 2011
+# Whom: flo@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= check_logfiles
+PORTVERSION= 3.4.3.1
+CATEGORIES= net-mgmt
+MASTER_SITES= http://labs.consol.de/wp-content/uploads/2011/03/
+
+MAINTAINER= flo@FreeBSD.org
+COMMENT= Nagios plugin which scans log files for specific patterns
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS+= --with-trusted-path=/bin:/sbin:/usr/bin:/usr/sbin:${LOCALBASE}/bin:${LOCALBASE}/sbin \
+ --libexecdir=${PREFIX}/libexec/nagios \
+
+.include <bsd.port.mk>