aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/cidr/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-07-28 12:53:31 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-07-28 12:53:31 +0000
commit14ea0d1990d833a6ecee560cffc488dd81b11f9f (patch)
treee7caaeacb214a210ae989ad116886230990d842b /net-mgmt/cidr/Makefile
parent51ffaf0366c3e2bafd68ddf1e30a0cae2b2dabe0 (diff)
downloadports-14ea0d1990d833a6ecee560cffc488dd81b11f9f.tar.gz
ports-14ea0d1990d833a6ecee560cffc488dd81b11f9f.zip
- Provide a patch to fix incorrect uses of strncpy
- Add an additional master site - Nuke patch-aa - Cleanup - Bump PORTREVISION - Take maintainer-ship Obtained from: OpenBSD
Notes
Notes: svn path=/head/; revision=168959
Diffstat (limited to 'net-mgmt/cidr/Makefile')
-rw-r--r--net-mgmt/cidr/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-mgmt/cidr/Makefile b/net-mgmt/cidr/Makefile
index 5e44cb0573a7..f7184b33aedf 100644
--- a/net-mgmt/cidr/Makefile
+++ b/net-mgmt/cidr/Makefile
@@ -6,22 +6,22 @@
PORTNAME= cidr
PORTVERSION= 2.3.2
+PORTREVISION= 1
CATEGORIES= net-mgmt
-MASTER_SITES= http://critical.ch/distfiles/
-MASTER_SITE_SUBDIR= nork
-DISTNAME= cidr-current
+MASTER_SITES= http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ehaupt@FreeBSD.org
COMMENT= RFC 1878 subnet calculator / helper
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-ALL_TARGET= cidr
-
MAN1= cidr.1
PLIST_FILES= bin/cidr
+do-build:
+ ${CC} ${CFLAGS} ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME}
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cidr ${PREFIX}/bin/cidr
- ${INSTALL_MAN} ${WRKSRC}/cidr.1 ${PREFIX}/man/man1/cidr.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
.include <bsd.port.mk>