aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/flow-tools
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-10-02 09:11:16 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-10-02 09:11:16 +0000
commit8f7bbd0ed4e42d8aca0687b9bab9a21e1a030ed3 (patch)
tree461667a4eae3300d0748fabac0c78c62c414c7f0 /net-mgmt/flow-tools
parent6bfb583a7d894bd369666e2755abd1b1138bad08 (diff)
downloadports-8f7bbd0ed4e42d8aca0687b9bab9a21e1a030ed3.tar.gz
ports-8f7bbd0ed4e42d8aca0687b9bab9a21e1a030ed3.zip
- Fix compiling with gcc 4.1
- Take maintainership Approved by: sem (mentor)
Notes
Notes: svn path=/head/; revision=174294
Diffstat (limited to 'net-mgmt/flow-tools')
-rw-r--r--net-mgmt/flow-tools/Makefile2
-rw-r--r--net-mgmt/flow-tools/files/patch-lib_ftchash.c11
-rw-r--r--net-mgmt/flow-tools/files/patch-lib_ftio.c20
-rw-r--r--net-mgmt/flow-tools/files/patch-lib_fttlv.c100
-rw-r--r--net-mgmt/flow-tools/pkg-plist12
5 files changed, 138 insertions, 7 deletions
diff --git a/net-mgmt/flow-tools/Makefile b/net-mgmt/flow-tools/Makefile
index dc812d9b2c58..323da43942a7 100644
--- a/net-mgmt/flow-tools/Makefile
+++ b/net-mgmt/flow-tools/Makefile
@@ -11,7 +11,7 @@ PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= ftp://ftp.eng.oar.net/pub/flow-tools/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= stas@FreeBSD.org
COMMENT= Suite of tools and library to work with netflow data
USE_PYTHON_RUN= yes
diff --git a/net-mgmt/flow-tools/files/patch-lib_ftchash.c b/net-mgmt/flow-tools/files/patch-lib_ftchash.c
new file mode 100644
index 000000000000..57ae25835d80
--- /dev/null
+++ b/net-mgmt/flow-tools/files/patch-lib_ftchash.c
@@ -0,0 +1,11 @@
+--- lib/ftchash.c.orig Mon Oct 2 12:30:55 2006
++++ lib/ftchash.c Mon Oct 2 12:31:29 2006
+@@ -326,7 +326,7 @@
+ (char*)ftch->traverse_chunk->base+ftch->traverse_chunk->next) {
+
+ ret = ftch->traverse_rec;
+- (char*)ftch->traverse_rec += ftch->d_size;
++ ftch->traverse_rec = (char *)ftch->traverse_rec + ftch->d_size;
+ return ret;
+
+ } else {
diff --git a/net-mgmt/flow-tools/files/patch-lib_ftio.c b/net-mgmt/flow-tools/files/patch-lib_ftio.c
new file mode 100644
index 000000000000..cfd0025bea3f
--- /dev/null
+++ b/net-mgmt/flow-tools/files/patch-lib_ftio.c
@@ -0,0 +1,20 @@
+--- lib/ftio.c.orig Mon Oct 2 12:26:19 2006
++++ lib/ftio.c Mon Oct 2 12:27:53 2006
+@@ -2267,7 +2267,7 @@
+ break;
+
+ nleft -= nread;
+- (char*)ptr += nread;
++ ptr = (char *)ptr + nread;
+ }
+ return (nbytes - nleft);
+ } /* readn */
+@@ -2292,7 +2292,7 @@
+ return(nwritten); /* error */
+
+ nleft -= nwritten;
+- (char*)ptr += nwritten;
++ ptr = (char *)ptr + nwritten;
+ }
+ return(nbytes - nleft);
+ } /* writen */
diff --git a/net-mgmt/flow-tools/files/patch-lib_fttlv.c b/net-mgmt/flow-tools/files/patch-lib_fttlv.c
new file mode 100644
index 000000000000..03ba232f80fc
--- /dev/null
+++ b/net-mgmt/flow-tools/files/patch-lib_fttlv.c
@@ -0,0 +1,100 @@
+--- lib/fttlv.c.orig Mon Oct 2 12:27:59 2006
++++ lib/fttlv.c Mon Oct 2 12:30:50 2006
+@@ -68,10 +68,10 @@
+ }
+
+ bcopy(&t, buf, 2);
+- (char*)buf+= 2;
++ buf = (char *)buf + 2;
+
+ bcopy(&len, buf, 2);
+- (char*)buf+= 2;
++ buf = (char *)buf + 2;
+
+ bcopy(&v, buf, 4);
+
+@@ -107,10 +107,10 @@
+ }
+
+ bcopy(&t, buf, 2);
+- (char*)buf+= 2;
++ buf = (char *)buf + 2;
+
+ bcopy(&len, buf, 2);
+- (char*)buf+= 2;
++ buf = (char *)buf + 2;
+
+ bcopy(&v, buf, 2);
+
+@@ -145,10 +145,10 @@
+ }
+
+ bcopy(&t, buf, 2);
+- (char*)buf+= 2;
++ buf = (char *)buf + 2;
+
+ bcopy(&len, buf, 2);
+- (char*)buf+= 2;
++ buf = (char *)buf + 2;
+
+ bcopy(&v, buf, 1);
+
+@@ -183,10 +183,10 @@
+ }
+
+ bcopy(&t, buf, 2);
+- (char*)buf+= 2;
++ buf = (char *)buf + 2;
+
+ bcopy(&len, buf, 2);
+- (char*)buf+= 2;
++ buf = (char *)buf + 2;
+
+ bcopy(v, buf, len);
+
+@@ -230,16 +230,16 @@
+ return -1;
+
+ bcopy(&t, buf, 2);
+- (char*)buf+= 2;
++ buf = (char *)buf + 2;
+
+ bcopy(&len, buf, 2);
+- (char*)buf+= 2;
++ buf = (char *)buf + 2;
+
+ bcopy(&ip, buf, 4);
+- (char*)buf += 4;
++ buf = (char *)buf + 4;
+
+ bcopy(&ifIndex, buf, 2);
+- (char*)buf += 2;
++ buf = (char *)buf + 2;
+
+ bcopy(name, buf, n);
+
+@@ -287,19 +287,19 @@
+ }
+
+ bcopy(&t, buf, 2);
+- (char*)buf+= 2;
++ buf = (char *)buf + 2;
+
+ bcopy(&len, buf, 2);
+- (char*)buf+= 2;
++ buf = (char *)buf + 2;
+
+ bcopy(&ip, buf, 4);
+- (char*)buf += 4;
++ buf = (char *)buf + 4;
+
+ bcopy(&entries, buf, 2);
+- (char*)buf += 2;
++ buf = (char *)buf + 2;
+
+ bcopy(ifIndex_list, buf, esize);
+- (char*)buf += esize;
++ buf = (char *)buf + esize;
+
+ bcopy(name, buf, n);
+
diff --git a/net-mgmt/flow-tools/pkg-plist b/net-mgmt/flow-tools/pkg-plist
index 8dc3a708299a..454a92546446 100644
--- a/net-mgmt/flow-tools/pkg-plist
+++ b/net-mgmt/flow-tools/pkg-plist
@@ -34,10 +34,10 @@ include/ftpaths.h
include/ftqueue.h
include/radix.h
lib/libft.a
-share/flow-tools/asn.sym
-share/flow-tools/ip-prot.sym
-share/flow-tools/ip-type.sym
-share/flow-tools/tag.sym
-share/flow-tools/tcp-port.sym
+%%DATADIR%%/asn.sym
+%%DATADIR%%/ip-prot.sym
+%%DATADIR%%/ip-type.sym
+%%DATADIR%%/tag.sym
+%%DATADIR%%/tcp-port.sym
+@dirrm %%DATADIR%%
@dirrm etc/flow-tools
-@dirrm share/flow-tools