aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/flow-tools
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-09-25 17:16:30 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-09-25 17:16:30 +0000
commitcf48301570a082732306bf375e7a2cf3605126f6 (patch)
tree63a3e6c1322580a61b1cd98a029450ddeda9d9e7 /net-mgmt/flow-tools
parent392ca3755770e56be981dc12b575b57595c6fa9d (diff)
downloadports-cf48301570a082732306bf375e7a2cf3605126f6.tar.gz
ports-cf48301570a082732306bf375e7a2cf3605126f6.zip
net-mgmt/flow-tools: Fix compilation when all options turned off
- Remove python 2.7 dependency [1] [2] PR: 249388 [1] 249739 [2] Submitted by: vladimir.pushkar@gmail.com [1] Reported by: swills [2]
Notes
Notes: svn path=/head/; revision=550057
Diffstat (limited to 'net-mgmt/flow-tools')
-rw-r--r--net-mgmt/flow-tools/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/net-mgmt/flow-tools/Makefile b/net-mgmt/flow-tools/Makefile
index 5dbcfd7ff280..6aa41eead6ea 100644
--- a/net-mgmt/flow-tools/Makefile
+++ b/net-mgmt/flow-tools/Makefile
@@ -4,7 +4,7 @@
PORTNAME= flow-tools
PORTVERSION= 0.68.6
DISTVERSIONPREFIX= v
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MAINTAINER= bofh@FreeBSD.org
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= docbook-to-man:textproc/docbook-to-man
-USES= autoreconf libtool:keepla python:2.7 shebangfix
+USES= autoreconf libtool:keepla python:patch shebangfix
USE_GITHUB= yes
USE_LDCONFIG= yes
USE_RC_SUBR= flow_capture flow_fanout
@@ -38,14 +38,25 @@ FLOW_CAPTURE_PIDDIR= ${VARDIR}/run/flow-capture
OPTIONS_DEFINE= MYSQL OPENSSL PGSQL
+PY2TO3_CMD= ${LOCALBASE}/bin/2to3-${PYTHON_VER}
+PY2TO3_ARGS= --fix=all --no-diffs --nobackups --verbose --write
+
MYSQL_USES= mysql
MYSQL_CONFIGURE_ON= --with-mysql="${LOCALBASE}"
OPENSSL_USES= ssl
OPENSSL_CONFIGURE_ON= --with-openssl="${OPENSSLBASE}"
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-postgresql
+PGSQL_CONFIGURE_OFF= --with-postgresql=no
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${PYTHON_MAJOR_VER} >= 3
+ ${PY2TO3_CMD} ${PY2TO3_ARGS} ${WRKSRC}/bin/flow-*
+.endif
post-install:
${STRIP_CMD} ${STAGEDIR}/${PREFIX}/lib/libft.so.0.0.0
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>