aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/gsnmp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-06-16 12:15:27 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-06-16 12:15:27 +0000
commit324725bb7d6959be1f5be320e05ab548243c250b (patch)
treecaf5c684ac7c4e7aead69bd251e27925b9d33fb8 /net-mgmt/gsnmp
parentba52f50b64d0864d8d0cf85327e8bd78c54557b3 (diff)
downloadports-324725bb7d6959be1f5be320e05ab548243c250b.tar.gz
ports-324725bb7d6959be1f5be320e05ab548243c250b.zip
A SNMP library built on top of glib2 and gnet2. The goal of the project is to
provide an efficient, clean, portable implementation of an SNMP stack for management applications. WWW: https://trac.eecs.iu-bremen.de/projects/gsnmp/ PR: ports/113511 Submitted by: Matt Peterson <matt@peterson.org>
Notes
Notes: svn path=/head/; revision=193658
Diffstat (limited to 'net-mgmt/gsnmp')
-rw-r--r--net-mgmt/gsnmp/Makefile25
-rw-r--r--net-mgmt/gsnmp/distinfo3
-rw-r--r--net-mgmt/gsnmp/pkg-descr5
-rw-r--r--net-mgmt/gsnmp/pkg-plist17
4 files changed, 50 insertions, 0 deletions
diff --git a/net-mgmt/gsnmp/Makefile b/net-mgmt/gsnmp/Makefile
new file mode 100644
index 000000000000..8ee0981a9716
--- /dev/null
+++ b/net-mgmt/gsnmp/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: gsnmp
+# Date created: Sat Jun 9 19:34:09 PDT 2007
+# Whom: Matt Peterson <matt@peterson.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsnmp
+PORTVERSION= 0.2.0
+CATEGORIES= net-mgmt
+MASTER_SITES= ftp://ftp.ibr.cs.tu-bs.de/local/${PORTNAME}/
+
+MAINTAINER= matt@peterson.org
+COMMENT= SNMP library written on top of glib and gnet2
+
+LIB_DEPENDS= gnet:${PORTSDIR}/net/gnet2
+
+USE_GNOME= gnomehack glib20
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir=${PREFIX}/man
+USE_LDCONFIG= yes
+
+MAN1= gsnmp-get.1
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/gsnmp/distinfo b/net-mgmt/gsnmp/distinfo
new file mode 100644
index 000000000000..3b2cb3c1c6ee
--- /dev/null
+++ b/net-mgmt/gsnmp/distinfo
@@ -0,0 +1,3 @@
+MD5 (gsnmp-0.2.0.tar.gz) = b29025d8aacb19fe5f8c03fc0dad25dd
+SHA256 (gsnmp-0.2.0.tar.gz) = ca3ce67155a1061f9602afd85e4f000d606a1e974087b18b3ee85405ee21508e
+SIZE (gsnmp-0.2.0.tar.gz) = 389559
diff --git a/net-mgmt/gsnmp/pkg-descr b/net-mgmt/gsnmp/pkg-descr
new file mode 100644
index 000000000000..4e17aa63ca10
--- /dev/null
+++ b/net-mgmt/gsnmp/pkg-descr
@@ -0,0 +1,5 @@
+A SNMP library built on top of glib2 and gnet2. The goal of the project is to
+provide an efficient, clean, portable implementation of an SNMP stack for
+management applications.
+
+WWW: https://trac.eecs.iu-bremen.de/projects/gsnmp/
diff --git a/net-mgmt/gsnmp/pkg-plist b/net-mgmt/gsnmp/pkg-plist
new file mode 100644
index 000000000000..625a392d28d4
--- /dev/null
+++ b/net-mgmt/gsnmp/pkg-plist
@@ -0,0 +1,17 @@
+bin/gsnmp-get
+include/gsnmp/ber.h
+include/gsnmp/dispatch.h
+include/gsnmp/gsnmp.h
+include/gsnmp/message.h
+include/gsnmp/pdu.h
+include/gsnmp/security.h
+include/gsnmp/session.h
+include/gsnmp/transport.h
+include/gsnmp/utils.h
+lib/libgsnmp.a
+lib/libgsnmp.la
+lib/libgsnmp.so
+lib/libgsnmp.so.0
+libdata/pkgconfig/gsnmp.pc
+share/aclocal/gsnmp.m4
+@dirrm include/gsnmp