aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga2
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2014-10-03 13:30:47 +0000
committerLars Engels <lme@FreeBSD.org>2014-10-03 13:30:47 +0000
commit16402ee0e3cfb651b817679d8fa02d9e51976e19 (patch)
tree3ae2c4f4d57b2d8c08faa724c51e91151ad0db3d /net-mgmt/icinga2
parentb1be43e55af4662eda484b87a891b304809be8e8 (diff)
downloadports-16402ee0e3cfb651b817679d8fa02d9e51976e19.tar.gz
ports-16402ee0e3cfb651b817679d8fa02d9e51976e19.zip
- Fix dependency on PGSQL
- Enable PGSQL by default - Install manpages to the proper location - Use option helpers [1] - Use proper order of .mk includes [1] - Bump PORTREVISION Suggested by: bapt [1]
Notes
Notes: svn path=/head/; revision=369899
Diffstat (limited to 'net-mgmt/icinga2')
-rw-r--r--net-mgmt/icinga2/Makefile29
-rw-r--r--net-mgmt/icinga2/files/patch-third-party__cmake__GNUInstallDirs.cmake11
-rw-r--r--net-mgmt/icinga2/pkg-plist14
3 files changed, 27 insertions, 27 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index b3b39dfc01ef..245f7c2179ef 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= icinga2
DISTVERSION= 2.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://github.com/Icinga/${PORTNAME}/archive/v${DISTVERSION}.tar.gz?dummy=/
@@ -27,7 +27,7 @@ OPTIONS_MULTI_BACKEND= MYSQL PGSQL
OPTIONS_RADIO= PLUGINS
OPTIONS_RADIO_PLUGINS= MONPLUGINS NAGPLUGINS
-OPTIONS_DEFAULT= MYSQL MONPLUGINS EXAMPLES
+OPTIONS_DEFAULT= MYSQL PGSQL MONPLUGINS EXAMPLES
MONPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/monitoring-plugins
NAGPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/nagios-plugins
@@ -60,29 +60,18 @@ SUB_LIST= ICINGA2LOGDIR=${ICINGA2LOGDIR} \
# Config files with references to "Linux"
LINUX_CONFIG= groups.conf services.conf hosts/localhost.conf
-.include <bsd.port.pre.mk>
+MYSQL_USE= mysql=yes
+PGSQL_USES= pgsql
+
+OPTIONS_SUB= yes
+
+.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= flex>=2.5.31:${PORTSDIR}/textproc/flex
CMAKE_ARGS+= -DFLEX_EXECUTABLE:STRING=${LOCALBASE}/bin/flex
CXXFLAGS+= -I${LOCALBASE}/include/flex
.endif
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-PLIST_SUB+= MYSQL=""
-.else
-PLIST_SUB+= MYSQL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USES+= pgsql
-PLIST_SUB+= PGSQL=""
-.else
-PLIST_SUB+= PGSQL="@comment "
-.endif
-
post-patch:
${REINPLACE_CMD} -e '/^add_subdirectory(initsystem)/d' \
-e '/logrotate\.d/d' ${WRKSRC}/etc/CMakeLists.txt
@@ -104,4 +93,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/icinga2/files/patch-third-party__cmake__GNUInstallDirs.cmake b/net-mgmt/icinga2/files/patch-third-party__cmake__GNUInstallDirs.cmake
new file mode 100644
index 000000000000..e6a04c6cabd6
--- /dev/null
+++ b/net-mgmt/icinga2/files/patch-third-party__cmake__GNUInstallDirs.cmake
@@ -0,0 +1,11 @@
+--- third-party/cmake/GNUInstallDirs.cmake.orig 2014-10-03 15:04:47.712808574 +0200
++++ third-party/cmake/GNUInstallDirs.cmake 2014-10-03 15:05:17.916805737 +0200
+@@ -166,7 +166,7 @@
+ set(CMAKE_INSTALL_DATADIR "${CMAKE_INSTALL_DATAROOTDIR}")
+ endif()
+
+-if(CMAKE_SYSTEM_NAME STREQUAL "OpenBSD")
++if(CMAKE_SYSTEM_NAME MATCHES "^(FreeBSD|OpenBSD)$")
+ if(NOT CMAKE_INSTALL_INFODIR)
+ set(CMAKE_INSTALL_INFODIR "" CACHE PATH "info documentation (info)")
+ set(CMAKE_INSTALL_INFODIR "info")
diff --git a/net-mgmt/icinga2/pkg-plist b/net-mgmt/icinga2/pkg-plist
index fcdcd62d4a96..be3e023e580e 100644
--- a/net-mgmt/icinga2/pkg-plist
+++ b/net-mgmt/icinga2/pkg-plist
@@ -79,6 +79,13 @@ lib/icinga2/libremote.so
%%PYTHON_SITELIBDIR%%/icinga2/utils/debug.pyc
%%PYTHON_SITELIBDIR%%/icinga2/utils/netstring.py
%%PYTHON_SITELIBDIR%%/icinga2/utils/netstring.pyc
+man/man8/icinga2-build-ca.8.gz
+man/man8/icinga2-build-key.8.gz
+man/man8/icinga2-disable-feature.8.gz
+man/man8/icinga2-enable-feature.8.gz
+man/man8/icinga2-prepare-dirs.8.gz
+man/man8/icinga2-sign-key.8.gz
+man/man8/icinga2.8.gz
sbin/icinga2
sbin/icinga2-disable-feature
sbin/icinga2-enable-feature
@@ -116,13 +123,6 @@ sbin/icinga2-list-objects
%%DATADIR%%/pki/openssl.cnf
%%DATADIR%%/pki/pkifuncs
%%DATADIR%%/pki/vars
-share/man/man8/icinga2-build-ca.8
-share/man/man8/icinga2-build-key.8
-share/man/man8/icinga2-disable-feature.8
-share/man/man8/icinga2-enable-feature.8
-share/man/man8/icinga2-prepare-dirs.8
-share/man/man8/icinga2-sign-key.8
-share/man/man8/icinga2.8
@dir /var/cache/icinga2
@dir /var/lib/icinga2/api/log
@dir /var/lib/icinga2/api/repository