aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga2
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2020-08-16 10:10:51 +0000
committerLars Engels <lme@FreeBSD.org>2020-08-16 10:10:51 +0000
commit282afd895fee96633dfdc173093d59472d4c2873 (patch)
tree9c67bd07b0dee9a61c92af589cb4fc628ca97629 /net-mgmt/icinga2
parente8ff7a53bb01b48c1699cd3753f8d2f4d380d912 (diff)
downloadports-282afd895fee96633dfdc173093d59472d4c2873.tar.gz
ports-282afd895fee96633dfdc173093d59472d4c2873.zip
net-mgmt/icinga2:
- Update to 2.12.0 - Pet portfmt
Notes
Notes: svn path=/head/; revision=545096
Diffstat (limited to 'net-mgmt/icinga2')
-rw-r--r--net-mgmt/icinga2/Makefile38
-rw-r--r--net-mgmt/icinga2/distinfo6
-rw-r--r--net-mgmt/icinga2/files/patch-CMakeLists.txt18
-rw-r--r--net-mgmt/icinga2/files/patch-itl_command-plugins.conf4
-rw-r--r--net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/files/patch-lib_icingadb_CMakeLists.txt11
-rw-r--r--net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/pkg-plist7
13 files changed, 63 insertions, 49 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index 003e3238e4f0..eb4f1160fd69 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= icinga2
DISTVERSIONPREFIX= v
-DISTVERSION= 2.11.3
+DISTVERSION= 2.12.0
CATEGORIES= net-mgmt
MAINTAINER= lme@FreeBSD.org
@@ -28,15 +28,15 @@ OPTIONS_GROUP_BACKEND= MYSQL PGSQL
OPTIONS_RADIO= PLUGINS
OPTIONS_RADIO_PLUGINS= MONPLUGINS NAGPLUGINS
-OPTIONS_DEFAULT= MYSQL PGSQL MONPLUGINS UNITY
+OPTIONS_DEFAULT= MONPLUGINS MYSQL PGSQL UNITY
-UNITY_DESC= Use icinga unity build system (faster, memory intensive)
+UNITY_DESC= Use icinga unity build system (faster, memory intensive)
MONPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:net-mgmt/monitoring-plugins
NAGPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:net-mgmt/nagios-plugins
-MYSQL_CMAKE_ON= -DICINGA2_WITH_MYSQL:BOOL=true
-PGSQL_CMAKE_ON= -DICINGA2_WITH_PGSQL:BOOL=true
+MYSQL_CMAKE_ON= -DICINGA2_WITH_MYSQL:BOOL=true
+PGSQL_CMAKE_ON= -DICINGA2_WITH_PGSQL:BOOL=true
UNITY_CMAKE_OFF= -DICINGA2_UNITY_BUILD=OFF
ICINGA2USER?= icinga
@@ -47,30 +47,30 @@ GROUPS= ${ICINGA2GROUP}
LOCALSTATEDIR?= /var
ICINGA2LOGDIR?= /var/log/${PORTNAME}
-CMAKE_ARGS+= -DICINGA2_USER=${ICINGA2USER} \
- -DICINGA2_GROUP=${ICINGA2GROUP} \
- -DICINGA2_COMMAND_USER=${ICINGA2USER} \
- -DICINGA2_COMMAND_GROUP=${ICINGA2USER} \
- -DICINGA2_PLUGINDIR=${LOCALBASE}/libexec/nagios \
- -DICINGA2_RUNDIR=/var/run \
- -DCMAKE_INSTALL_SYSCONFDIR=${PREFIX}/etc \
+CMAKE_ARGS+= -DCMAKE_EXE_LINKER_FLAGS=${PREFIX}/lib/icinga2 \
-DCMAKE_INSTALL_LOCALSTATEDIR=${LOCALSTATEDIR} \
-DCMAKE_INSTALL_MANDIR=${MANPREFIX}/man \
- -DCMAKE_EXE_LINKER_FLAGS=${PREFIX}/lib/icinga2 \
+ -DCMAKE_INSTALL_SYSCONFDIR=${PREFIX}/etc \
-DCMAKE_MODULE_LINKER_FLAGS=${PREFIX}/lib/icinga2 \
-DCMAKE_SHARED_LINKER_FLAGS=${PREFIX}/lib/icinga2 \
- -DCMAKE_STATIC_LINKER_FLAGS=${PREFIX}/lib/icinga2
+ -DCMAKE_STATIC_LINKER_FLAGS=${PREFIX}/lib/icinga2 \
+ -DICINGA2_COMMAND_GROUP=${ICINGA2USER} \
+ -DICINGA2_COMMAND_USER=${ICINGA2USER} \
+ -DICINGA2_GROUP=${ICINGA2GROUP} \
+ -DICINGA2_PLUGINDIR=${LOCALBASE}/libexec/nagios \
+ -DICINGA2_RUNDIR=/var/run \
+ -DICINGA2_USER=${ICINGA2USER}
-SUB_LIST= ICINGA2LOGDIR=${ICINGA2LOGDIR} \
+SUB_LIST= ICINGA2GROUP=${ICINGA2GROUP} \
+ ICINGA2LOGDIR=${ICINGA2LOGDIR} \
ICINGA2USER=${ICINGA2USER} \
- ICINGA2GROUP=${ICINGA2GROUP} \
WWWGRP=${WWWGRP}
-PLIST_SUB= ICINGA2USER=${ICINGA2USER} \
- ICINGA2GROUP=${ICINGA2GROUP} \
+PLIST_SUB= ICINGA2GROUP=${ICINGA2GROUP} \
+ ICINGA2USER=${ICINGA2USER} \
WWWGRP=${WWWGRP}
-SUB_FILES= pkg-message ${PORTNAME}-newsyslog.conf
+SUB_FILES= ${PORTNAME}-newsyslog.conf pkg-message
# Config files with references to "Linux"
LINUX_CONFIG= groups.conf services.conf hosts.conf
diff --git a/net-mgmt/icinga2/distinfo b/net-mgmt/icinga2/distinfo
index 5fc4c7d4f68e..d572b2db466d 100644
--- a/net-mgmt/icinga2/distinfo
+++ b/net-mgmt/icinga2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588188729
-SHA256 (icinga-icinga2-v2.11.3_GH0.tar.gz) = 03c46c9af9cb8763ec02428f87a38ab3d7876f56cc10dc5eac5bda0c182f6a76
-SIZE (icinga-icinga2-v2.11.3_GH0.tar.gz) = 7475785
+TIMESTAMP = 1597091051
+SHA256 (icinga-icinga2-v2.12.0_GH0.tar.gz) = 47b409755ded2752a13c3f5fd62dab0411c3e1069653b3c099e8276528d96f7c
+SIZE (icinga-icinga2-v2.12.0_GH0.tar.gz) = 7530104
diff --git a/net-mgmt/icinga2/files/patch-CMakeLists.txt b/net-mgmt/icinga2/files/patch-CMakeLists.txt
index ea94d37d068e..6767dc100751 100644
--- a/net-mgmt/icinga2/files/patch-CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+--- CMakeLists.txt.orig 2020-08-03 13:43:47 UTC
+++ CMakeLists.txt
-@@ -28,8 +28,8 @@ if(NOT CMAKE_BUILD_TYPE)
+@@ -13,8 +13,8 @@ if(NOT CMAKE_BUILD_TYPE)
FORCE)
endif()
@@ -11,16 +11,16 @@
option(ICINGA2_WITH_CHECKER "Build the checker module" ON)
option(ICINGA2_WITH_COMPAT "Build the compat module" ON)
option(ICINGA2_WITH_LIVESTATUS "Build the Livestatus module" ON)
-@@ -241,6 +241,12 @@ if(CMAKE_C_COMPILER_ID STREQUAL "GNU")
+@@ -260,6 +260,12 @@ if(CMAKE_C_COMPILER_ID STREQUAL "GNU")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g -pthread")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -pthread")
endif()
- endif()
-
++endif()
++
+if(CMAKE_SYSTEM_NAME MATCHES "FreeBSD.*")
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -lexecinfo")
+ set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -lexecinfo")
+ set(CMAKE_STATIC_LINKER_FLAGS "${CMAKE_STATIC_LINKER_FLAGS} -lexecinfo")
-+endif()
-+
- include(CheckCXXCompilerFlag)
+ endif()
- function(check_cxx_linker_flag flag var)
+ include(CheckCXXCompilerFlag)
diff --git a/net-mgmt/icinga2/files/patch-itl_command-plugins.conf b/net-mgmt/icinga2/files/patch-itl_command-plugins.conf
index bdf1a47f419f..2020d180abdf 100644
--- a/net-mgmt/icinga2/files/patch-itl_command-plugins.conf
+++ b/net-mgmt/icinga2/files/patch-itl_command-plugins.conf
@@ -1,6 +1,6 @@
---- itl/command-plugins.conf.orig 2018-10-11 12:01:05 UTC
+--- itl/command-plugins.conf.orig 2020-08-03 13:43:47 UTC
+++ itl/command-plugins.conf
-@@ -1628,6 +1628,10 @@ object CheckCommand "procs" {
+@@ -1616,6 +1616,10 @@ object CheckCommand "procs" {
set_if = "$procs_nokthreads$"
description = "Only scan for non kernel threads"
}
diff --git a/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt
index 41f6ea3085f3..b693e911ddc0 100644
--- a/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/checker/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+--- lib/checker/CMakeLists.txt.orig 2020-08-03 13:43:47 UTC
+++ lib/checker/CMakeLists.txt
-@@ -35,7 +35,7 @@ set_target_properties (
+@@ -20,7 +20,7 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt
index 939feb064f48..817acc9238ce 100644
--- a/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/compat/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+--- lib/compat/CMakeLists.txt.orig 2020-08-03 13:43:47 UTC
+++ lib/compat/CMakeLists.txt
-@@ -41,17 +41,17 @@ set_target_properties (
+@@ -26,17 +26,17 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt
index 086dfb2ca34c..77ae611d9a92 100644
--- a/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/db_ido_mysql/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+--- lib/db_ido_mysql/CMakeLists.txt.orig 2020-08-03 13:43:47 UTC
+++ lib/db_ido_mysql/CMakeLists.txt
-@@ -37,7 +37,7 @@ set_target_properties (
+@@ -22,7 +22,7 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt
index 7f0a61b8e337..e1fa0f0b7c51 100644
--- a/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/db_ido_pgsql/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+--- lib/db_ido_pgsql/CMakeLists.txt.orig 2020-08-03 13:43:47 UTC
+++ lib/db_ido_pgsql/CMakeLists.txt
-@@ -37,7 +37,7 @@ set_target_properties (
+@@ -22,7 +22,7 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_icingadb_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_icingadb_CMakeLists.txt
new file mode 100644
index 000000000000..8c22c0ef647c
--- /dev/null
+++ b/net-mgmt/icinga2/files/patch-lib_icingadb_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- lib/icingadb/CMakeLists.txt.orig 2020-08-16 09:41:13 UTC
++++ lib/icingadb/CMakeLists.txt
+@@ -22,7 +22,7 @@ set_target_properties (
+ )
+
+ install_if_not_exists(
+- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/icingadb.conf
++ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/icingadb.conf.sample
+ ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ )
+
diff --git a/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt
index e19ba05602d9..c6c61430747c 100644
--- a/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/livestatus/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+--- lib/livestatus/CMakeLists.txt.orig 2020-08-03 13:43:47 UTC
+++ lib/livestatus/CMakeLists.txt
-@@ -71,7 +71,7 @@ set_target_properties (
+@@ -56,7 +56,7 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt
index 50e7bcc37910..b9460efc5c30 100644
--- a/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/notification/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+--- lib/notification/CMakeLists.txt.orig 2020-08-03 13:43:47 UTC
+++ lib/notification/CMakeLists.txt
-@@ -35,7 +35,7 @@ set_target_properties (
+@@ -20,7 +20,7 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt
index b42de356a14c..90ad02309c7a 100644
--- a/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/perfdata/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+--- lib/perfdata/CMakeLists.txt.orig 2020-08-03 13:43:47 UTC
+++ lib/perfdata/CMakeLists.txt
-@@ -45,32 +45,32 @@ set_target_properties (
+@@ -30,32 +30,32 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/pkg-plist b/net-mgmt/icinga2/pkg-plist
index c7fb12edb340..0dcfd3f3b547 100644
--- a/net-mgmt/icinga2/pkg-plist
+++ b/net-mgmt/icinga2/pkg-plist
@@ -18,6 +18,7 @@ etc/bash_completion.d/icinga2
@sample %%ETCDIR%%/features-available/elasticsearch.conf.sample
@sample %%ETCDIR%%/features-available/gelf.conf.sample
@sample %%ETCDIR%%/features-available/graphite.conf.sample
+@sample %%ETCDIR%%/features-available/icingadb.conf.sample
%%MYSQL%%@sample(%%ICINGA2USER%%,%%ICINGA2GROUP%%,0640) %%ETCDIR%%/features-available/ido-mysql.conf.sample
%%PGSQL%%@sample(%%ICINGA2USER%%,%%ICINGA2GROUP%%,0640) %%ETCDIR%%/features-available/ido-pgsql.conf.sample
@sample %%ETCDIR%%/features-available/influxdb.conf.sample
@@ -37,9 +38,9 @@ etc/bash_completion.d/icinga2
@sample %%ETCDIR%%/zones.conf.sample
%%ETCDIR%%/zones.d/README
%%MYSQL%%lib/icinga2/libmysql_shim.so
-%%MYSQL%%lib/icinga2/libmysql_shim.so.2.11.3
+%%MYSQL%%lib/icinga2/libmysql_shim.so.2.12.0
%%PGSQL%%lib/icinga2/libpgsql_shim.so
-%%PGSQL%%lib/icinga2/libpgsql_shim.so.2.11.3
+%%PGSQL%%lib/icinga2/libpgsql_shim.so.2.12.0
lib/icinga2/sbin/icinga2
libexec/nagios/check_nscp_api
man/man8/icinga2.8.gz
@@ -180,6 +181,8 @@ sbin/icinga2
%%DATADIR%%/include/windows-plugins
share/vim/vimfiles/ftdetect/icinga2.vim
share/vim/vimfiles/syntax/icinga2.vim
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) %%ETCDIR%%
+@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) %%ETCDIR%%/conf.d
@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) %%ETCDIR%%/features-enabled
@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/cache/icinga2
@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/lib/icinga2/api/log