aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/klg
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /net-mgmt/klg
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'net-mgmt/klg')
-rw-r--r--net-mgmt/klg/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/net-mgmt/klg/Makefile b/net-mgmt/klg/Makefile
index 70afd76c8ddf..fc29b0796e8e 100644
--- a/net-mgmt/klg/Makefile
+++ b/net-mgmt/klg/Makefile
@@ -11,7 +11,7 @@ COMMENT= PHP-based looking glass for Cisco, Juniper and Quagga/Zebra routers
LICENSE= BSD3CLAUSE
-USES= tar:txz
+USES= tar:txz php
USE_MYSQL= yes
USE_PHP= mysql pcre sockets xml
WANT_PHP_WEB= yes
@@ -33,10 +33,14 @@ OPTIONS_DEFAULT= SSH2
SSH2_DESC= SSH2 support for router access
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MSSH2}
-RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/ssh2.so:security/pecl-ssh2
+. if ${PHP_VER} < 70
+RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/ssh2.so:security/pecl-ssh2-0@${PHP_FLAVOR}
+. else
+RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/ssh2.so:security/pecl-ssh2@${PHP_FLAVOR}
+. endif
.endif
do-install:
@@ -47,4 +51,4 @@ do-install:
${CP} ${WRKSRC}/klg_config.php ${STAGEDIR}/${WWWDIR}/klg_config.php.sample
${CP} ${WRKSRC}/klg_template.html ${STAGEDIR}/${WWWDIR}/klg_template.html.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>