aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/mk-livestatus
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-06-07 06:07:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-06-07 06:07:04 +0000
commitaa504a5a1499f4914ece4598e75e33b28126bd67 (patch)
tree69d04e8155b3586dca7fc5fdeed75abeae85ce3a /net-mgmt/mk-livestatus
parent86e726453b249875aaffb20c9e88c579e05ce49e (diff)
downloadports-aa504a5a1499f4914ece4598e75e33b28126bd67.tar.gz
ports-aa504a5a1499f4914ece4598e75e33b28126bd67.zip
MKLivestatus is a very simple and smart Nagios eventbroker module.
Livestatus is concepted and tuned to reduce disk, memory and cpu loads caused by live-data processing on the Nagios system. Just as NDO, Livestatus makes use of the Nagios Event Broker API and loads a binary module into the Nagios process. But other than NDO, Livestatus does not actively write out data e.g. to the disk. Instead, it opens a socket for external applications to connect to and fetch the current status information from Nagios. WWW: http://mathias-kettner.de/checkmk_livestatus.html PR: ports/145449 Submitted by: Peter C. Lai <cowbert at gmail.com>
Notes
Notes: svn path=/head/; revision=255997
Diffstat (limited to 'net-mgmt/mk-livestatus')
-rw-r--r--net-mgmt/mk-livestatus/Makefile25
-rw-r--r--net-mgmt/mk-livestatus/distinfo3
-rw-r--r--net-mgmt/mk-livestatus/files/patch-src-Makefile.in12
-rw-r--r--net-mgmt/mk-livestatus/pkg-descr10
-rw-r--r--net-mgmt/mk-livestatus/pkg-message10
5 files changed, 60 insertions, 0 deletions
diff --git a/net-mgmt/mk-livestatus/Makefile b/net-mgmt/mk-livestatus/Makefile
new file mode 100644
index 000000000000..633cde4c0615
--- /dev/null
+++ b/net-mgmt/mk-livestatus/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mk-livestatus
+# Date created: 10 april 2010
+# Whom: Peter C. Lai <cowbert@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mk-livestatus
+PORTVERSION= 1.1.3
+CATEGORIES= net-mgmt
+MASTER_SITES= http://mathias-kettner.de/download/
+
+MAINTAINER= cowbert@gmail.com
+COMMENT= Mathias Kettner's mk-livestatus plugin for nagios
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+PLIST_FILES= lib/mk-livestatus/unixcat lib/mk-livestatus/livestatus.o
+PLIST_DIRS= lib/${PORTNAME}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/mk-livestatus/distinfo b/net-mgmt/mk-livestatus/distinfo
new file mode 100644
index 000000000000..0dfff44d2d07
--- /dev/null
+++ b/net-mgmt/mk-livestatus/distinfo
@@ -0,0 +1,3 @@
+MD5 (mk-livestatus-1.1.3.tar.gz) = df32a163a8663c1784afd1fa329732a0
+SHA256 (mk-livestatus-1.1.3.tar.gz) = 8882b52332038d081b52ef7d0d16084ee184e07f536f227cad7da2c266f8e0c9
+SIZE (mk-livestatus-1.1.3.tar.gz) = 318465
diff --git a/net-mgmt/mk-livestatus/files/patch-src-Makefile.in b/net-mgmt/mk-livestatus/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..5e92703665f9
--- /dev/null
+++ b/net-mgmt/mk-livestatus/files/patch-src-Makefile.in
@@ -0,0 +1,12 @@
+--- src/Makefile.in.orig 2010-04-06 12:02:18.000000000 +0000
++++ src/Makefile.in 2010-04-06 12:03:10.000000000 +0000
+@@ -227,7 +227,7 @@
+ am__quote = @am__quote@
+ am__tar = @am__tar@
+ am__untar = @am__untar@
+-bindir = @bindir@
++bindir = $(pkglibdir)
+ build_alias = @build_alias@
+ builddir = @builddir@
+ datadir = @datadir@
+
diff --git a/net-mgmt/mk-livestatus/pkg-descr b/net-mgmt/mk-livestatus/pkg-descr
new file mode 100644
index 000000000000..0bcd7d8d7b1d
--- /dev/null
+++ b/net-mgmt/mk-livestatus/pkg-descr
@@ -0,0 +1,10 @@
+MKLivestatus is a very simple and smart Nagios eventbroker module.
+Livestatus is concepted and tuned to reduce disk, memory and cpu loads
+caused by live-data processing on the Nagios system. Just as NDO,
+Livestatus makes use of the Nagios Event Broker API and loads a binary
+module into the Nagios process. But other than NDO, Livestatus does not
+actively write out data e.g. to the disk. Instead, it opens a socket for
+external applications to connect to and fetch the current status
+information from Nagios.
+
+WWW: http://mathias-kettner.de/checkmk_livestatus.html
diff --git a/net-mgmt/mk-livestatus/pkg-message b/net-mgmt/mk-livestatus/pkg-message
new file mode 100644
index 000000000000..e903833984bd
--- /dev/null
+++ b/net-mgmt/mk-livestatus/pkg-message
@@ -0,0 +1,10 @@
+Notes:
+
+ * See the documentation at http://mathias-kettner.de/checkmk_livestatus.html
+
+ * Requires that net-mgmt/nagios be built with WITH_EVENT_BROKER=yes or
+ livestatus.o will never be loaded...
+
+ * unixcat (for use with reading from the socket and/or inetd(8) support)
+ moved to $LOCALBASE/lib/mk-livestatus from $LOCALBASE/bin in
+ order to avoid a conflict with sysutils/ucspi-unix