aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-check_hdd_health/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-10 04:51:19 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-10 04:51:19 +0000
commitf66a9da0a53c93a12fb9d177b45f731f6ac93a7b (patch)
treec5f6e900af85d5e5e2087e24041abf73a707774b /net-mgmt/nagios-check_hdd_health/Makefile
parent584292a25ad2f0eb3a79ce50c847bb83a699ec25 (diff)
downloadports-f66a9da0a53c93a12fb9d177b45f731f6ac93a7b.tar.gz
ports-f66a9da0a53c93a12fb9d177b45f731f6ac93a7b.zip
check_hdd_health is a Nagios plug-in written in shell to check HDD health.
This script check HDD from S.M.A.R.T this values: - Spin Retry Count - Reallocated Sector Ct - Reallocated Event Count - Current Pending Sector - Offline Uncorrectable - Total health test PR: ports/152916 Submitted by: jamrich.majo at gmail.com
Notes
Notes: svn path=/head/; revision=265961
Diffstat (limited to 'net-mgmt/nagios-check_hdd_health/Makefile')
-rw-r--r--net-mgmt/nagios-check_hdd_health/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-mgmt/nagios-check_hdd_health/Makefile b/net-mgmt/nagios-check_hdd_health/Makefile
new file mode 100644
index 000000000000..5b3cb4482c28
--- /dev/null
+++ b/net-mgmt/nagios-check_hdd_health/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: nagios-check_hdd_health
+# Date created: 2010-12-02
+# Whom: jamrich.majo@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= nagios-check_hdd_health
+PORTVERSION= 1.0
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.bwelectronics.sk/jamrich/ports/
+
+MAINTAINER= jamrich.majo@gmail.com
+COMMENT= Nagios plug-in to check HDD health from S.M.A.R.T
+
+RUN_DEPENDS= smartmontools>=0:${PORTSDIR}/sysutils/smartmontools
+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/libexec/nagios
+ @${INSTALL_SCRIPT} ${.CURDIR}/src/check_hdd_health ${PREFIX}/libexec/nagios
+
+.include <bsd.port.mk>