aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-check_mysql_slave
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2024-04-06 23:32:10 +0000
committerFlorian Smeets <flo@FreeBSD.org>2024-04-07 09:36:13 +0000
commit92a030dffd4fd7c3f5abdd7a85b16086da294fe1 (patch)
treed83f5e611d5723c97792ba1aa7179471fd6c2e40 /net-mgmt/nagios-check_mysql_slave
parent04a6b84a1a7982cc3e6966d9a6be0b8e6f8648ee (diff)
downloadports-92a030dffd4fd7c3f5abdd7a85b16086da294fe1.tar.gz
ports-92a030dffd4fd7c3f5abdd7a85b16086da294fe1.zip
databases/p5-DBD-mysql: Fix for MariaDB users
Add a new variable DBD_MYSQL, use that in *_DEPENDS and add mysql to USES where required. DBD_MYSQL will automatically set the correct DBD dependency. In cd16748194e2 databases/p5-DBD-mysql was updated to 5.x, in 5.x the support for MariaDB was removed and only MySQL >= 8.0 is supported. In the 4.x releases MariaDB is still supported, according to upstream 4.x will still be supported for a while [1], so use that for now when we detect that MYSQL_FLAVOUR is set to mariadb. databases/p5-DBD-mysql4 was added in d95f49cb3b54. DBD:MariaDB would be another alternative, but migrating to it might need more analysis than just staying with the 4.x releases of p5-DBD-mysql. This thread on the amavis-users mailing list has a very good summary [2] from the author of DBD:MariaDB. This includes ideas and suggestions from vvd and mat. Thanks! [1] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=277889#c17 [2] https://lists.amavis.org/pipermail/amavis-users/2024-March/006823.html PR: 275100, 277889 Reviewed by: vvd, mat Fixes: cd16748194e2 Differential Revision: https://reviews.freebsd.org/D44662
Diffstat (limited to 'net-mgmt/nagios-check_mysql_slave')
-rw-r--r--net-mgmt/nagios-check_mysql_slave/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-mgmt/nagios-check_mysql_slave/Makefile b/net-mgmt/nagios-check_mysql_slave/Makefile
index d0103111d32e..74f559c7ee3c 100644
--- a/net-mgmt/nagios-check_mysql_slave/Makefile
+++ b/net-mgmt/nagios-check_mysql_slave/Makefile
@@ -1,6 +1,6 @@
PORTNAME= check_mysql_slave
PORTVERSION= 0.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://buhacoff.net/2009/products/check_mysql_slave/archive/ \
ZI
@@ -14,13 +14,13 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= p5-DBI>=1.60.7:databases/p5-DBI \
- p5-DBD-mysql>0:databases/p5-DBD-mysql
+ ${DBD_MYSQL}
PORTSCOUT= ignore:1
NO_BUILD= yes
NO_ARCH= yes
-USES= perl5 shebangfix
+USES= mysql perl5 shebangfix
SHEBANG_FILES= check_mysql_slave check_mysql_slave_epn
USE_PERL5= run
DOC_FILES= check_mysql_slave.html check_mysql_slave.pod