aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-12-21 11:12:54 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-12-21 11:12:54 +0000
commit25be77d69c78e8b0db53f9cc20e062d06d60f510 (patch)
tree6c22c510ea5f90f908f5ba56f121455486eb705d /net-mgmt/nagios-plugins
parent8d367325229095d906cb94e5736dfa77ce105566 (diff)
downloadports-25be77d69c78e8b0db53f9cc20e062d06d60f510.tar.gz
ports-25be77d69c78e8b0db53f9cc20e062d06d60f510.zip
Update to 2.1.4.
Reported by: portscout Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=429067
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile2
-rw-r--r--net-mgmt/nagios-plugins/distinfo6
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins_netutils.c46
3 files changed, 4 insertions, 50 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 2a9bc9d5d5f8..be2c06965873 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nagios-plugins
-PORTVERSION= 2.1.3
+PORTVERSION= 2.1.4
PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= net-mgmt
diff --git a/net-mgmt/nagios-plugins/distinfo b/net-mgmt/nagios-plugins/distinfo
index 48b8f3013f5c..402342be8488 100644
--- a/net-mgmt/nagios-plugins/distinfo
+++ b/net-mgmt/nagios-plugins/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1473952706
-SHA256 (nagios-plugins-2.1.3.tar.gz) = 46f57d4b2379f4255719be7605290ec90639b9f411be78091e8971cf54f15453
-SIZE (nagios-plugins-2.1.3.tar.gz) = 2720462
+TIMESTAMP = 1482317108
+SHA256 (nagios-plugins-2.1.4.tar.gz) = 4355b5daede0fa72bbb55d805d724dfa3d05e7f66592ad71b4e047c6d9cdd090
+SIZE (nagios-plugins-2.1.4.tar.gz) = 2721216
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins_netutils.c b/net-mgmt/nagios-plugins/files/patch-plugins_netutils.c
deleted file mode 100644
index b211deaf4615..000000000000
--- a/net-mgmt/nagios-plugins/files/patch-plugins_netutils.c
+++ /dev/null
@@ -1,46 +0,0 @@
---- plugins/netutils.c.orig 2016-08-01 16:27:46 UTC
-+++ plugins/netutils.c
-@@ -179,7 +179,7 @@ int
- np_net_connect (const char *host_name, int port, int *sd, int proto)
- {
- struct addrinfo hints;
-- struct addrinfo *res;
-+ struct addrinfo *res, *res0;
- struct sockaddr_un su;
- char port_str[6], host[MAX_HOST_ADDRESS_LENGTH];
- size_t len;
-@@ -206,7 +206,7 @@ np_net_connect (const char *host_name, i
- memcpy (host, host_name, len);
- host[len] = '\0';
- snprintf (port_str, sizeof (port_str), "%d", port);
-- result = getaddrinfo (host, port_str, &hints, &res);
-+ result = getaddrinfo (host, port_str, &hints, &res0);
-
- if (result != 0) {
- if (result == EAI_NONAME)
-@@ -215,6 +215,7 @@ np_net_connect (const char *host_name, i
- printf ("%s\n", gai_strerror (result));
- return STATE_UNKNOWN;
- }
-+ res = res0;
-
- while (res) {
- /* attempt to create a socket */
-@@ -222,7 +223,7 @@ np_net_connect (const char *host_name, i
-
- if (*sd < 0) {
- printf ("%s\n", _("Socket creation failed"));
-- freeaddrinfo (res);
-+ freeaddrinfo (res0);
- return STATE_UNKNOWN;
- }
-
-@@ -245,7 +246,7 @@ np_net_connect (const char *host_name, i
- close (*sd);
- res = res->ai_next;
- }
-- freeaddrinfo (res);
-+ freeaddrinfo (res0);
- }
- /* else the hostname is interpreted as a path to a unix socket */
- else {