aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagstamon/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-10-20 20:42:32 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-10-20 20:42:32 +0000
commit9ee95a91e9e2bcfb85e07a4c717b2f365b0725ce (patch)
treef30f843e1308391a44509c7ba743d2a3916aa9da /net-mgmt/nagstamon/Makefile
parent00494d72073290b7d9fc6d3c5c6e5a1f082099c5 (diff)
downloadports-9ee95a91e9e2bcfb85e07a4c717b2f365b0725ce.tar.gz
ports-9ee95a91e9e2bcfb85e07a4c717b2f365b0725ce.zip
- Update to 3.0.2
- Specify LICENSE_FILE
Notes
Notes: svn path=/head/; revision=482619
Diffstat (limited to 'net-mgmt/nagstamon/Makefile')
-rw-r--r--net-mgmt/nagstamon/Makefile27
1 files changed, 13 insertions, 14 deletions
diff --git a/net-mgmt/nagstamon/Makefile b/net-mgmt/nagstamon/Makefile
index 847ef4ea60c6..b041daa72826 100644
--- a/net-mgmt/nagstamon/Makefile
+++ b/net-mgmt/nagstamon/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= nagstamon
-PORTVERSION= 1.0.1
-PORTREVISION= 2
+PORTVERSION= 3.0.2
CATEGORIES= net-mgmt python
-MASTER_SITES= https://nagstamon.ifw-dresden.de/files/very_stable/ \
+MASTER_SITES= https://nagstamon.ifw-dresden.de/files/stable/ \
LOCAL/ehaupt
DISTNAME= Nagstamon-${PORTVERSION}
@@ -13,22 +12,22 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Nagios status monitor for your desktop
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= sox:audio/sox \
- ${PYTHON_PKGNAMEPREFIX}keyring>=1.3:security/py-keyring@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}keyring>0:security/py-keyring@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.2.1:www/py-beautifulsoup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}keyring>0:security/py-keyring@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>0:sysutils/py-psutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-kerberos>0:security/py-requests-kerberos@${PY_FLAVOR}
+
+USES= cpe python:3.6+ pyqt:5
+USE_PYTHON= autoplist distutils
+USE_PYQT= core_run dbus_run gui_run multimedia_run network_run sip_run \
+ svg_run widgets_run
-USES= cpe python:2.7
CPE_VENDOR= henri_wahl
-USE_PYTHON= distutils
-USE_GNOME= pygtk2 librsvg2
NO_ARCH= yes
WRKSRC= ${WRKDIR}/Nagstamon
-post-patch:
- @${REINPLACE_CMD} -e 's|share/\(man/man1\)|\1|' ${WRKSRC}/setup.py
-
-post-install:
- @${LN} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}.py ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-
.include <bsd.port.mk>