aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ndpmon/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-21 20:20:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-21 20:20:49 +0000
commit9a676e7dbc8cacac4713b7cc118f1beb8355e3b1 (patch)
tree14f9d8479131dce714a99c305b390e659d67cad0 /net-mgmt/ndpmon/Makefile
parent165ff1ee2477961520af726e15d3dc03779beb58 (diff)
downloadports-9a676e7dbc8cacac4713b7cc118f1beb8355e3b1.tar.gz
ports-9a676e7dbc8cacac4713b7cc118f1beb8355e3b1.zip
NDPMon is an equivalent of ArpWatch for IPv6.
NDPMon, Neighbor Discovery Protocol Monitor, is a tool working with ICMPv6 packets. NDPMon observes the local network to see if nodes using neighbor discovery messages behave properly. When it detects a suspicious Neighbor Discovery message, it notifies the administrator by writing in the syslog and in some cases by sending an email report. WWW: http://ndpmon.sourceforge.net Janos Mohacsi <janos.mohacsi@bsd.hu> PR: ports/106840 Submitted by: janos.mohacsi at bsd.hu
Notes
Notes: svn path=/head/; revision=180384
Diffstat (limited to 'net-mgmt/ndpmon/Makefile')
-rw-r--r--net-mgmt/ndpmon/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-mgmt/ndpmon/Makefile b/net-mgmt/ndpmon/Makefile
new file mode 100644
index 000000000000..844843701d4a
--- /dev/null
+++ b/net-mgmt/ndpmon/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: ndpmon
+# Date created: 2006-12-17
+# Whom: janos.mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= ndpmon
+PORTVERSION= 1.0
+CATEGORIES= net-mgmt ipv6
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${PORTNAME}-${PORTVERSION}b.tgz
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= On-link icmpv6 message monitoring and reporting daemon
+
+USE_GNOME= libxml2
+
+GNU_CONFIGURE= yes
+
+MAN8= ndpmon.8
+PORTDOCS= INSTALL README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/ndpmon.c \
+ ${WRKSRC}/ndpmon.8 \
+ ${WRKSRC}/config_ndpmon.xml \
+ ${WRKSRC}/neighbor_list.xml
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/ndpmon.8 ${PREFIX}/man/man8
+ ${INSTALL_PROGRAM} ${WRKSRC}/ndpmon ${PREFIX}/sbin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.dtd \
+ ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/config_ndpmon.xml ${PREFIX}/etc/config_ndpmon.xml-dist
+ ${MKDIR} ${PREFIX}/var
+ ${INSTALL_DATA} ${WRKSRC}/neighbor_list.xml ${PREFIX}/var/ndpmon_neighbor_list.xml
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>